Customizing SMF > Modifications and Packages

Pretty URLs 1.0 - Updated for SMF 2.0

<< < (1323/1434) > >>

mossite:
This pretty URL, i want to know a few big forum where it works perfectly. It seem not to be as good as it sounds

iwords:
On a brand new install of SMF 2.0.2 and Pretty URLs 1.0 with no other mods installed, everything works as it should, but the error log shows the following error whenever I view the Pretty URLs Settings page:-


--- Code: ---http://newforum/index.php?action=admin;area=pretty;sa=settings
8: Undefined index: pretty_bufferusecache
File: D:/Inetpub/wwwroot/newforum/Themes/default/languages/PrettyUrls.english.php (pretty_settings sub template - eval?)
Line: 84
--- End code ---

I can't see any obvious reason for the error, particularly as the text label the error refers to ("Use caching instead of database table for PrettyUrls") appears just fine on the settings page.

Any ideas what's causing this?

vbgamer45:
A missing language string? What language are you using?

iwords:
I'm using English.

The theme I'm using is a copy of Curve which doesn't have a language folder to start.  I tried copying the language folder from 'default' in case something was missing, but that doesn't solve it.

Seems strange that it complains about a missing string, but it still displays it OK on the page.

iwords:

--- Quote from: iwords on April 03, 2012, 05:57:15 AM ---On a brand new install of SMF 2.0.2 and Pretty URLs 1.0 with no other mods installed, everything works as it should, but the error log shows the following error whenever I view the Pretty URLs Settings page:-


--- Code: ---http://newforum/index.php?action=admin;area=pretty;sa=settings
8: Undefined index: pretty_bufferusecache
File: D:/Inetpub/wwwroot/newforum/Themes/default/languages/PrettyUrls.english.php (pretty_settings sub template - eval?)
Line: 84
--- End code ---

I can't see any obvious reason for the error, particularly as the text label the error refers to ("Use caching instead of database table for PrettyUrls") appears just fine on the settings page.

Any ideas what's causing this?

--- End quote ---

I've managed to resolve this myself.

This mod doesn't appear to have a default value for modSettings['pretty_bufferusecache'] and if one hasn't been explicitly set, it generates an error.

To fix, go to the Pretty URLs settings page, tick the box labelled 'Use caching instead of database table for PrettyUrls' and click 'Save Changes'.  Then untick the same box, and click Save Changes again.  Everything should work fine and the error should stop appearing.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version