SMF Support > Install and Upgrade Help

2.0.2 upgrade failed

(1/3) > >>

Krash:

Trynig to upgrade 1.1.12 -> 2.0.2, getting these errors at bottom of screen when upgrade.php loads:

Warning: Unknown: open(/var/chroot/home/content/p/r/o/domain/tmp/sess_be116a1407c6e484a5a6e23fe401f653, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

I had previously fixed these errors, which had disabled the 1.1.12 forum, using repair_settings.php.  Forum was running fine, but now upgrade.php won't run and is showing the same errors.  Ran repair_settings again, but settings are correct.

Restored 1.1.12 backup, works fine, but when I run repair_settings, I see the same errors at the bottom.  Settings are correct, errors don't show anywhere else in the forum.  The 2.0.2 upgrade backs up the first table, then quits.

NanoSector:
Hi Krash.,

Have you checked your php.ini, more specific the session.save_path setting? If you can't, can you get your host to check it?

Krash:

It's not my account, but I'll see if I can get to it.  The original problem was an old 1.1.12 forum that stopped working due to session verification errors.  I fixed it with repair_settings - queryless urls was unset, and database driven sessions was off.  I set them correctly, and the forum works fine, but upgrade won't run.  No one has any idea why the settings would have changed.  The forum was generating three errors at a rate of 50-60 per minute while in maintenance mode before I fixed it, and two of the errors were the same as I'm seeing at bottom of screen in upgrade.php and repair_settings.php.

Another odd thing, after a couple of failed upgrades, I looked at Settings.php, and $maintenance was set to '2'.  I had set it to '1' and confirmed maintenance mode before I started the upgrade.  There was also some garbage at the end of the file - thought I had saved it, but must have overwritten in the scramble to get 1.1.12 back up and running.

Krash:

Just ran phpinfo - session.save_path has no value.

NanoSector:

--- Quote from: Krash. on May 14, 2012, 02:04:45 PM ---
Just ran phpinfo - session.save_path has no value.



--- End quote ---
That needs to be set then :)

Navigation

[0] Message Index

[#] Next page

Go to full version