SMF Support > Install and Upgrade Help

"Openid_uri" error while converting from punBB

(1/1)

Ahmed_YJJ:
Hi,
I am trying to convert my forum from punBB 1.32 to SMF. I uploaded SFM 202 with Filezilla and installed it and it seems that it works.
I tried then to use "convert.php" to get my posts and other stuff, but using it I got:

Converting...
Making sure database structure is appropriate...Converting members...Field 'openid_uri' doesn't have a default value

What is this?

Ahmed_YJJ:
Well...

I found in mysql under smf_members that "openid_uri". And I see it has written under default "None".
Ok, that means I will change. But it do not allow!



--- Quote ---Error

SQL query:

ALTER TABLE `smf_members` CHANGE `openid_uri` `openid_uri` TEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL DEFAULT NULL

MySQL said: Documentation
#1067 - Invalid default value for 'openid_uri'
--- End quote ---

--- Quote ---
Error

SQL query:

ALTER TABLE `smf_members` CHANGE `openid_uri` `openid_uri` TEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL DEFAULT CURRENT_TIMESTAMP

MySQL said: Documentation
#1067 - Invalid default value for 'openid_uri'

--- End quote ---

Ahmed_YJJ:
Could not convert to simplemachines from punBB. Converted FluxBB.

Ahmed_YJJ:
I tried littlebit FluxBB, but did not like it. It is very the same punBB 1.2.
While it have more compact design, I needed not buggy subforums, too. But starting to install plugins, I understood that FluxBB ir not for me. They do not have now plugins, just unofficial modifications.
Almost every add-on (and fluxbb is very basic) needs modification.
I have done that when I had punBB 1.2, but anoying thing with modifications is that you can not really upgrade or modifications will be lost.
Also their subforums seems to have the same subforms bug as punBB, - it mess up sign of new posts which do not switch correctrly.
So I tried again smf installation.

I managed to solve this problem. You need to change at database (using phpmyadmin) default value to NULL. It will not accept this value unless you check under ir where is written Null.

So you overcome this error. I got the same error with "ignore_boards" and solved the same.
But then stucked with:
Making sure database structure is appropriate...Converting members...Data too long for column 'password_salt' at row 1


Tried to solve but failed. Then tried to install myBB, Fudforum, phpbb2 (with plan to convert it to phpbb3). I failed with different problemes. With phpbb2 I succeed but non-english letters where crippled. My forum is in utf-8, but I could not convert it correctly. For 5 days tried different things, but all failed. Lost 5 days on this! My forum members are angry...
I will return to punBB and wait for convertors.

Navigation

[0] Message Index

Go to full version