Customizing SMF > Modifications and Packages

httpBL

<< < (217/233) > >>

daviloco:
Hello snoopy_virtual. i have this errors in my forum...and your mod give me this errors..


--- Code: ---


Notice: Undefined index: bookmark in /home/tuxpelic/public_html/Sources/Subs.php on line 4376

Warning: Cannot modify header information - headers already sent by (output started at /home/tuxpelic/public_html/Sources/Subs-adkblocks.php:1) in /home/tuxpelic/public_html/Sources/httpBL_Subs.php on line 128

Warning: Cannot modify header information - headers already sent by (output started at /home/tuxpelic/public_html/Sources/Subs-adkblocks.php:1) in /home/tuxpelic/public_html/warning.php on line 218



--- End code ---

Could you be checked?


snoopy_virtual:
Those warnings you get there are saying that mod httpBL cannot work properly because you have 2 errors:

- An error inside the file Subs.php (some index called bookmark in line 4376 not defined properly)

- And another error inside the file Subs-adkblocks.php (the file, at line one is sending the headers before it's supposed to do it)

I don't know the file Subs-adkblocks.php and I know that inside the original file Subs.php there is no index called bookmark so I suppose both must be from some other mods you are using that have not been done properly.

Send me both files so I can check them and correct those errors for you.

====================

By the way, if you prefer talking in Spanish, check this other thread: Ayuda con el MOD httpBL en espaƱol

Oldcrow:
Snoopy it has been a few day now with no errors, now all of a sudden I started getting these errors, and quite a few of them.


See below..



--- Quote ---http://www.theover50goldengroup.com/smf/index.php?action=login2
8: Undefined variable: ip
File: /home/theoverg/public_html/smf/Sources/httpBL_Subs.php
Line: 519




http://www.theover50goldengroup.com/smf/index.php?action=login2
2: Missing argument 1 for httpBL_look_for_empty_ip(), called in /home/theoverg/public_html/smf/Sources/httpBL_Subs.php on line 680 and defined
File: /home/theoverg/public_html/smf/Sources/httpBL_Subs.php
Line: 517
--- End quote ---


Any thoughts or ideas on this, corrections...


Ron..

snoopy_virtual:
I suppose you didn't correct this bug I told you last week:

http://www.simplemachines.org/community/index.php?topic=366399.msg3327443#msg3327443

Oldcrow:

--- Quote from: snoopy_virtual on May 07, 2012, 05:58:28 PM ---I suppose you didn't correct this bug I told you last week:

http://www.simplemachines.org/community/index.php?topic=366399.msg3327443#msg3327443

--- End quote ---


Yes I did make the change, I posted the same time I did the change..below is like I did it..



   // If $ip is empty let's try to find it with more methods
   if ($ip == '')
      $ip = httpBL_look_for_empty_ip($ip);
   
   $values['ip'] = $ip;
   if ($values['ip'] == '')

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version