Advertisement:
NameCheap

Author Topic: Fatal error: Maximum execution time of 30 seconds exceeded  (Read 9397 times)

Offline ne.miguelito

  • Jr. Member
  • **
  • Posts: 355
Fatal error: Maximum execution time of 30 seconds exceeded
« on: June 27, 2008, 11:34:20 PM »
Hello,

When I try to send PM's for all my members (Approx. 4600 members) appears this:

Quote
Fatal error: Maximum execution time of 30 seconds exceeded in /home/nemigue/public_html/Sources/Subs-Post.php on line 552


in that line has this:

Quote
   $to_array = array_diff($to_array, array($to_address));


some suggestion?

Offline Jade Elizabeth

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,613
  • Gender: Female
  • Keep your enemies close and your friends closer ;)
    • @aCreativeBurrow on Twitter
    • Creative Burrow
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #1 on: July 02, 2008, 01:24:20 AM »
Yeah, contact your host about increasing the php "memory_limit"

I had to, it was at 8MB, I needed 16MB :)..He told me I could upload my own, I did...no more errors!!
Once proud Documentation Writer and Help Squad Leader
Please Help My Mum! | Need help? See my $5 Fiverr Gigs!


Need More Posts? I TRIPLED my sites activity in 10 days! YOU CAN TOO!

Quote
[12:13am] <%Jade> link me
[12:14am] <+orstio> <a href="Jade">link</a>


Offline ne.miguelito

  • Jr. Member
  • **
  • Posts: 355
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #2 on: July 02, 2008, 08:23:40 AM »
In my host:

"memory_limit"   32MB

Offline Jade Elizabeth

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,613
  • Gender: Female
  • Keep your enemies close and your friends closer ;)
    • @aCreativeBurrow on Twitter
    • Creative Burrow
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #3 on: July 02, 2008, 09:11:34 AM »
Wow really?

How big is your forum?
Once proud Documentation Writer and Help Squad Leader
Please Help My Mum! | Need help? See my $5 Fiverr Gigs!


Need More Posts? I TRIPLED my sites activity in 10 days! YOU CAN TOO!

Quote
[12:13am] <%Jade> link me
[12:14am] <+orstio> <a href="Jade">link</a>


Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,656
  • Gender: Male
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #4 on: July 02, 2008, 09:14:55 AM »
The memory limit isn't the issue here it is the maximum execution time ;)

Try opening index.php and adding the following after <?php

set_time_limit(0);

If that doesn't work you host is enforcing the time limit and you'll have to contact them and request they increase it :)
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline Jade Elizabeth

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,613
  • Gender: Female
  • Keep your enemies close and your friends closer ;)
    • @aCreativeBurrow on Twitter
    • Creative Burrow
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #5 on: July 02, 2008, 09:38:17 AM »
The memory limit isn't the issue here it is the maximum execution time ;)

Try opening index.php and adding the following after <?php

set_time_limit(0);

If that doesn't work you host is enforcing the time limit and you'll have to contact them and request they increase it :)

Wow, I dunno who told me it was memory_limit then..though that fixed it on my forum. Thanks H.
« Last Edit: July 04, 2008, 03:31:42 PM by Alundra »
Once proud Documentation Writer and Help Squad Leader
Please Help My Mum! | Need help? See my $5 Fiverr Gigs!


Need More Posts? I TRIPLED my sites activity in 10 days! YOU CAN TOO!

Quote
[12:13am] <%Jade> link me
[12:14am] <+orstio> <a href="Jade">link</a>


Offline ne.miguelito

  • Jr. Member
  • **
  • Posts: 355
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #6 on: July 04, 2008, 03:15:19 PM »
The memory limit isn't the issue here it is the maximum execution time ;)

Try opening index.php and adding the following after <?php

set_time_limit(0);

If that doesn't work you host is enforcing the time limit and you'll have to contact them and request they increase it :)

the index.php to alter it is what is in the root of the forum?

Offline greyknight17

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 14,890
  • Gender: Male
    • Kevin's Resource Center
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #7 on: July 04, 2008, 09:00:21 PM »
Yes, open it up and add that single line after <?php

Offline Realinfo

  • Full Member
  • ***
  • Posts: 617
    • Real Info
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #8 on: July 24, 2008, 04:17:20 AM »
Sir............... I added what u said after ............... but this show again an error and my My forum not get opned. then i deleted that.....and then my forum come to normal.................. <?php this i found just a start................. is it that............. or where I'm wrong............... thanks.....................

Offline Jade Elizabeth

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,613
  • Gender: Female
  • Keep your enemies close and your friends closer ;)
    • @aCreativeBurrow on Twitter
    • Creative Burrow
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #9 on: July 24, 2008, 12:23:57 PM »
Sir............... I added what u said after ............... but this show again an error and my My forum not get opned. then i deleted that.....and then my forum come to normal.................. <?php this i found just a start................. is it that............. or where I'm wrong............... thanks.....................

Code: [Select]
<?php
set_time_limit
(0);

That's what it should look like :)
Once proud Documentation Writer and Help Squad Leader
Please Help My Mum! | Need help? See my $5 Fiverr Gigs!


Need More Posts? I TRIPLED my sites activity in 10 days! YOU CAN TOO!

Quote
[12:13am] <%Jade> link me
[12:14am] <+orstio> <a href="Jade">link</a>


Offline Realinfo

  • Full Member
  • ***
  • Posts: 617
    • Real Info
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #10 on: August 25, 2008, 08:16:35 AM »
sir.............this  problem is coming again and again............ so tell me clearly and simply................ INDEX.PHP of FTP has to change........... in this way u told...........

Offline Jade Elizabeth

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,613
  • Gender: Female
  • Keep your enemies close and your friends closer ;)
    • @aCreativeBurrow on Twitter
    • Creative Burrow
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #11 on: August 25, 2008, 08:43:30 AM »
Please copy and paste the first 3 lines of your index.php. This is in the root folder of the forum :).
Once proud Documentation Writer and Help Squad Leader
Please Help My Mum! | Need help? See my $5 Fiverr Gigs!


Need More Posts? I TRIPLED my sites activity in 10 days! YOU CAN TOO!

Quote
[12:13am] <%Jade> link me
[12:14am] <+orstio> <a href="Jade">link</a>


Offline Realinfo

  • Full Member
  • ***
  • Posts: 617
    • Real Info
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #12 on: August 27, 2008, 02:32:52 AM »
<?php
/**********************************************************************************
* index.php                                                                       *
***********************************************************************************
* SMF: Simple Machines Forum                                                      *
* Open-Source Project Inspired by Zef Hemel (zef@zefhemel.com)                    *
* =============================================================================== *
* Software Version:           SMF 1.1.5                                           *
* Software by:                Simple Machines (http://www.simplemachines.org)     *
* Copyright 2006-2007 by:     Simple Machines LLC (http://www.simplemachines.org) *




Sir these are few first lines of My Index.php

Tell what i have to do?????????

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,656
  • Gender: Male
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #13 on: August 27, 2008, 08:45:36 AM »
Please attach your index.php here :)
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline Realinfo

  • Full Member
  • ***
  • Posts: 617
    • Real Info
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #14 on: August 27, 2008, 10:41:44 AM »
sir......... are u sure I can attach index.php here........ I mean Isn't contain any password or anything by which anyone can hack ............. as I don't know much.............


Sir I attach Index file that i got when i download SMF......... so make change in it and then i will get............

Offline N3RVE

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,906
  • Gender: Male
    • N3RVE.COM
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #15 on: August 27, 2008, 11:09:43 AM »
sir......... are u sure I can attach index.php here........ I mean Isn't contain any password or anything by which anyone can hack ............. as I don't know much.............
SMF doesn't store confidential information like passwords, etc in source files - they are in the database.
The files you should not make public are Settings.php and Settings_bak.php.
Use the attached ;)

-[n3rve]
Ralph "[n3rve]" Otowo
Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote
“Somewhere, something incredible is waiting to be known.” - Carl Sagan

Offline Realinfo

  • Full Member
  • ***
  • Posts: 617
    • Real Info
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #16 on: August 27, 2008, 10:09:36 PM »
Thanks.............. That was all I want.......... now see if that no error will come