Advertisement:

Author Topic: 2 Problems, need help  (Read 9913 times)

Offline luisantunes

  • Semi-Newbie
  • *
  • Posts: 16
2 Problems, need help
« on: December 20, 2011, 05:16:40 PM »
Hi guys,

I have two problems perhaps small problems but not know solve them.

1st
how do I replace my database backup (SMF 1.1.15) if I delete it

2st
I am trying to install another Forum (SMF 2.0.1) but it gives me the following error :

Critical Error!
The version of your database server is very old, and does not meet SMF's minimum requirements.
Please ask your host to either upgrade it or supply a new one, and if they won't, please try a different host.

I already contacted the help desk of my domain and they say the MySQL database server version used is 5.0.67
sorry for the noob questions :(

Thank you for help
greetings all

Online Oldiesmann

  • Lead Developer
  • SMF Super Hero
  • *
  • Posts: 24,071
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • http://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: 2 Problems, need help
« Reply #1 on: December 21, 2011, 12:48:29 PM »
1. If you deleted the backup, you can't replace it. If you mean restoring the backup, see How do I restore a database backup?.

2. Put this code in a file, upload it to your server and run it. What does it show as the client version?

Code: [Select]
<?php
echo 'MySQL client version: ' mysql_get_client_info();
?>

Offline luisantunes

  • Semi-Newbie
  • *
  • Posts: 16
Re: 2 Problems, need help
« Reply #2 on: December 21, 2011, 01:08:53 PM »
Hi,

It show this:

MySQL client version: 3.23.49

Online Oldiesmann

  • Lead Developer
  • SMF Super Hero
  • *
  • Posts: 24,071
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • http://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: 2 Problems, need help
« Reply #3 on: December 21, 2011, 04:58:57 PM »
That's your problem. Tell your host to upgrade the client libraries.

I'm actually surprised MySQL is even working with such ancient client libraries.

Offline luisantunes

  • Semi-Newbie
  • *
  • Posts: 16
Re: 2 Problems, need help
« Reply #4 on: December 22, 2011, 02:12:11 PM »
Hi,

Thank you for your support.
I already contacted my host and I await a response from them.

In my first problem is that the database disappeared I have not deleted... nobody knows what happened only I have access to Admin control panel

Offline luisantunes

  • Semi-Newbie
  • *
  • Posts: 16
Re: 2 Problems, need help
« Reply #5 on: December 22, 2011, 05:54:57 PM »

HI,
this was the answer I had from my host:


[root@leaf3 mess]# mysql --version
mysql Ver 5.0.67 Distrib 14.12, for redhat-linux-gnu (i686) using readline 5.1

Here we would like to assure many of our other customer who hosted in same server using same version of MySQL which required by application in current market. Also all of this application supported by MySQL version in our server.

Online Oldiesmann

  • Lead Developer
  • SMF Super Hero
  • *
  • Posts: 24,071
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • http://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: 2 Problems, need help
« Reply #6 on: December 23, 2011, 01:53:39 PM »
It doesn't matter what version MySQL is in this case. The client libraries (the files used by PHP and other languages to interact with MySQL) are out of date. If your host doesn't know the difference between the two, then you should find a better host.

Offline luisantunes

  • Semi-Newbie
  • *
  • Posts: 16
Re: 2 Problems, need help
« Reply #7 on: December 27, 2011, 08:04:41 PM »
Hello,

Oldiesmann many thanks for your help.
My host did update the libraries and now it works fine (2.0).
I am grateful for the help

Best regards,
Luis Antunes