SMF Support > SMF 2.0.x Support

updated to 2.02 and getting this error...

(1/12) > >>

DarkAngel612:
PHP Warning:  mysql_real_escape_string() expects parameter 2 to be resource, boolean given in /home/xxxx/public_html/xxxxx/Sources/Subs-Db-mysql.php on line 132

I found the other threads from last year but was wondering if there is something new to do or an idea what is happening?

I am also showing this error to be in effect since [09-Mar-2012 08:32:09]

The above message appears over and over with [21-Mar-2012 22:40:11] appearing to be the last entry---have disabled the sites error log to see if a new one generates again with this error and as for admin/error log the only entries are for an undefined error:

http://thefantasiesattic.net/attic/index.php?board=350.0;nowap

8: Undefined index: costa_topico_normal
File: Themes/chemical/MessageIndex.template.php
Line: 237

8: Undefined index: costa_topico_fixo
File: Themes/chemical/MessageIndex.template.php
Line: 226

which the other forums (1 test 1 live) that have this theme do not have this error or the other one, just our main forum.

Apache version      2.2.17
PHP version     5.2.17
MySQL version     5.0.95-community
Architecture     x86_64
Operating system     linux
Perl version     5.8.8
Kernel version     2.6.18-028stab089.1


SMF 2.02

Mods:

Kermit:
Those undefined index errors have something to do with one of your installed modifications,to be more specific

http://custom.simplemachines.org/mods/index.php?action=parse;mod=3300;attach=195226;smf_version=2.0.2

you can check the coding,apparently the mod was not completely uninstalled,so you can remove the rest code manually

and regarding the first error,i don't know how to fix it

DarkAngel612:

--- Quote from: Kermit on March 22, 2012, 04:50:59 AM ---Those undefined index errors have something to do with one of your installed modifications,to be more specific

http://custom.simplemachines.org/mods/index.php?action=parse;mod=3300;attach=195226;smf_version=2.0.2

you can check the coding,apparently the mod was not completely uninstalled,so you can remove the rest code manually

and regarding the first error,i don't know how to fix it

--- End quote ---

I am so sorry I should have been more specific...that 2nd error is not from a mod, it is from something that is not set in the language file for the Chemical theme.

But thanks anyway I will need to contact the creator -- runic -- for an answer


however, I am going to check the coding too even though I do not have that particular mod installed.

Kermit:
Nope,those strings have nothing to do with a theme,they belong to that mod which i have linked,just you need to check the codes manually

DarkAngel612:

--- Quote from: Kermit on March 22, 2012, 07:22:11 AM ---Nope,those strings have nothing to do with a theme,they belong to that mod which i have linked,just you need to check the codes manually

--- End quote ---

ok will do even if it never has been installed...lol

Navigation

[0] Message Index

[#] Next page

Go to full version