Advertisement:

Author Topic: Need to get Modification Settings back  (Read 2579 times)

Offline BinkyM

  • Semi-Newbie
  • *
  • Posts: 49
  • Gender: Female
  • I've been running forums since 1987 (not a typo!).
    • @lilMMAsweetie on Twitter
    • Snarkish
Need to get Modification Settings back
« on: May 06, 2012, 10:19:34 AM »
Hi, SMF peeps:

I feel sheepish asking this. I installed a skanky mod and it zotzed my Modification Settings. When I go to Modification Settings, I get a blank page. Likewise my Feature Settings. I'm just sick about this. I uninstalled the mod, and even went in by hand to make sure it's gone, but I'm still missing those two settings pages. Since the URL for the page contains "action=admin;area=modsettings" I thought I'd do a search for "modsettings" in my files, see what I could find, but that was a massive disappointment: I found 3178 mentions of $modsettings in 138 files. (Popular variable!) That's no way to fix it. I'm hoping that someone can tell me, "Bink, replace this source file and that source file and you'll be back in business again." My fingers are crossed that it's that easy. I'm pretty sure you'll say, "Bink, re-install," but I'm holding out hope that just one file was florfed and that it won't hurt as much as yanking off a BandAid.

My fingers are crossed. Thanks for any help and support you have to offer. I'm epically appreciative for anything you have.

Binky

Offline ApplianceJunk

  • SMF Hero
  • ******
  • Posts: 3,410
    • ApplianceJunk.com
Re: Need to get Modification Settings back
« Reply #1 on: May 06, 2012, 10:56:41 AM »
Hi Binky

What mod was it that you installed?

Quote
I've been running forums since 1987 (not a typo!).

Wow, that's amazing!

Seen you have been a member here for sometime now too. What's with the low post count? ;)

I bet a few of use could learn a thing or two about running a forum from you.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 63,484
Re: Need to get Modification Settings back
« Reply #2 on: May 06, 2012, 11:02:13 AM »
Are there any errors in the error log?
And his eyes have all the seeming of a demon's that is dreaming,
And the lamp-light o'er him streaming throws his shadow on the floor

Offline BinkyM

  • Semi-Newbie
  • *
  • Posts: 49
  • Gender: Female
  • I've been running forums since 1987 (not a typo!).
    • @lilMMAsweetie on Twitter
    • Snarkish
Re: Need to get Modification Settings back
« Reply #3 on: May 06, 2012, 11:02:36 AM »
Hi, Junk:

It was Social Buttons by SMFSimple.com that pooped all over everything.

Quote
Seen you have been a member here for sometime now too. What's with the low post count?

I posted six years ago asking about converting my forums from Ikonboard, but back then, the only was to do it was with a PC, which I don't have, so I slunk away. Nowadays, the conversion process doesn't require a PC, so I'm gonna take the leap! Yay, me! I've been busy building myself a theme and adding mods and getting everything >just so< so that I'll be ready to take the plunge and join the 21st century and have (blush) FEATURES! Woohoo!

Offline BinkyM

  • Semi-Newbie
  • *
  • Posts: 49
  • Gender: Female
  • I've been running forums since 1987 (not a typo!).
    • @lilMMAsweetie on Twitter
    • Snarkish
Re: Need to get Modification Settings back
« Reply #4 on: May 06, 2012, 11:13:45 AM »
That's an excellent question, Arantor, and one I can't answer because when I sat down today, I had 333 errors so I deleted 'em all, thinking I'd start fresh, and I don't currently have any errors. (My life's motto: "It seemed like a good idea at the time.") I'll keep an eye on it, see whether anything interesting shows up.

(Oh, why me, ffs?)

Offline K@

  • Lead Support Specialist
  • SMF Master
  • *
  • Posts: 47,556
  • Gender: Male
  • Yum!
Re: Need to get Modification Settings back
« Reply #5 on: May 06, 2012, 05:09:37 PM »
This help?

http://www.simplemachines.org/community/index.php?topic=400356.0

I bet a few of use could learn a thing or two about running a forum from you.

Not about backing-up before installing mods, it would seem.

Offline BinkyM

  • Semi-Newbie
  • *
  • Posts: 49
  • Gender: Female
  • I've been running forums since 1987 (not a typo!).
    • @lilMMAsweetie on Twitter
    • Snarkish
Re: Need to get Modification Settings back
« Reply #6 on: May 06, 2012, 05:25:42 PM »
K@:

It *would* help, 'cept I don't know what file(s) it is I need to replace. I was hoping someone could tell me.

Quote
Not about backing-up before installing mods, it would seem

Snort! Thing is I haven't anything to back up but about 24 messages and my theme. (My theme IS okay, right? It's separate from the code files, isn't it?) (PLEASE say "yes," or I'm going outside and finding a pit and siccing him on you!) (Aw, I'm both a cat *and* a pup person, so my threat is hollow. You're safe.) (Here: have some fish guts.)

I'm just getting the forum ready before I transfer over my messages from an Ikonboard forum and bring the members in, so it's in testing right now. I haven't been worried enough to back up. All I wanna do is to find out what file(s) handle the Modification and Feature Settings so I can replace it/them and go on my merry way. And sure enough, that thread you pointed me to says to do zactly that. I just need to know the right file(s), that's all.

C'mere so I can scratch your ears.

Offline K@

  • Lead Support Specialist
  • SMF Master
  • *
  • Posts: 47,556
  • Gender: Male
  • Yum!
Re: Need to get Modification Settings back
« Reply #7 on: May 07, 2012, 05:47:14 AM »
What that process in the thread I pointed you to does, is replace all the files back to as everything was, before you installed the mod. So, whichever file it was, it'll be put back, as-was.

So, everything will be as it was, before the mod was installed and fooked everything up.

C'mere so I can scratch your ears.


Offline BinkyM

  • Semi-Newbie
  • *
  • Posts: 49
  • Gender: Female
  • I've been running forums since 1987 (not a typo!).
    • @lilMMAsweetie on Twitter
    • Snarkish
Re: Need to get Modification Settings back
« Reply #8 on: May 07, 2012, 10:50:40 AM »
But see, K@, that woulda worked had I not installed another mod after the dumb Social Buttons mod. But I did. A few. I didn't realize what, exactly, had happened. In my zeal to get things going, I think I thought it was just a system burp, so I kept right on plugging along, thinking my Modification Settings would come back next time I looked. (I hadn't needed them up until that point.) I forgot about 'em until I went to my Feature Settings at some point and then discovered that they, too, were blank. It was then that I twigged to something a little more serious being wrong.

I think I'm slowly arriving at the fact that I need a re-install, and with it, the fact that the majority of my work has been on the stylesheets and the graphics. Okay, and the Package Manager doesn't work nice and neatly, so I either hafta download everything and then upload it, or else do it by hand. Well, that's not so awful; I think I have about nine packages installed, roughly. I'm just sad that the mods aren't more thoroughly tested; I'da thought that the community woulda thumped the snot out of all of them so that things like this don't happen. Then again, I guess any given mod isn't used by *everyone*, so bad stuff doesn't turn up the way I'd hope.

Nertz. I guess I'd better get everything I think I might lik to have in the future installed NOW before the membership arrives, because I don't want the database to have more than 100K of records in it when I go and cremate it with mods, huh?

Binky

Offline BinkyM

  • Semi-Newbie
  • *
  • Posts: 49
  • Gender: Female
  • I've been running forums since 1987 (not a typo!).
    • @lilMMAsweetie on Twitter
    • Snarkish
Re: Need to get Modification Settings back
« Reply #9 on: May 07, 2012, 11:08:24 AM »
Are there any errors in the error log?

Kay; I now have 57 errors in my error log, so I can answer this question: every single one of those errors is in /Sources/Subs-Post.php, which "contains those functions pertaining to posting, and other such operations, including sending emails, ims, blocking spam, preparsing posts, spell checking, and the post box." They all seem to be related to eNotify and avatar, both of which are mods I've installed. (The former lets one know that there are PMs or replies waiting; the latter forces a registrant to pick an avatar, something a bot will usually fail to do.)

Does this tell you anything other than that there are most likely problems with these mods? My forum isn't live yet. I'm gonna go turn these mods off for now, see whether that stops the errors.

Binky

Offline K@

  • Lead Support Specialist
  • SMF Master
  • *
  • Posts: 47,556
  • Gender: Male
  • Yum!
Re: Need to get Modification Settings back
« Reply #10 on: May 07, 2012, 12:47:59 PM »
No need to fully reinstall, if you want to take that route.

Just get the files from the large upgrade and upload them all (Except upgrade.php), overwriting what you have and you'll be back in the virgin state, as it were, with all posts and members intact.

The mods'll still be in Package Manager. They'll just need to be reapplied (Or not).

Offline BinkyM

  • Semi-Newbie
  • *
  • Posts: 49
  • Gender: Female
  • I've been running forums since 1987 (not a typo!).
    • @lilMMAsweetie on Twitter
    • Snarkish
Re: Need to get Modification Settings back
« Reply #11 on: May 08, 2012, 12:06:36 PM »
Wow, K@. That was in the thread to which you pointed me, and I missed it? Am I a bonehead or what? (No need to answer that; I know what the answer is. (sigh))

But now that you bring it up, it suddenly dawns on me that I have TWO backups and I didn't even realize it because I didn't think of them that way: twice I've dragged my entire install off my server to make grepping quicker. I've got two copies here, one from back in the beginning, and a recent one (which is a ruined one). I just didn't think of them as backups 'cause they're not tarballs. (banging head on desk) Whatta dipstick. (sob!) I'm a lucky dipstick, though, huh?

I, Binky Melnik, do solemnly swear henceforth to read the first three pages of threads in their *entirety* when people point me to them to be helpful. I'll pay close attention to *everything* in the thread so I don't miss anything important.

I'm sorry I wasn't thorough and I appreciate your help a lot. I'm sorry I made you post a second pointer because I'm a big, hopeless dope. Thanks *ever* so much!

Binky

Offline BinkyM

  • Semi-Newbie
  • *
  • Posts: 49
  • Gender: Female
  • I've been running forums since 1987 (not a typo!).
    • @lilMMAsweetie on Twitter
    • Snarkish
Re: Need to get Modification Settings back
« Reply #12 on: May 08, 2012, 12:36:09 PM »
Holy smokies, K@! I'm looking at my Modifications Settings page right this minute! I've already seen my Feature Settings page! I did as you suggested, grabbed the Large Upgrade and pulled out any non-pertinent directories (Attachments, Smileys, Avatars, and so on), and then uploaded the whole wad. Now I'm gonna drag it all off the server again before I bollix it up. Wow! Thanks sooo much! This is just *so* cool! I am a happy kid! Yay, me! And Yay, K@! If I could give you +1, I'd do it! In lieu of that: (scratches the inside of your thigh)

Offline K@

  • Lead Support Specialist
  • SMF Master
  • *
  • Posts: 47,556
  • Gender: Male
  • Yum!
Re: Need to get Modification Settings back
« Reply #13 on: May 08, 2012, 02:18:29 PM »
All I can say, to that, is...



Plus, just to offend everyone...


Offline BinkyM

  • Semi-Newbie
  • *
  • Posts: 49
  • Gender: Female
  • I've been running forums since 1987 (not a typo!).
    • @lilMMAsweetie on Twitter
    • Snarkish
Re: Need to get Modification Settings back
« Reply #14 on: May 08, 2012, 03:53:59 PM »
Niiice rack! (At first I thought they were nuts, and I was confused!)

Offline K@

  • Lead Support Specialist
  • SMF Master
  • *
  • Posts: 47,556
  • Gender: Male
  • Yum!
Re: Need to get Modification Settings back
« Reply #15 on: May 09, 2012, 05:23:45 AM »
I'm nuts.

I suspect that you may have noticed...