Simple Machines > News and Updates

PHP security warning

(1/5) > >>

Norv:
All,

These days a serious security vulnerability has been discovered in PHP, all versions since 8 years ago. The vulnerability has nothing to do with SMF and cannot be addressed by us, because the forum code doesn't even get to be executed. It can only be patched or mitigated at server level. However, we are bringing it to your attention because it's critical (remote code execution), for you to make sure to test if your site is affected (hopefully not), and if necessary, notify your host and try to mitigate it.

The issue is reported on a very particular configuration, PHP ran as CGI script (not FCGI), on Apache, rather unusual these days. If your host is running it, however, then it is possible that arbitrary code can be executed, compromising your sites. This does NOT apply to the most common PHP setups these days (PHP ran by mod_php, or fast-cgi are NOT affected), so it is possible you may not be affected. We would advise however, to test if your site is vulnerable, and take measures in that case.

How to test if your sites are vulnerable: (please see this link)
Add ?-s at the end of any URL of a PHP script, like: yoursite/index.php?-s
If you see PHP code, your PHP is vulnerable.
If you see your page normally, your site is not affected.

How to mitigate the issue:
If your site is affected, and you may have mod_rewrite available and enabled in Apache, then please add to .htaccess the rewrite rule:

--- Code: ---RewriteEngine on

RewriteCond %{QUERY_STRING} ^[^=]*$
RewriteCond %{QUERY_STRING} %2d|\- [NC]
RewriteRule .? - [F,L]

--- End code ---

Also, if you can verify the issue is happening for your site, please do notify your host immediately, including a link to the issue.
They can make sure to either (or all): change their configuration, apply the .htaccess patch to all sites, and, when the PHP issue will be fixed, to upgrade their PHP installation.


Please find here the current (already outdated) official report from PHP:
http://www.php.net/archive/2012.php#id2012-05-03-1
Note in addition, that the new versions released at the time of this post are still vulnerable, the release of PHP 5.3.12 and 5.4.2 has been rushed by the accidental disclosure of the bug report they were working on, and the patch is still faulty. The code committed to Github for PHP 5.3.12 is clearly buggy, and I'd expect PHP to release another patch anytime now. When they do, it is highly recommended that servers running this kind of configuration upgrade their PHP or change this configuration altogether.

Looking:
Thanks for informing us.

Kryzen:
Thank you for the notice :)

tumbleweed:
If you are running a cPanel server this issue was fixed more then two years ago:
http://forums.cpanel.net/f185/php-5-3-12-security-vulnerability-patch-275011.html

NanoSector:
Seems like Facebook may have some issues sooner or later..
Thanks for informing.

Navigation

[0] Message Index

[#] Next page

Go to full version