Advertisement:

Author Topic: [SMF 2.x] Messages qui ne s'affichent pas dans certaines langues  (Read 2285 times)

Offline DeathSign

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 845
  • Gender: Male
  • Sys/Net Admin
Après la résolution d'un problème à la base très étrange, un petit résumé.

Symptômes, en choisissant certaines langues dans votre profil :
- Certains messages disparaissent complètement alors que certains s'affichent
- Ailleurs sur le forum, des caractères accentués passent mal (quand ils s'affichent)

Explication possible :
- L'encodage des fichiers de langues utilisé est incorrect, c'est-à-dire qu'il ne concorde pas avec celle de la base de données.

Question à se poser : Avez-vous installé des fichiers de langue utf-8 à la place des "normaux" (ISO-8859-1) ?

Vérifications :
- Dans PHPMyadmin, sélectionnez votre base de donnée et dans l'onglet "Structure" affiché qui montre toutes vos tables, vérifiez la colonne Interclassement sur les tables de SMF.
- Si vous utilisez autre chose, vous pouvez utiliser une commande SQL standard : sélectionnez la base de données utilisée par SMF avec la commande USE VOTREBASEDEDONNEE et utilisez SHOW TABLE STATUS   Parmi les résultats, repérez la colonne Collation sur l'une des tables de SMF, admettons smf_messages (si smf_ est le préfixe configuré pour SMF).
- Vérification supplémentaire possible : Ouvrez votre fichier Settings.php situé à la racine de votre forum, repérez la ligne $db_character_set si elle existe

-> Si ces résultats ne contiennent pas "utf-8" vous devez utiliser les fichiers de langues french et pas french-utf-8 (dans le cas contraire c'est que vous avez converti auparavant votre forum en UTF-8 vous devez donc utiliser les fichiers de langues french-utf8 mais les symptômes sont différents, tous les messages devraient apparaitre, seuls les accents sont mal affichés).

Test :
Allez dans Admin->Langues->Paramètres et sélectionnez la langue et son encodage qui devrait être utilisé. Bien sûr si vous ne l'avez pas installé, allez-y grâce à Admin->Langues->Ajouter langue.
Décochez Permettre aux utilisateurs de choisir la langue afin de s'assurer que vous utilisez la bonne version des fichiers de langue et vérifiez les messages si le problème apparaît toujours ou pas.

Résolution :
Si tout est rétabli, vous n'avez plus qu'à supprimer les fichiers de langues incorrects via Admin->Langues->Modifier les langues, cliquez sur la langue concernée et utilisez le bouton Effacer.
Si le problème persiste, posez le problème sur le forum en fournissant le plus d'information possible !

Amicalement,
DeathSign

PS: S'il y a une erreur dans ce topic, n'hésitez pas à me le faire savoir ! Si vous voyez des améliorations, pareil !
« Last Edit: February 12, 2012, 05:41:55 PM by DeathSign »

Offline GravuTrad

  • Local Moderator
  • SMF Hero
  • *
  • Posts: 8,486
  • Gender: Male
  • One of the french SMF translators
On a toujours besoin d'un plus petit que soi! (Petit!Petit!)



Think about Search function before posting.
Pensez à la fonction Recherche avant de poster.