Advertisement:

Author Topic: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'  (Read 16640 times)

Offline boolat

  • Semi-Newbie
  • *
  • Posts: 13
Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« on: October 12, 2005, 02:11:15 PM »
hello,

after installation of com_joomla_smf_forum_1.0.1b I have this like error on the page of Joomla-SMF Forum Configuration:

 I seek and seek but does not find the error ?

Quote
Warning: touch(): Unable to create file /www/docs/hosted/yuce.be/cache/mh_announcement.rdf because Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 18

Warning: chmod(): Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 19

Warning: filemtime(): Stat failed for /www/docs/hosted/yuce.be/cache/mh_announcement.rdf (errno=13 - Permission denied) in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 31

Warning: fopen(/www/docs/hosted/yuce.be/cache/mh_announcement.rdf): failed to open stream: Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 45

Warning: fwrite(): supplied argument is not a valid stream resource in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 46

Warning: fclose(): supplied argument is not a valid stream resource in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 47

Warning: fopen(/www/docs/hosted/yuce.be/cache/mh_announcement.rdf): failed to open stream: Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 68

Warning: filesize(): Stat failed for /www/docs/hosted/yuce.be/cache/mh_announcement.rdf (errno=13 - Permission denied) in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 70


Warning: touch(): Unable to create file /www/docs/hosted/yuce.be/cache/index2.php&option=com_rss&feed=RSS1.0&no_html=ss1 because Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 18

Warning: chmod(): Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 19

Warning: filemtime(): Stat failed for /www/docs/hosted/yuce.be/cache/index2.php&option=com_rss&feed=RSS1.0&no_html=ss1 (errno=13 - Permission denied) in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 31

Warning: fopen(/www/docs/hosted/yuce.be/cache/index2.php&option=com_rss&feed=RSS1.0&no_html=ss1): failed to open stream: Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 45

Warning: fwrite(): supplied argument is not a valid stream resource in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 46

Warning: fclose(): supplied argument is not a valid stream resource in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 47

Warning: fopen(/www/docs/hosted/yuce.be/cache/index2.php&option=com_rss&feed=RSS1.0&no_html=ss1): failed to open stream: Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 68

Warning: filesize(): Stat failed for /www/docs/hosted/yuce.be/cache/index2.php&option=com_rss&feed=RSS1.0&no_html=ss1 (errno=13 - Permission denied) in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 70

Your Joomla-SMF Integration version is 1.0.1b

Warning: touch(): Unable to create file /www/docs/hosted/yuce.be/cache/mh_mambo_smf_update.rdf because Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 18

Warning: chmod(): Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 19

Warning: filemtime(): Stat failed for /www/docs/hosted/yuce.be/cache/mh_mambo_smf_update.rdf (errno=13 - Permission denied) in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 31

Warning: fopen(/www/docs/hosted/yuce.be/cache/mh_mambo_smf_update.rdf): failed to open stream: Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 45

Warning: fwrite(): supplied argument is not a valid stream resource in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 46

Warning: fclose(): supplied argument is not a valid stream resource in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 47

Warning: fopen(/www/docs/hosted/yuce.be/cache/mh_mambo_smf_update.rdf): failed to open stream: Permission denied in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 68

Warning: filesize(): Stat failed for /www/docs/hosted/yuce.be/cache/mh_mambo_smf_update.rdf (errno=13 - Permission denied) in /www/docs/hosted/yuce.be/administrator/components/com_smf/rdf.php on line 70
Error: Cannot reach JoomlaHacks.com feed!

Online Kindred

  • The Mean One
  • Local Moderator
  • SMF Master
  • *
  • Posts: 39,732
  • Gender: Male
  • Red Sox WIN!
    • wagner999 on Facebook
    • Kindred-999 on GitHub
    • www.linkedin.com/in/wdwagner/ on LinkedIn
    • @Kindred_999 on Twitter
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #1 on: October 12, 2005, 02:37:42 PM »
this is an issue with the bridge from joomlahacks.com

The majority of us (and pretty much all the support) on this site uses Orstio's bridge (3.19a is the current revision)
Please ask support questions for the joomlahacks bridge over on Joomlahacks.com for a quicker and better answer.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support forums.  Thank you.

Offline Vramin

  • Semi-Newbie
  • *
  • Posts: 18
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #2 on: October 12, 2005, 08:47:39 PM »
Well, it may be a JoomlaHacks installation, but those look to me like good old fashioned permissions problems. Sometimes you need to open the files that are throwing the errors (rdf.php, for example) and see what files they're trying to open. Generally speaking, all of your web files need to world readable, and a lot of the files need to be writeable during the installation.

But if that doesn't fix it, I second the motion. Go to the JoomlaHacks [nofollow] site where they seem to know how to make all this stuff work. Thanks to them I now have a working bridge (I never got it to work with the other one). There is a good installation guide on their site, but it's not responding right now so I can't post a link for you. It's on the front page, though.

Online Kindred

  • The Mean One
  • Local Moderator
  • SMF Master
  • *
  • Posts: 39,732
  • Gender: Male
  • Red Sox WIN!
    • wagner999 on Facebook
    • Kindred-999 on GitHub
    • www.linkedin.com/in/wdwagner/ on LinkedIn
    • @Kindred_999 on Twitter
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #3 on: October 13, 2005, 08:13:35 AM »
lol Vramin....


boolat, on a second look, it could be a safe-mode issue.

OR...  big question here...   did you alreayd install SMF as a stand-alone setup before installing the bridge?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support forums.  Thank you.

Offline boolat

  • Semi-Newbie
  • *
  • Posts: 13
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #4 on: October 13, 2005, 08:25:55 AM »
ok pobleme is hosting cache chmod permision ! in denied !
thx

Offline chadness

  • Sophist Member
  • *****
  • Posts: 1,025
  • Gender: Male
    • technoadvice.com
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #5 on: October 13, 2005, 12:06:49 PM »
You could try using Mamboxplorer to fix the permissions.

Orstio

  • Guest
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #6 on: October 13, 2005, 10:33:18 PM »
Go to your Joomla admin panel.

Click on Global Configuration.

Click on the Server tab.

Set the permissions to 0777 for files and folders, and check the boxes indicating "Apply to existing files".

Once you have everything working as you  feel is fit, set your permissions appropriately using FTP or cPanel.  That way, you will own the permissions on the files, rather than apache owning them.

Offline Vramin

  • Semi-Newbie
  • *
  • Posts: 18
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #7 on: October 19, 2005, 04:28:21 PM »
Go to your Joomla admin panel.

Click on Global Configuration.

Click on the Server tab.

Set the permissions to 0777 for files and folders, and check the boxes indicating "Apply to existing files".

Once you have everything working as you  feel is fit, set your permissions appropriately using FTP or cPanel.  That way, you will own the permissions on the files, rather than apache owning them.
I've eyballed that option a couple of times but had never changed it. Thanks for the tip, I was annoyed that when I installed components and such they belonged to nobody:nobody and I couldn't change them.

What are the recommended permissions for files and directories once you think things are tight?

Offline Vramin

  • Semi-Newbie
  • *
  • Posts: 18
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #8 on: October 19, 2005, 04:33:30 PM »
Actually, I went and looked at a clean Joomla install and checked the options.

0644 for files

0755 for directories


Offline p9939068

  • Semi-Newbie
  • *
  • Posts: 33
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #9 on: October 27, 2005, 02:13:31 PM »
if you're lazy like me, 777 for all. it doesnt really make a difference.

Offline Vramin

  • Semi-Newbie
  • *
  • Posts: 18
Re: Joomla-SMF Forum Configuration 'mambo 4.5.2.1'
« Reply #10 on: October 27, 2005, 10:28:37 PM »
if you're lazy like me, 777 for all. it doesnt really make a difference.
I'm on a shared server, so I don't like that idea.