Advertisement:
NameCheap

Author Topic: Caratteri strani al posto di lettere  (Read 21923 times)

Offline I-MAXI

  • Newbie
  • *
  • Posts: 3
Caratteri strani al posto di lettere
« on: July 24, 2008, 03:17:26 PM »
Salve,

sono nuovo nella community di supporto italiano, ma sono un grande utilizzatore di SMF fin dalla 1.1.3 :)

Ora però con la versione 1.1.5 ho il seguente problema.

Al posto di alcuni caratteri delle volte mi vengono questi simboli   â�¬Ã�Ru perchè?

Offline tatore

  • Sophist Member
  • *****
  • Posts: 1,259
  • Gender: Male
    • SalvoFranchina.it
Re: Caratteri strani al posto di lettere
« Reply #1 on: July 24, 2008, 07:45:00 PM »
HAi convertito il database all'encoding UTF-8...?
Perchè l'unico problema che puo' dare questa anomalia nel set dei caratteri è la conversione del database e delle entità html da ISO a UTF-8.
*Salvo*







Quote from: Rumbaar
I wont jump to conclusion, but you might be hacked?

Offline I-MAXI

  • Newbie
  • *
  • Posts: 3
Re: Caratteri strani al posto di lettere
« Reply #2 on: July 25, 2008, 04:39:33 AM »
si forse si...

ma come potrei vederlo? Nel caso l'ho convertito come posso riportarlo ad ISO e a quale ISO?

Grazie

Offline tatore

  • Sophist Member
  • *****
  • Posts: 1,259
  • Gender: Male
    • SalvoFranchina.it
Re: Caratteri strani al posto di lettere
« Reply #3 on: July 25, 2008, 05:23:35 AM »
No, non puoi tornare indietro (se non hai un backup).
Nel file Settings.php alla fine ha una stringa in cui è specificato il tipo di linguaggio utilizzato dal forum. E ancora piu' nel dettaglio, puoi vedere sul db accanto ad ogni tabella se l'encoding è

Latin_swedish_ci

oppure
utf8_general_ci
Se puoi, anche privatamente, mandami un mp con il link al tuo forum.
*Salvo*







Quote from: Rumbaar
I wont jump to conclusion, but you might be hacked?

Offline I-MAXI

  • Newbie
  • *
  • Posts: 3
Re: Caratteri strani al posto di lettere
« Reply #4 on: July 25, 2008, 07:21:37 AM »
mmh vediamo...

se entro in phpMyAdmin nella home leggo: Set di caratteri MySQL:  UTF-8 Unicode (utf8)

mentre in ogni tabella in una delle colonne ogni volta c'è scritto   utf8_general_ci

comunque è molto strano perchè ho appena re-installato il forum ed ho DEspuntato utilizza caratteri UTF8.....

ciao e grazie molte
« Last Edit: July 25, 2008, 07:23:10 AM by I-MAXI »

Offline ruzzine

  • Newbie
  • *
  • Posts: 1
Re: Caratteri strani al posto di lettere
« Reply #5 on: August 12, 2008, 12:07:14 PM »
Salve,
anche io ho un problema simile..un carattere o cmq alcuni caratteri come il TM si vedono con quel simbolo strano.. tutto questo è successo dall'aggiornamento dal 1.1.4 al 1.1.5.
La cosa strana è che se imposto la lingua in english i caratteri tornano a vedersi..se metto italian no..
La lingua è italian e non italian utf.. ho provato a modificare tutte le tabelle da latin a uft8.. e mi dà la stessa cosa.. con le tabelle modificate in utf8 ho provato a installare la lingua italiana utf ma nisba..continuano a vedersi con quei caratteri strani!.. Come posso risolvere?..