Advertisement:

Author Topic: Registro errori del forum  (Read 6338 times)

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #20 on: March 27, 2012, 10:14:33 AM »
Ok, allora visto che il forum è già lento di suo lascio la spunta. 8)
Ora tengo controllato il registro errori, e spero che non ne vengano fuori altri...
Che dire, sei un grande...
Grazie come sempre Emanuele...

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #21 on: March 28, 2012, 11:12:10 AM »
Ho tenuto sotto controllo il registro errori, e di tutti quelli citati nel primo post non vi è piu traccia.
Ora ho visto 2 errori (credo siano banali ma già che ci siamo....) che fanno riferimento a 2 file.

Il primo è:
8: Undefined index: manual_posting_Change_size
File: /.................../public_html/forum/Themes/default/Help.template.php
Riga: 1652


Ho controllato questo file alla riga 1652, e ho trovato questo:

Code: [Select]
</select><br />
<select onchange="surroundText(\'[size=\'+this.options[this.selectedIndex].value+\']\', \'[/size]\', document.forms.postmodify.message); this.selectedIndex = 0;" style="margin-bottom: 1ex; margin-left: 2ex;">
<option value="" selected="selected">
', $txt['manual_posting_Change_size'], '
</option>
<option value="9pt">
', $txt['manual_posting_Change_Font_9'], '




Il secondo è:
8: Undefined offset: 1
File: /.................../public_html/forum/Sources/Subs.php
Riga: 1066


Ho controllato questo file alla riga 1066 e ho trovato una modifica che avevo fatto tanto tempo fà (circa un anno fà) che mi è servita per aggiungere la funzione ed2k-stats accanto ai link di emule.
Questa modifica stà funzionando da sempre senza alcun problema, e comunque ieri mentre spulciavo SMF Italia ho visto che poco tempo fà un altro utente ha chiesto info in merito in questo post e vedendo quello che gli hai detto ho avuto la conferma di aver fatto giusto.

Questa è la riga incriminata:

Code: [Select]
}

function link_from_a_ed2k ($m)
{
preg_match('/ed2k:\/\/\|file\|.+?\|.+?\|(.+?)\|.*/i', $m[0], $match);
   $stats = '&nbsp;<a href="http://ed2k.shortypower.org/?hash=' . $match[1] . '"><img src="http://www.mioforum.net/forum/Themes/default/images/stats.gif" alt="" /></a>';
$ed2k_img = '<img src="./ed2kfile/donkey.gif" alt="ed2k:" title="Edonkey Link" /> ';
return $ed2k_img .'<a href="' . $m[1] . '">' . $m[5] . '</a> (' . human_size($m[3]) . ')' .  $stats;
}

function link_from_ed2k ($m)
{
preg_match('/ed2k:\/\/\|file\|.+?\|.+?\|(.+?)\|.*/i', $m[0], $match);
   $stats = '&nbsp;<a href="http://ed2k.shortypower.org/?hash=' . $match[1] . '"><img src="http://www.mioforum.net/forum/Themes/default/images/stats.gif" alt="" /></a>';
$ed2k_img = '<img src="./ed2kfile/donkey.gif" alt="ed2k:" title="Edonkey Link" /> ';
return $m[1] . $ed2k_img . '<a href="' . $m[2] . '">' . $m[3] . '</a> (' . human_size($m[4]) . ')' . $stats . $m[5];
}
// end of ed2k links functions



Premeto che ho lasciato in Disable template evaluation? la spunta come mi avevi detto.

Grazie mille in anticipo....

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,161
  • Gender: Male
  • THERE'S JUST ME
Re: Registro errori del forum
« Reply #22 on: March 30, 2012, 08:24:53 AM »
Il primo mi sembra un altro mod, quale può essere?

Il secondo ancora un altro problema con un mod, presumibilmente non trova l'hash ($match[1]) e quindi non ti da il link corretto alle statistiche del link edk.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #23 on: March 30, 2012, 09:30:48 AM »
Intanto grazie...
Per il secondo errore ho notato una cosa strana.
Praticamente funziona e quindi mi apre la pagina Ed2k-stats,
ma invece di aprirmi una nuova scheda come accade in tutti forum di questo genere
 me la apre direttamente nella stessa pagina.
Per il primo invece non saprei, ho inserito sopra la riga che mi viene segnalata ma non capisco
cosa potrebbe essere.
A ptoposito, ho dovuto disabilitare oggi la spunta alla
voce Disable template evaluation? perché non mi caricava piu le antprime mentre si creava una
nuova discussione.
Grazie come sempre Emanuele...

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,161
  • Gender: Male
  • THERE'S JUST ME
Re: Registro errori del forum
« Reply #24 on: March 30, 2012, 12:34:04 PM »
Strano, disable template evaluation non fa niente che possa interferire col normale funzionamento di SMF...fa solo fare alcune operazioni in meno...quindi ci dovrebbero essere addirittura meno possibilità d'errore...
Sicuro non fosse altro?


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #25 on: March 30, 2012, 12:48:12 PM »
Praticamente come ho messo la spunta in Disable template evaluation? le anteprime non si sono piu riuscite a fare, e come l'ho tolta hanno ripreso a funzionare, e gli altri errori che citavo sopra nemmeno piu l'ombra....
Bhò...
Resta comunque un mistero il fatto che quando si clicca su ed2k-stats si apre la pagina direttamente invece di aprirsi in una nuova scheda...

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,161
  • Gender: Male
  • THERE'S JUST ME
Re: Registro errori del forum
« Reply #26 on: March 30, 2012, 01:18:22 PM »
Beh, da nessuna parte in quella funzione c'è alcuna istruzione che dice al browser di aprire il link in una nuova pagina...quindi come minimo devi aggiungere un
Code: [Select]
target="_blank"nel code, ad esempio:
Code: [Select]
$stats = '&nbsp;<a target="_blank" href="http://ed2k.shortypower.org/?hash=' . $match[1] . '"><img src="http://www.mioforum.net/forum/Themes/default/images/stats.gif" alt="" /></a>';
$ed2k_img = '<img src="./ed2kfile/donkey.gif" alt="ed2k:" title="Edonkey Link" /> ';
return $ed2k_img .'<a target="_blank" href="' . $m[1] . '">


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #27 on: March 30, 2012, 01:35:51 PM »
Perfettoooooooooooooooooo... 8) 8) 8)
Ora funge come volevo, mi apre una nuova scheda....
Per gli errori rimaniamo un attimo fermi perchè da quando ho tolto la spunta a Disable template evaluation? non me ne ha piu dati.
Quindi non mi rimane altro da fare che ringraziarti perchè sei un mito....
Se dovessero ripresentarsi rispondo direttamente a questo post.
Grazie ancora Emanuele, a presto...

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #28 on: April 02, 2012, 10:27:35 AM »
Rieccomi....
Ho notato altri errori e volevo farteli notare:

1)
ht.p://mioforum/forum/index.php?action=featuresettings
8: Undefined index: auto_index_title
File: /.........../public_html/forum/Sources/ModSettings.php
Riga: 149

2)
ht.p://mioforum/forum/index.php?topic=39357.0
8: Undefined offset: 1
File: /.........../public_html/forum/Sources/Subs.php
Riga: 1066

3)
ht.p://mioforum/forum/index.php?action=help;page=post
8: Undefined index: manual_posting_Change_size
File: /.........../public_html/forum/Themes/default/languages/Manual.italian.php (manual_posting sub template - eval?)
Riga: 1652


Che ne pensi?
Cosa può creare questi errori?

Grazie in anticipo come sempre...

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,161
  • Gender: Male
  • THERE'S JUST ME
Re: Registro errori del forum
« Reply #29 on: April 04, 2012, 10:02:08 AM »
Qualche riga di codice per capire non farebbe male... :P

Il primo ed il terzo sembrerebbero mancanza di stringhe di traduzione, il secondo mi lascia un po' perplesso, ma senza dettagli è dura capire...


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #30 on: April 04, 2012, 11:44:11 AM »
Vuoi che scarico i file incriminati e ti posto le righe che riportano gli errori?
Grazie mille...

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,161
  • Gender: Male
  • THERE'S JUST ME
Re: Registro errori del forum
« Reply #31 on: April 04, 2012, 12:44:58 PM »
yep.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #32 on: April 04, 2012, 01:31:17 PM »

1)
ht.p://mioforum/forum/index.php?action=featuresettings
8: Undefined index: auto_index_title
File: /.........../public_html/forum/Sources/ModSettings.php
Riga: 149




2)
ht.p://mioforum/forum/index.php?topic=39357.0
8: Undefined offset: 1
File: /.........../public_html/forum/Sources/Subs.php
Riga: 1066




3)
ht.p://mioforum/forum/index.php?action=help;page=post
8: Undefined index: manual_posting_Change_size
File: /.........../public_html/forum/Themes/default/languages/Manual.italian.php (manual_posting sub template - eval?)
Riga: 1652

Il terzo errore non posso postarlo perchè non esiste la riga 1652, arriva sino alla riga 827.


Grazie come sempre Emanuele...

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,161
  • Gender: Male
  • THERE'S JUST ME
Re: Registro errori del forum
« Reply #33 on: April 04, 2012, 02:18:20 PM »
1)
ht.p://mioforum/forum/index.php?action=featuresettings
8: Undefined index: auto_index_title
File: /.........../public_html/forum/Sources/ModSettings.php
Riga: 149
Manca la traduzione in italiano.

2)
ht.p://mioforum/forum/index.php?topic=39357.0
8: Undefined offset: 1
File: /.........../public_html/forum/Sources/Subs.php
Riga: 1066
Prova a sostituire $match[1] con $match[0].

3)
ht.p://mioforum/forum/index.php?action=help;page=post
8: Undefined index: manual_posting_Change_size
File: /.........../public_html/forum/Themes/default/languages/Manual.italian.php (manual_posting sub template - eval?)
Riga: 1652

Il terzo errore non posso postarlo perchè non esiste la riga 1652, arriva sino alla riga 827.
template eval.


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #34 on: April 04, 2012, 03:13:00 PM »
Ricapitolo...

Per l'errore 1:

Code: [Select]
    1)
    ht.p://mioforum/forum/index.php?action=featuresettings
    8: Undefined index: auto_index_title
    File: /.........../public_html/forum/Sources/ModSettings.php
    Riga: 149

Manca la traduzione in italiano.

Hai per caso idea di che mod si tratta? Non ho nessuna mod Nei pacchetti installati che fà riferimento a auto_index_title.


Per l'errore 2:

Code: [Select]
    2)
    ht.p://mioforum/forum/index.php?topic=39357.0
    8: Undefined offset: 1
    File: /.........../public_html/forum/Sources/Subs.php
    Riga: 1066

Prova a sostituire $match[1] con $match[0].

Ho fatto come mi hai detto, ora tengo controllato il registro errori per vedere se si ripresenta.


Per l'errore 3:

Code: [Select]
    3)
    ht.p://mioforum/forum/index.php?action=help;page=post
    8: Undefined index: manual_posting_Change_size
    File: /.........../public_html/forum/Themes/default/languages/Manual.italian.php (manual_posting sub template - eval?)
    Riga: 1652

    Il terzo errore non posso postarlo perchè non esiste la riga 1652, arriva sino alla riga 827.

template eval.

Mi hai citato template eval, ma non ho capito cosa intendi. Devo modificare o controllare qualche file?


Grazie ancora per l'aiuto...

Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,161
  • Gender: Male
  • THERE'S JUST ME
Re: Registro errori del forum
« Reply #35 on: April 04, 2012, 03:16:47 PM »
Per l'errore 1:

Code: [Select]
    1)
    ht.p://mioforum/forum/index.php?action=featuresettings
    8: Undefined index: auto_index_title
    File: /.........../public_html/forum/Sources/ModSettings.php
    Riga: 149

Manca la traduzione in italiano.

Hai per caso idea di che mod si tratta? Non ho nessuna mod Nei pacchetti installati che fà riferimento a auto_index_title.
Neanche la più pallida idea.
Assumento che come la maggior parte dei mod abbia messo la stringa in...oddio non mi ricordo più dove vanno...ModSettings.english.php? Boh, dovrebbe essere.
Apri quel file, cerca quella stringa e copiala nel file con lo stesso nome, ma per l'italiano (ad esempio ModSettings.italian.php


Per l'errore 2:

Code: [Select]
    2)
    ht.p://mioforum/forum/index.php?topic=39357.0
    8: Undefined offset: 1
    File: /.........../public_html/forum/Sources/Subs.php
    Riga: 1066

Prova a sostituire $match[1] con $match[0].

Ho fatto come mi hai detto, ora tengo controllato il registro errori per vedere se si ripresenta.
Più che altro tieni monitorati i link, se sono corretti oppure no...


Per l'errore 3:

Code: [Select]
    3)
    ht.p://mioforum/forum/index.php?action=help;page=post
    8: Undefined index: manual_posting_Change_size
    File: /.........../public_html/forum/Themes/default/languages/Manual.italian.php (manual_posting sub template - eval?)
    Riga: 1652

    Il terzo errore non posso postarlo perchè non esiste la riga 1652, arriva sino alla riga 827.

template eval.

Mi hai citato template eval, ma non ho capito cosa intendi. Devo modificare o controllare qualche file?
Che cos'hai fatto l'altra volta che c'era template eval? :P


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #36 on: April 04, 2012, 03:35:17 PM »
Per l'errore 1:

Code: [Select]
       1)
        ht.p://mioforum/forum/index.php?action=featuresettings
        8: Undefined index: auto_index_title
        File: /.........../public_html/forum/Sources/ModSettings.php
        Riga: 149

    Manca la traduzione in italiano.


    Hai per caso idea di che mod si tratta? Non ho nessuna mod Nei pacchetti installati che fà riferimento a auto_index_title.

Neanche la più pallida idea.
Assumento che come la maggior parte dei mod abbia messo la stringa in...oddio non mi ricordo più dove vanno...ModSettings.english.php? Boh, dovrebbe essere.
Apri quel file, cerca quella stringa e copiala nel file con lo stesso nome, ma per l'italiano (ad esempio ModSettings.italian.php

Provo e poi ti dico... ;)


Per l'errore 2:

Code: [Select]
        2)
        ht.p://mioforum/forum/index.php?topic=39357.0
        8: Undefined offset: 1
        File: /.........../public_html/forum/Sources/Subs.php
        Riga: 1066

    Prova a sostituire $match[1] con $match[0].


    Ho fatto come mi hai detto, ora tengo controllato il registro errori per vedere se si ripresenta.

Più che altro tieni monitorati i link, se sono corretti oppure no...

Ho dovuto rimettere $match[1] perchè alcuni link non funzionavano piu, e non si visualizzavano piu cliccabili ma solo scritti.


Per l'errore 3

Code: [Select]
        3)
        ht.p://mioforum/forum/index.php?action=help;page=post
        8: Undefined index: manual_posting_Change_size
        File: /.........../public_html/forum/Themes/default/languages/Manual.italian.php (manual_posting sub template - eval?)
        Riga: 1652

        Il terzo errore non posso postarlo perchè non esiste la riga 1652, arriva sino alla riga 827.

    template eval.


    Mi hai citato template eval, ma non ho capito cosa intendi. Devo modificare o controllare qualche file?

Che cos'hai fatto l'altra volta che c'era template eval?

Se disabilito template eval non mi funzionano piu le anteprime....



Ci sentiamo domani, faccio un pò di prove.....
Grazie come sempre per l'aiuto....
Buona serata....

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #37 on: April 05, 2012, 10:15:02 AM »
Eccomi...
Ricapitolo:

Per l'errore 1 ho controllato il file ModSettings.english.php e della stringa auto_index_title non vi è traccia.

Per l'errore 2 come ti dicevo ieri non posso mettere $match[0] perchè non funzionano piu alcuni link.

Per l'errore 3 se disabilito template eval non mi funzionano piu le anteprime.

Cavolo non se ne viene a capo..... :o

Hai qualche altra idea da tirare fuori dal cilindro magico?  ;D

Grazie per la tua disponibilità.....


Offline emanuele

  • SMF Super Hero
  • *******
  • Posts: 14,161
  • Gender: Male
  • THERE'S JUST ME
Re: Registro errori del forum
« Reply #38 on: April 05, 2012, 10:24:33 AM »
Per l'errore 1 ho controllato il file ModSettings.english.php e della stringa auto_index_title non vi è traccia.
Cerca in qualche altro file, altrimenti può essere un altro pezzo di un mod che hai installato e poi rimosso...

Per l'errore 2 come ti dicevo ieri non posso mettere $match[0] perchè non funzionano piu alcuni link.
Ripeto: mi domando come i link facciano a funzionare perché $match[1] è *sempre* inesistente (ed è appunto per questo che viene riportato l'errore), quindi il link mancherà sempre di quel pezzo...boh.

Per l'errore 3 se disabilito template eval non mi funzionano piu le anteprime.
E se non lo abiliti non puoi vedere dove si trova veramente l'errore senza tirare ad indovinare (altrimenti detto cercare tutte le occorrenze di "manual_posting_Change_size" in tutti i file e sperare ce ne sia solo una).


Take a peek at what I'm doing! ;D



Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Offline red-77

  • Semi-Newbie
  • *
  • Posts: 35
Re: Registro errori del forum
« Reply #39 on: April 05, 2012, 10:54:39 AM »
2 cose:

1) Questo tipo di errori può influenzare in qualche modo la navigazione, per esempio rendere il caricamento delle pagine lento, o cos'altro?

2) Per l'errore 2 puoi spiegarti meglio?

Grazie ancora...