Customizing SMF > Modifications and Packages

SA Facebook Integration

<< < (552/770) > >>

LOVELORD:
Hello,

I have problem with publish button on my site... When I want to publish something i recive this error:

API Error Code: 191
API Error Description: The specified URL is not owned by the application
Error Message: redirect_uri is not owned by the application.

I found that I must add SDK Javascript somewhere on site, but i dont know where i must add this script
https://developers.facebook.com/docs/reference/javascript/

Also when I try to cennect to facebook with my account, or when I try to login or register account throuth facebook.

Any help what I need to do.

Also where i can find this access token?

SA™:
you dont have to add SDK Javascript anywere it included in the mod

the error tells you whats up with it


--- Quote ---API Error Description: The specified URL is not owned by the application
Error Message: redirect_uri is not owned by the application.
--- End quote ---

you have basicly set up you app wrong or you didnt set up an application on facebook

LOVELORD:

--- Quote from: SA™ on August 07, 2012, 01:00:17 PM ---you dont have to add SDK Javascript anywere it included in the mod

the error tells you whats up with it


--- Quote ---API Error Description: The specified URL is not owned by the application
Error Message: redirect_uri is not owned by the application.
--- End quote ---

you have basicly set up you app wrong or you didnt set up an application on facebook

--- End quote ---

Can you tell what i must do to set up application on facebook?

phtomay:

--- Quote from: phtomay on August 04, 2012, 03:35:09 AM ---
--- Quote from: SA™ on August 04, 2012, 03:27:19 AM ---
@phtomay
did you remove extension=php_curl.dll the whoole line? should only remove the ; semicolon you have abvisly messed up you php.ini
im not sure what else to say

--- End quote ---

I only removed the ; semicolon. other website on my localhost are accessible, so it might not be that my php.ini files is messed up.
Thanks for your response

--- End quote ---

Texan78:
Making last minute checks on everything before I go Live and everything in the mod works with the exception of the Publisher.

I have "Enable Post Publisher" set to "New Topics" Then have "Publish to facebook?" set to "Page".

My Facebook Page and User ID is entered and entered correctly. After entering the information I click save.

I then clicked on the grant permissions button and everything was granted correctly. Two of the "Facebook Access Tokens" were entered. There is three boxes to enter tokens. When I granted permission the first and third box populated but not the second.

I made a test post and it doesn't post to the FB page. Am I missing a step of over looking something? Is their suppose to be three tokens and if so where do I get the third one. This same function works perfect with the Twitter Mod.

Also one other quick question. When users log in with their FB account which password does the forum store as a password. Because if a user wants to update display name or forum profile account settings they have to enter their password to complete it.

Any ideas of suggestions would be greatly appreciated.

-Thanks!

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version