SMF Support > SMF 1.1.x Support

Having problems with the package manager?

(1/163) > >>

Some people have run into problems using the package manager.  These are caused either by safe mode issues, or wrong paths.

If you're trying to use the package manager in safe mode, you may experience problems.  This is caused by ownership issues.  Previously, our recommendation has been to ask your host to enable PHP suExec, which solves those issues.

Recently, we came upon another solution which may resolve the need for PHP suExec in safe mode environments.  While this is still something your host should/could do for you, it is also something you can do without their involvement in many cases.

PLEASE NOTE: This solution may or may not work for everyone.  We would like feedback on whether or not it works for you.

The tool attached does two things: first, it changes the permissions (if possible) on the files in your SMF installation to combat safe mode, and second it tells you what path it used, which is what you should use in the package manager as well.  Please use this tool if you are having problems installing mods, and copy down the path it gives you.  The next major release of SMF should solve these problems.

The trick this file uses is that setting your permissions a certain way will make it so that files created by PHP, for example in "attachments", are still owned by *you*, not PHP.  This is, in many cases, better anyway, because you don't want files owned by someone else in your stuff!


Tried the tool on a friend's board...

I still get this when trying to use the package manager:

--- Quote ---2: opendir(): SAFE MODE Restriction in effect. The script whose uid is 832 is not allowed to access /.../var/www/html/forums/Packages/temp owned by uid 48
File: /.../var/www/html/forums/Sources/Subs-Package.php
Line: 895
--- End quote ---

Try deleting the temp directory and trying again... or... hmm, I'll make a change to the attachment, one moment..



* Oldiesmann waits

: fopen(): SAFE MODE Restriction in effect. The script whose uid is 2542 is not allowed to access /home/customers/kulma/public_html/keskustelu/Packages/temp owned by uid 502
Tiedosto: /home/customers/kulma/public_html/keskustelu/Sources/Subs-Package.php
Rivi: 1454


[0] Message Index

[#] Next page

Go to full version