Advertisement:
NameCheap

Author Topic: SMF 1.1.5 and Joomla 1.5.3 + ssi_login  (Read 17151 times)

Offline Mr. Jinx

  • Full Member
  • ***
  • Posts: 409
  • Gender: Male
    • UPC Forum - Chelloo.com
SMF 1.1.5 and Joomla 1.5.3 + ssi_login
« on: July 10, 2008, 10:46:25 AM »
I'm using the php function "ssi_login" on one of my pages in joomla.
This seems to work, however the URL redirect feature just doesn't work!
 
For example, I include this code in joomla:
Code: [Select]
require_once("/path/SSI.php");
ssi_login('http://redirectpage');

There are many ways to do this: a custom module / in your template / using a php-code module like 'Jumi'. You can login just fine, but you will be directed to the forum, not the specified url.

Somehow it must loose the variable '$_SESSION['login_url']. This is where the redirection url is stored, but once you are logged in, it must be gone or something.

Any other ways to solve this?
« Last Edit: October 31, 2009, 09:58:13 AM by Mr. Jinx »

Offline Mr. Jinx

  • Full Member
  • ***
  • Posts: 409
  • Gender: Male
    • UPC Forum - Chelloo.com
Re: SMF 2.0 RC1 and Joomla 1.5.14 + ssi_login
« Reply #1 on: October 25, 2009, 03:39:07 PM »
I found a solution for my previous question by adding:
Code: [Select]
$_SESSION['login_url']=$scripturl;To Boardindex.template.php, just under de global section.

However, now that I've upgraded to SMF 2.0 RC1.2 the problem is back :(

If I test the ssi_login redirection function by editting 'ssi_examples.php' it works just fine.
I just can't get it to work from within a joomla module. It will always lose the login_url variable.
Can someone help me with this one?

Offline Mr. Jinx

  • Full Member
  • ***
  • Posts: 409
  • Gender: Male
    • UPC Forum - Chelloo.com