Advertisement:

Author Topic: Random Lags  (Read 2781 times)

Offline Eudemon

  • Sr. Member
  • ****
  • Posts: 802
  • An Anime Fan
    • KumaKuni
Random Lags
« on: February 24, 2012, 12:17:29 PM »
My host is http://www.servint.net/vps.php
I'm on the 49/month VPS package
I only have two smf sites running on the server, I shared member,log etc tables for both sites
so both sites combine i get around 120 visitors in 30 min period
most of the time, the page create speed is less than 0.2 second for me
but sometimes can go up to 25 sec all the sudden with no sudden increase of traffic, it usually last 30min~1hr30min, once or twice a day

there was one time, a bot spammer that got banned kept on activating his account, which slowed down my server
that was logged in the error log, so i blocked his ip on my server site then problem solved
anyways, every time when lag happens, i check both smf error log and server error log, nothing suspicious

this is my status.php http://eudemon.org/status.php

and sometimes when lag happens i get these email from my server
tailwatchd - chkservd on vps.eudemon.org status: hang‏
Code: [Select]
The chkservd sub-process with pid 32026 was running for 302 seconds.  The sub-process was terminated as it exceeded the time between checks of 300 seconds.  Please check /var/log/chkservd.log and /usr/local/cpanel/logs/tailwatchd_log to discover the cause.lfd on vps.eudemon.org failed‏
Code: [Select]
lfd failed @ Thu Feb 23 23:49:40 2012. A restart was attempted automagically.
 
Service Check Method:  [check command]
 
Number of Restart Attempts: 1

whenever i ask my host if they can determine the issue, they always say "you're over using the resource please upgrade.."
which i don't think it's the case for 2 smf site with combined 120 visitors/30min in a $50 per month VPS
hack?configuration issue?trojan?i don't know
I'm not good at server configuration/trouble shooting
if you need I can give my credential to my WHM and cpanel
« Last Edit: February 24, 2012, 12:32:24 PM by Eudemon »

Offline Roph

  • Jr. Member
  • **
  • Posts: 376
  • Gender: Male
Re: Random Lags
« Reply #1 on: February 24, 2012, 01:42:58 PM »
Are you using persistent database connections? Are you using any sort of PHP caching?

If not, you can ask the servint NOC to setup APC for you. Ask for a 32mb APC cache, that should do it for your board and your amount of RAM.

Have you done any of the steps outlined in this thread?

Fellow servint essential VPS customer here :)

Offline Eudemon

  • Sr. Member
  • ****
  • Posts: 802
  • An Anime Fan
    • KumaKuni
Re: Random Lags
« Reply #2 on: March 04, 2012, 05:42:00 PM »
update
i switched to fastcgi and apc, the slowness issue solved
but then i got even more failure messages, and my WHM and cpanel will occasionally stop working
i asked them about it, all i got was something the same like "you're using too much resource, upgrade package etc"

i did a test, i completely remove all files from my server, the public_html folder is empty
the failure messages still didn't stop
so i ask them to rebuilt my server
now the issue is solved

thanks for your advise tho