Customizing SMF > Modifications and Packages

Pretty URLs 1.0 - Updated for SMF 2.0

<< < (1330/1437) > >>

Scratching my Head:
Hi. I know this will probably seem redundant, and maybe even obvious.
I thought I'd post it in the hopes it may help someone.

May be it is even a type of a bug. Depending upon your definition of a bug.



When receiving the internal server error, check to make sure the htaccess file created by the mod is correct.

Entirely correct.


Here is what I mean.

I set up a test forum. I even called it: Test Forum


When the mod creates the htaccess file it goes like this:




--- Code: ---# PRETTYURLS MOD BEGINS
# Pretty URLs mod
# http://code.google.com/p/prettyurls/
# .htaccess file generated automatically on: May 5, 2012, 12:08

RewriteEngine on
RewriteBase /Test Forum

--- End code ---


See the problem?

It should write it like this:


--- Code: ---# PRETTYURLS MOD BEGINS
# Pretty URLs mod
# http://code.google.com/p/prettyurls/
# .htaccess file generated automatically on: May 5, 2012, 12:08

RewriteEngine on
RewriteBase /Test%20Forum
--- End code ---


making sure that the %20 is there.

Every change to the htaccess file brings back the space instead of writing %20


I know.
I know.
I know.

Test Forum is sloppy coding. (shrug)

Just hope this helps someone who may, innocently create a forum with a space.


Hope all are well!

: o )


eldublu:
Hi all

I've just installed the mod and almost everything seems to work ok. The problem I have is that it prevents the use of alternate stylesheets that are set up for our theme, once the mod is enabled the default stylesheet colour is the one that shows regardless of the one selected.

Any ideas what to change to allow the alt stylesheets to work?

Update: I've disabled the mod for the time being, if it helps you can view the site with it's alt stylesheet selection (top right corner) working here

vincentfkc:
is Pretty URL possible to mod for Asian Language Topic (UTF-8)

like wordpress

u can rewrite fowllowing topic to URL base


--- Code: ---
http://www.me.com/生年1993/
http://www.me.com/%E7%94%9F%E5%B9%B41993/


--- End code ---


thanx

nend:
Just reported a bug @ http://code.google.com/p/prettyurls/issues/detail?id=154

It is untested, but by the results of a script I am working on SQLite3 Cache, I am sure that Pretty Url's suffers the same fate.

It seems when SMF's database is SQLite any SQLite database request from inside the callback function ob_sessrewrite() causes the script to exit without any output, no errors and no database activity.

This is not a SMF bug, it seems to be related to ob_start()'s callback function and SQLite.

You can see the problem though, even with SMF's database layer there is no way at this time to add compatibility with database calls from within ob_sessrewrite().

vinzbomb:
hi everybody,

i got a problem, i erase the skip action list and don't know what it was !!! So if someone can tell me the default skip action list in pretty urls will be nice !!!

Also i get logout everytime i use reply or post or simply when i go the an category of my forum i'm disconnected from the forum !!!

what's the problem?!!!!

thanks for replying me !!

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version