Advertisement:

Author Topic: 500 Error Internal server error - When login in the Forum (after upgrade)  (Read 19429 times)

Offline DukeN

  • Semi-Newbie
  • *
  • Posts: 42
Hi,
Let’s hope that someone can help me with this strange problem. I upgraded my forum SMF 1.1 RC2 to SMF 2.0 RC2. ( Not the production site, but test site ;) )

I was a little bit surprised that the upgrade was successful… great job guys!

I’m running a rather old joomla bridge for 1.x and have the forum wrapped in the website. After the upgrade I was logged in as myself automatically and had all the admin rights. I changed the template to the standard one and was happy to see the forum working correctly. All the topics, messages and users where there. Even the links where the same with the joomla / smf bridge.

So I needed to logout on the forum. This was working correctly. No it isn’t possible for me to login on the forum again. When I fill in the user crendtials I’m getting a 500 error internal server page/message.   
I’m seeing the login screen at: http://www.mysite.nl/component/option,com_smf/Itemid,81/action,login
When I fill random credentials en press the login butting the error: HTTP 500 on http://www.mysite.nl/component/option,com_smf/Itemid,81/action,login2

I already tried the repair_settings.php but without any luck. News users can register and are getting there activation email. In the activation email there is the activate link. When you activate the account it is possible to login whit in the activation screen….
I really hope someone had the solutions for this problem. Everything else on the forum  is running good.

Thx, Regards DukeN

 

Offline DukeN

  • Semi-Newbie
  • *
  • Posts: 42
Apache log tells me:

[Wed Jan 06 14:19:32 2010] [error] [client 127.0.0.1] (20024)The given path misformatted or contained invalid characters: Cannot map GET /:// HTTP/1.1 to file, referer: http://localhost/
[Wed Jan 06 14:19:32 2010] [error] [client 127.0.0.1] File does not exist: E:/server2go/htdocs/images/stories/users/straffen_thumb.jpg, referer: http://localhost/
[Wed Jan 06 14:19:32 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'knr2788_sitemap'@'localhost' (using password: YES) in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 4, referer: http://localhost/
[Wed Jan 06 14:19:32 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_select_db(): supplied argument is not a valid MySQL-Link resource in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 6, referer: http://localhost/
[Wed Jan 06 14:39:16 2010] [error] [client 127.0.0.1] (20024)The given path misformatted or contained invalid characters: Cannot map GET /:// HTTP/1.1 to file, referer: http://www.mywebsite.nl/
[Wed Jan 06 14:39:16 2010] [error] [client 127.0.0.1] File does not exist: E:/server2go/htdocs/images/stories/users/straffen_thumb.jpg, referer: http://www.mywebsite.nl/
[Wed Jan 06 14:39:16 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'knr2788_sitemap'@'localhost' (using password: YES) in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 4, referer: http://www.mywebsite.nl/
[Wed Jan 06 14:39:16 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_select_db(): supplied argument is not a valid MySQL-Link resource in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 6, referer: http://www.mywebsite.nl/
[Wed Jan 06 14:39:16 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_query(): supplied argument is not a valid MySQL-Link resource in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 18, referer: http://www.mywebsite.nl/
[Wed Jan 06 14:39:26 2010] [error] [client 127.0.0.1] (20024)The given path misformatted or contained invalid characters: Cannot map GET /:// HTTP/1.1 to file, referer: http://www.mywebsite.nl/component/option,com_smf/Itemid,81/
[Wed Jan 06 14:39:26 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'knr2788_sitemap'@'localhost' (using password: YES) in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 4, referer: http://www.mywebsite.nl/component/option,com_smf/Itemid,81/
[Wed Jan 06 14:39:26 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_select_db(): supplied argument is not a valid MySQL-Link resource in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 6, referer: http://www.mywebsite.nl/component/option,com_smf/Itemid,81/
[Wed Jan 06 14:39:26 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_query(): supplied argument is not a valid MySQL-Link resource in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 18, referer: http://www.mywebsite.nl/component/option,com_smf/Itemid,81/
[Wed Jan 06 14:39:37 2010] [error] [client 127.0.0.1] (20024)The given path misformatted or contained invalid characters: Cannot map GET /:// HTTP/1.1 to file, referer: http://www.mywebsite.nl/component/option,com_smf/Itemid,81/action,login
[Wed Jan 06 14:39:37 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'knr2788_sitemap'@'localhost' (using password: YES) in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 4, referer: http://www.mywebsite.nl/component/option,com_smf/Itemid,81/action,login
[Wed Jan 06 14:39:37 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_select_db(): supplied argument is not a valid MySQL-Link resource in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 6, referer: http://www.mywebsite.nl/component/option,com_smf/Itemid,81/action,login
[Wed Jan 06 14:39:37 2010] [error] [client 127.0.0.1] PHP Warning:  mysql_query(): supplied argument is not a valid MySQL-Link resource in E:\\server2go\\htdocs\\autositemap\\autositemap.php on line 18, referer: http://www.mywebsite.nl/component/option,com_smf/Itemid,81/action,login
[Wed Jan 06 14:39:48 2010] [error] [client 127.0.0.1] PHP Fatal error:  Call to undefined function db_insert_id() in E:\\server2go\\htdocs\\components\\com_smf\\smf.php on line 908, referer: http://www.mywebsite.nl/component/option,com_smf/Itemid,81/action,login


Offline DukeN

  • Semi-Newbie
  • *
  • Posts: 42
Rule 908 on smf.php: $memberID = db_insert_id();

More in this colum around rule 908.

//There must be a result, so let's write this one into SMF....
      mysql_query("
         INSERT INTO {$db_prefix}members
            (memberName, realName, passwd, emailAddress, dateRegistered, ID_POST_GROUP, lngfile, buddy_list, pm_ignore_list, messageLabels, personalText, websiteTitle, websiteUrl, location, ICQ, MSN, signature, avatar, usertitle, memberIP, secretQuestion, additionalGroups)
         VALUES ('$username', '$name', '$mos_user[password]', '$mos_user[email]', $mos_user[dateRegistered], '4', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '')");
      $memberID = db_insert_id();
      
      updateStats('member', $memberID, $name);
         
      mysql_query("
         UPDATE {$db_prefix}log_activity
         SET registers = registers + 1
         WHERE date ='" . date("Y-m-d") . "'
         LIMIT 1");
            
      return 'retry';

Offline DukeN

  • Semi-Newbie
  • *
  • Posts: 42
It looks like it has someting to do with the Joomla 1.x and SMF Bridge. The SMF bridge is created for SMF 1.x. The bridge isn't nessesary because users only use there accounts on the forum. Not the entire website. But the forum should be wrapped, and the bridge is doing this also.

When i change the code
$memberID = db_insert_id();
to
$memberID = mysql_insert_id();

The 500 error doens't come up but SMF wants to change the password for the users because it of security issues. This can't be done. There isn't any error coming up when changing the password. So i'm back to the start :( 

Offline greyknight17

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 14,890
  • Gender: Male
    • Kevin's Resource Center
Re: 500 Error Internal server error - When login in the Forum (after upgrade)
« Reply #4 on: February 04, 2010, 07:53:45 PM »
Do you still need assistance on this? I will move this to the Joomla Bridge support board so it gets the proper attention.

Offline Kindred

  • The Mean One
  • Local Moderator
  • SMF Master
  • *
  • Posts: 40,200
  • Gender: Male
    • wagner999 on Facebook
    • Kindred-999 on GitHub
    • www.linkedin.com/in/wdwagner/ on LinkedIn
    • @Kindred_999 on Twitter
Re: 500 Error Internal server error - When login in the Forum (after upgrade)
« Reply #5 on: February 05, 2010, 08:44:56 AM »
the joomla bridge which was released officially does not support smf 2.0 at all...

note: the bridge has been withdrawn for a while now
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support forums.  Thank you.

Offline 青山 素子

  • Server Team
  • SMF Super Hero
  • *
  • Posts: 16,512
  • 戦場ヶ原、蕩れ!
    • motokochan on GitHub
    • @motokochan on Twitter
    • Animeneko Network
Re: 500 Error Internal server error - When login in the Forum (after upgrade)
« Reply #6 on: February 11, 2010, 04:52:38 PM »
If you just want to "wrap" the forum, look at making a custom theme. There are plenty of tutorials on this site for adding custom code around the forum.
Motoko-chan
Director, Simple Machines

Just like... making of enemies / 負ける気しない やめるきない / You are cool but fool - Charisma.com 『HATE』

Note: I am not a member of the Simple Machines Forum project.