Advertisement:

Author Topic: email Inactive Users  (Read 20911 times)

Offline Suki

  • Developer
  • SMF Super Hero
  • *
  • Posts: 13,843
  • Kaizoku Jotei
    • Free SMF mods
Re: email Inactive Users
« Reply #140 on: June 17, 2015, 09:36:38 AM »
You are prob using an outdated version of SMF, it you search this topic it has been mentioned a few times already, its not really a major bug and it goes away as soon as you select a membergroup or update to SMF 2.0.10

I'm using SMF 2.0.10. All file versions are up-to-date.

I saw your response in this reply:

http://www.simplemachines.org/community/index.php?topic=521464.msg3706248#msg3706248

I've tried setting "Disable the deletion of users feature". The log messages continue no matter what this option is set to. I've also tried selecting a membergroup and that doesn't seem to change anything, either.

The "Disable the deletion of users feature" has nothing to do with this issue, it was something the other user asked for, not relevant to your issue.

You need to select a membergroup and SAVE the changes.

If you are indeed using 2.0.10 then on your ./Sources/ManageServer.php file you should have this exact same line:


Code: [Select]
$context['config_vars'][$config_var[1]]['value'] = !empty($context['config_vars'][$config_var[1]]['value']) ? unserialize($context['config_vars'][$config_var[1]]['value']) : array();
Thats the line that fixes your issue and it has been included in SMF 2.0.9.
No todos son tán malos, no todo está mal
No todos son villanos queriéndote matar
No todo está perdido ni se va a acabar
La vida es un picnic.

Offline sah62

  • Semi-Newbie
  • *
  • Posts: 61
Re: email Inactive Users
« Reply #141 on: June 18, 2015, 10:28:05 AM »
The "Disable the deletion of users feature" has nothing to do with this issue, it was something the other user asked for, not relevant to your issue.

You need to select a membergroup and SAVE the changes.

If you are indeed using 2.0.10 then on your ./Sources/ManageServer.php file you should have this exact same line:


Code: [Select]
$context['config_vars'][$config_var[1]]['value'] = !empty($context['config_vars'][$config_var[1]]['value']) ? unserialize($context['config_vars'][$config_var[1]]['value']) : array();
Thats the line that fixes your issue and it has been included in SMF 2.0.9.

That line is present exactly as written above.

One thing I noticed, though: I can't seem to save membergroup selections. I can select multiple groups, but when I click on "Save" to save the settings they are not selected when the page is redisplayed. Should the groups be visibly selected after saving the settings?

Offline Suki

  • Developer
  • SMF Super Hero
  • *
  • Posts: 13,843
  • Kaizoku Jotei
    • Free SMF mods
Re: email Inactive Users
« Reply #142 on: June 18, 2015, 10:37:42 AM »
Can you attach your Sources/ManageServer.php file here please.

Does your host allows serialize() to be used?

Does the other settings gets saved correctly?
No todos son tán malos, no todo está mal
No todos son villanos queriéndote matar
No todo está perdido ni se va a acabar
La vida es un picnic.

Offline sah62

  • Semi-Newbie
  • *
  • Posts: 61
Re: email Inactive Users
« Reply #143 on: June 18, 2015, 11:09:21 AM »
Can you attach your Sources/ManageServer.php file here please.

File attached.

Quote
Does your host allows serialize() to be used?

Yes, I run my own server. PHP version is PHP 5.5.9-1ubuntu4.9.

Quote
Does the other settings gets saved correctly?

Yes, it seems so. I can check and uncheck options, enter integer values, and set text for email just fine.  The only issue appears to be with saving group selections.