SMF Support > Install and Upgrade Help

[SOLVED] Cannot install SMF 2.02. Php errors / warnings on my local server.

(1/9) > >>

AndrzejL:
Hi folks.

I have been registered with many different forums and I must say I like SMF software based forums the most. I am running my small server using PCLinuxOS as a OS with Wordpress (no php / mysql problems) on it.

About 3 days ago I have decided to start running a little forum (even if just for LAN). Just to get myself familiarized with administration / possibilities / mods and so on.

I did my basic research and I have confirmed that basic download.simplemachines.org/requirements.php requirements are met.

I have downloaded SMF 2.02 onto my server and went to localhost:10101/forum

Why 10101? It is the port that http server runs at and the smf tarball was extracted to the /forum folder in my root www directory hence the addy.

1. Installation started no problem. Click continue. Fine.

2. Next step - I had to chmod 777 some folders / files on the server and re-check for writing permissions - all good.

3. Next step also no problems, localhost as a database host, in the same time created a quick database lets say forumdb with all privs granted to user forumadm on localhost and with password let's say SuperStrongPassword ;). I have confirmed that the base exists and that user is granted to perform all the necessary operations using phpMyAdmin. I have filled all the info and I have continued to the next step.

4. Here (which I discovered later after changing /etc/php.ini to display errors) first errors occur. I get this:


--- Quote ---Notice: Undefined variable: db_server in /media/WWW_Server/www/html/forum/install.php on line 810

Notice: Undefined variable: db_name in /media/WWW_Server/www/html/forum/install.php on line 810

Notice: Undefined variable: db_user in /media/WWW_Server/www/html/forum/install.php on line 810

Notice: Undefined variable: db_passwd in /media/WWW_Server/www/html/forum/install.php on line 810

Notice: Undefined variable: db_name in /media/WWW_Server/www/html/forum/install.php on line 841
--- End quote ---

but nevertheless I didn't saw them at first - so I filled in all the details like Forum name, Forum URL, first three boxes checked, forth about the info gathering unchecked and went to next step.

5. Blank screen. Nothing. Zip. Zero. Nada. Big bobkas... After I have modified php.ini to display errors I got this:


--- Quote ---Warning: require_once(/media/WWW_Server/www/html/forum/Sources/Subs-Db-.php) [function.require-once]: failed to open stream: No such file or directory in /media/WWW_Server/www/html/forum/install.php on line 357

Fatal error: require_once() [function.require]: Failed opening required '/media/WWW_Server/www/html/forum/Sources/Subs-Db-.php' (include_path='.:/usr/lib/php/:/usr/share/pear/:/usr/share/php/') in /media/WWW_Server/www/html/forum/install.php on line 357
--- End quote ---
.

I have been googling this and never really got to solve the whole thing so if You could please help me with it - I would appreciate it.

Regards.

Andrzej

NanoSector:
Did you modify Install.php yourself? And what PHP version are you running?

AndrzejL:

--- Quote from: Yoshi2889 on June 05, 2012, 10:32:50 AM ---Did you modify Install.php yourself? And what PHP version are you running?

--- End quote ---

Thanks for replying.

I did not modified install.php in any way kind sir.

Php version + related mods and so on:


--- Quote ---[andrzejl@icsserver ~]$ rpm -qa | grep php
php-filter-5.3.3-2pclos2011
php-pdo-5.3.3-2pclos2011
php-xmlwriter-5.3.3-2pclos2011
php-mysql-5.3.3-2pclos2011
php-devel-5.3.3-2pclos2011
php-tokenizer-5.3.3-2pclos2011
php-imap-5.3.3-2pclos2011
php-session-5.3.3-2pclos2011
phpMyAdmin-3.4.10.1-1pclos2012
php-eaccelerator-0.9.6.1-1pclos2010
php-json-5.3.3-2pclos2011
php-cli-5.3.3-2pclos2011
php-mcrypt-5.3.3-2pclos2011
php-ftp-5.3.3-2pclos2011
php-sysvshm-5.3.3-2pclos2011
php-gd-5.3.3-2pclos2011
php-xml-5.3.3-2pclos2011
php-ini-5.3.3-0.1pclos2010
php-xmlreader-5.3.3-2pclos2011
php-eaccelerator-admin-0.9.6.1-1pclos2010
php-posix-5.3.3-2pclos2011
php-zlib-5.3.3-2pclos2011
php-timezonedb-2009.18-2pclos2010
php-suhosin-0.9.32.1-1pclos2010
apache-mod_php-5.3.3-3pclos2011
libphp5_common5-5.3.3-2pclos2011
php-hash-5.3.3-2pclos2011
php-dom-5.3.3-2pclos2011
php-pdo_sqlite-5.3.3-2pclos2011
php-mbstring-5.3.3-2pclos2011
php-sysvsem-5.3.3-2pclos2011
php-bcmath-5.3.3-2pclos2011
php-openssl-5.3.3-2pclos2011
php-gettext-5.3.3-2pclos2011
php-ctype-5.3.3-2pclos2011
[andrzejl@icsserver ~]$
--- End quote ---

Regards.

Andy

AndrzejL:
Any other questions that might be useful?

Any known solutions?

Any hunches?

Thanks in advance.

Regards.

Andy

CapadY:
Did you edit your settings.php ?

If not, open it and take a look at the settings if they are right.

Navigation

[0] Message Index

[#] Next page

Go to full version