Customizing SMF > Modifications and Packages

Related Topics

<< < (131/139) > >>

mageguild:
I am trying to remove this mod, but I get this error:


--- Quote ---This package cannot be uninstalled, because there is no uninstaller!

Please contact the mod author for more information.
--- End quote ---

How can I uninstall it?

phantomm:
Don't know if someone posted solution for "The used table type doesn't support FULLTEXT indexes"
but this is how I solved it:

1. Login to phpMyAdmin
2. Select database
3. !!! Make backup !!!
4. Run this query (replace PREFIX_ with your db prefix!):

--- Code: ---CREATE TABLE IF NOT EXISTS PREFIX_related_subjects (
id_topic int(10) unsigned NOT NULL,
subject tinytext NOT NULL,
PRIMARY KEY (id_topic),
FULLTEXT KEY subject (subject)
) ENGINE=MyISAM;

--- End code ---

5. Open file ./Sources/Subs-RelatedFulltext.php
6. Find:

--- Code: --- global $smcFunc, $db_prefix;

$smcFunc['db_query']('', '
DROP TABLE IF EXISTS ' . $db_prefix . 'related_subjects',
array('security_override' => true)
);

$smcFunc['db_query']('', '
CREATE TABLE IF NOT EXISTS ' . $db_prefix . 'related_subjects (
id_topic int(10) unsigned NOT NULL,
subject tinytext NOT NULL,
PRIMARY KEY (id_topic),
FULLTEXT KEY subject (subject)
)',
array('security_override' => true)
);

return true;

--- End code ---

Replace it with:

--- Code: --- /*global $smcFunc, $db_prefix;

$smcFunc['db_query']('', '
DROP TABLE IF EXISTS ' . $db_prefix . 'related_subjects',
array('security_override' => true)
);

$smcFunc['db_query']('', '
CREATE TABLE IF NOT EXISTS ' . $db_prefix . 'related_subjects (
id_topic int(10) unsigned NOT NULL,
subject tinytext NOT NULL,
PRIMARY KEY (id_topic),
FULLTEXT KEY subject (subject)
)',
array('security_override' => true)
);

return true;*/

--- End code ---

7. Save and upload file
8. Rebuild indexes :)
9. Post reply in this topic and let me know if this worked for you :)

:

--- Quote ---Don't know if someone posted solution for "The used table type doesn't support FULLTEXT indexes"
--- End quote ---

This error is only going to become more common as MySQL 5.5+ makes InnoDB default, not MyISAM.

Armada:

--- Quote from: phantomm on July 06, 2012, 02:38:43 PM ---Don't know if someone posted solution for "The used table type doesn't support FULLTEXT indexes"
but this is how I solved it:

--- End quote ---

Is your fix a way of getting round having InnoDB tables?

:
Yes, essentially. InnoDB is now default, the above basically just forces them to be MyISAM on creation, an option not explicitly given by the standard DB library, and otherwise it just creates what is the system default.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version