Advertisement:

Author Topic: Installing on PostgreSQL: "Cannot connect to the database server..." error  (Read 12788 times)

Offline Dikw002

  • Newbie
  • *
  • Posts: 1
I decided compare engines MyBB, phpBB and SMF.

MyBB and phpBB where installed whithout problems. But SMF 2.0 has an error on second step of installation.


Critical Error!
Cannot connect to the database server with the supplied data.

If you are not sure about what to type in, please contact your host.


All setting like "Server name", "username" and so on where checked many times and are absolutely correct. There wasn't any connection indeed. PostgreSQL debug logs show me absence of connection attempts. I suppose it's an engine proplem

My server configuration:
Apache 1.3.34
php 5.2.0
PostgreSQL 7.4.17

PHP use pgsql (not pdo_psql) extention.
PostgreSQL(libpq) Version    8.1.18

Offline Nibogo

  • SMF Hero
  • ******
  • Posts: 6,543
  • Gender: Male
    • smfpacks on Facebook
    • @smfpacks on Twitter
    • SMFPacks
PostgreSQL 8.0 (or higher) is required, ask your hosting company to update to latest version, there SMF should be installed without any errors.