Advertisement:

Author Topic: You don't have permission to access /index.php on this server.  (Read 42582 times)

Offline xertech

  • Semi-Newbie
  • *
  • Posts: 33
Hello All and thanks in advance for any support for the following problem.

I have 2.0 Beta 3.1 ...
Last night i was responding to a post and when I hit the "post" button a

Forbidden

You don't have permission to access /index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an
ErrorDocument to handle the request


popped up.

Did a complete deinstall and reinstall but encountered the same problem.

what am I missing ?

All the post's are still there and I don't see any other problems with the site, it seems to be a permission problem but have know idea where...
« Last Edit: August 19, 2008, 09:41:17 PM by xertech »

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: You don't have permission to access /index.php on this server.
« Reply #1 on: August 19, 2008, 09:48:55 PM »
Does this problem occur all the time?

Offline xertech

  • Semi-Newbie
  • *
  • Posts: 33
Re: You don't have permission to access /index.php on this server.
« Reply #2 on: August 19, 2008, 09:50:48 PM »
no _ only when posting...   

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: You don't have permission to access /index.php on this server.
« Reply #3 on: August 19, 2008, 09:51:24 PM »
No, I meant does this occur every time you attempt to post?

Offline xertech

  • Semi-Newbie
  • *
  • Posts: 33
Re: You don't have permission to access /index.php on this server.
« Reply #4 on: August 19, 2008, 09:53:18 PM »
Sorry, yes everytime .  And thanks for the help!

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: You don't have permission to access /index.php on this server.
« Reply #5 on: August 19, 2008, 09:57:30 PM »
Usually this error occurs because of the host-- not the forum itself. I suggest contacting the host and presenting them the issue.

However just to be sure, make sure all your forum directories are CHMODED to the correct intervals and that index.php exists in the main SMF directory (check the contents and make sure it has code in it).

How do I chmod? / What is chmod?

Likewise, it could (small chance) be a path problem. So try to run repair_settings.php in your main directory and click the recommended values.

What is repair_settings.php?

Also, what version of PHP are you running? What server environment? Did you recently move your forum to another host?

Offline xertech

  • Semi-Newbie
  • *
  • Posts: 33
Re: You don't have permission to access /index.php on this server.
« Reply #6 on: August 19, 2008, 09:59:27 PM »
Cool _ I will check the permissions and run the repair script , again thanks for the advice and will let you know how it goes...




cPanel Version 11.23.4-STABLE
cPanel Build 26138
Theme x3
Apache version 1.3.37 (Unix)
PHP version 4.4.2
MySQL version 4.1.22-standard-log
Architecture i686
« Last Edit: August 19, 2008, 10:03:59 PM by xertech »

Offline xertech

  • Semi-Newbie
  • *
  • Posts: 33
Re: You don't have permission to access /index.php on this server.
« Reply #7 on: August 20, 2008, 02:23:03 PM »
UPDATE  .    All the permissions are correct, ran the repair script and checked for any errors on my database but still having the same problem..

This morning I logged on with my Blackberry and was able to post !  Thought the problem went away but as soon as I logged on with my laptop I was given the same error message.   

Thanking it was a cookie problem, i phoned one of the members in Orlando Fl and he had he same error message ..

So Blackberry OK ,  PC not OK ...  I left a service ticket with my host provider and waiting for their return message, so i hope its something on the host side and not the SMF side..

FYI  _  just installed another forum in a different location on the same server (different dbase also) and the same problem occurs __ it has to be a problem with the hosting company and not the SMF forum... I'll let you know what their answer is after I finally get one.

« Last Edit: August 20, 2008, 02:50:05 PM by xertech »

Offline RL Joneson

  • Jr. Member
  • **
  • Posts: 100
  • Gender: Male
  • RL Joneson. Design. Web. Print.
    • RL Joneson. Design. Web. Print.
Re: You don't have permission to access /index.php on this server.
« Reply #8 on: August 21, 2008, 02:16:25 PM »
When you say "another forum" do you mean a completely new one? Or are you using altered .temps from the forum you are having trouble with?

« Last Edit: August 21, 2008, 02:28:14 PM by RL Joneson »

Offline xertech

  • Semi-Newbie
  • *
  • Posts: 33
Re: You don't have permission to access /index.php on this server.
« Reply #9 on: August 21, 2008, 08:58:56 PM »
Yeh _another forum with a different database.    The hosting company fixed the problem, they haven't gotten back to me yet but it was the hosting company that caused the problem and not the forum software.

Offline RL Joneson

  • Jr. Member
  • **
  • Posts: 100
  • Gender: Male
  • RL Joneson. Design. Web. Print.
    • RL Joneson. Design. Web. Print.
Re: You don't have permission to access /index.php on this server.
« Reply #10 on: August 25, 2008, 12:36:45 PM »
Did they mention what the issue was??

Offline Rumbaar

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,804
  • Gender: Male
  • Inherent Omniscience
    • Rumbaar.net
Re: You don't have permission to access /index.php on this server.
« Reply #11 on: September 05, 2008, 07:00:47 PM »
Probably some kind of mod_security or security setting.  It hard when they do things like this to troubleshoot.

If this is solved feel free to mark it as solved otherwise reply.  To mark an issue solved please change the first post message icon to the 'tick' icon.
 
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Offline N3RVE

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,906
  • Gender: Male
    • N3RVE.COM
Re: You don't have permission to access /index.php on this server.
« Reply #12 on: February 08, 2009, 09:32:07 AM »
Marked as solved, if you're still experiencing issues, feel free to respond with details of what isn't working :)

-[n3rve]
Ralph "[n3rve]" Otowo
Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote
“Somewhere, something incredible is waiting to be known.” - Carl Sagan

Offline liamtoo

  • Semi-Newbie
  • *
  • Posts: 75
Re: You don't have permission to access /index.php on this server.
« Reply #13 on: November 29, 2011, 08:19:34 AM »
I know this is an old topic but my experience might help anyone searching for a solution. I too had this problem. In my case it was an overzealous mod_security. My host was blocking certain words and word strings. So try changing your message content line by line and select preview each time. If that is the problem it'll be obvious.