Customizing SMF > Portals, Bridges, and Integrations

New tools to help integrating SMF with something else

<< < (14/32) > >>

frytec:
@ andre,

check it:

--- Quote from: errorlog ---[27-Feb-2012 18:20:41] PHP Fatal error: The database value you're trying to insert does not exist: member_ip(smf_2_api.php-1595) in /home/aikaforum/cata/public_html/forum/Sources/Subs-Db-mysql.php on line 684
[27-Feb-2012 18:23:25] PHP Fatal error: The database value you're trying to insert does not exist: p_member_ip(smf_2_api.php-2522) in /home/aikaforum/cata/public_html/forum/Sources/Subs-Db-mysql.php on line 684
[27-Feb-2012 18:23:26] PHP Notice: Undefined index: USER_AGENT in /home/aikaforum/cata/public_html/forum/smf_2_api.php on line 1875
--- End quote ---

Andre N:
When you're registering members, the script is trying to use $user_info['ip'] to register the user's IP address with their other info, but it looks like that isn't being set for some reason.
Try calling loadUserSettings() before you register them to try to get the IP.
If that doesn't work, try changing $user_info['ip'] for $_SERVER['REMOTE_ADDR'] on ~line 1475
Is that server variable set? Are you running this on localhost?

frytec:
@andre, its running on the server,
i changed the ip thing but that didnt help.
it still not registering.
do you think if i throw my full function here will help your visualization?
or maybe you want to login to my ftp.. idk..

Andre N:

--- Quote from: frytec on February 28, 2012, 02:52:06 PM ---@andre, its running on the server,
i changed the ip thing but that didnt help.
it still not registering.
do you think if i throw my full function here will help your visualization?
or maybe you want to login to my ftp.. idk..


--- End quote ---

Hi frytec,
I updated the API to 0.1.2 to fix the issue with those variables being unset, the logout trouble, the magic quotes issue, and anything else mentioned in the previous threads. This should take care of your problem with registering. Can you download the new version (from the first post of this thread) and upload it and try it out?
Try the login, logout too as I modified them a little bit. If it doesn't work still can you post the error message from the log or pm me a temporary ftp account and the location of your script? :)

frytec:
ok, im gona test the new version of api, justo to clarify, whats the correct usage of logout function?

smfapi_logout();

or

smfapi_logout($username);

or

smfapi_loadUserSettings(); smfapi_logout();

?

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version