Customizing SMF > Modifications and Packages

Pretty URLs 1.0 - Updated for SMF 2.0

<< < (1330/1418) > >>

Update: I installed a clean copy of 2.0.2 with no mods, and then duplicated and installed my MySQL database that has ~2,000 accounts/members. I was able to successfully send out ~2,000 eMails through SMF with no errors.

--- Quote from: iverSUN on April 20, 2012, 12:20:34 PM ---ERROR
I'm trying to send out an HTML newsletter via eMail, and I'm having some problems.

--- Quote ---Fatal error: Maximum execution time of 30 seconds exceeded in /Sources/PrettyUrls-Filters.php on line 269
--- End quote ---

I've turned on Mail Que settings (set to 40 emails per minute, 3 emails per page load) to help throttle the server and keep load down. It adds about 67 email addresses to the que, out of ~2,000.

I've also added the action "admin" to the skip actions area, so PrettyURLs isn't doing anything for the admin area. The link looks like:;area=news;sa=mailingsend

--- End quote ---

Scratching my Head:
Hi. I know this will probably seem redundant, and maybe even obvious.
I thought I'd post it in the hopes it may help someone.

May be it is even a type of a bug. Depending upon your definition of a bug.

When receiving the internal server error, check to make sure the htaccess file created by the mod is correct.

Entirely correct.

Here is what I mean.

I set up a test forum. I even called it: Test Forum

When the mod creates the htaccess file it goes like this:

# Pretty URLs mod
# .htaccess file generated automatically on: May 5, 2012, 12:08

RewriteEngine on
RewriteBase /Test Forum

--- End code ---

See the problem?

It should write it like this:

# Pretty URLs mod
# .htaccess file generated automatically on: May 5, 2012, 12:08

RewriteEngine on
RewriteBase /Test%20Forum
--- End code ---

making sure that the %20 is there.

Every change to the htaccess file brings back the space instead of writing %20

I know.
I know.
I know.

Test Forum is sloppy coding. (shrug)

Just hope this helps someone who may, innocently create a forum with a space.

Hope all are well!

: o )

Hi all

I've just installed the mod and almost everything seems to work ok. The problem I have is that it prevents the use of alternate stylesheets that are set up for our theme, once the mod is enabled the default stylesheet colour is the one that shows regardless of the one selected.

Any ideas what to change to allow the alt stylesheets to work?

Update: I've disabled the mod for the time being, if it helps you can view the site with it's alt stylesheet selection (top right corner) working here

is Pretty URL possible to mod for Asian Language Topic (UTF-8)

like wordpress

u can rewrite fowllowing topic to URL base

--- Code: ---生年1993/

--- End code ---


Just reported a bug @

It is untested, but by the results of a script I am working on SQLite3 Cache, I am sure that Pretty Url's suffers the same fate.

It seems when SMF's database is SQLite any SQLite database request from inside the callback function ob_sessrewrite() causes the script to exit without any output, no errors and no database activity.

This is not a SMF bug, it seems to be related to ob_start()'s callback function and SQLite.

You can see the problem though, even with SMF's database layer there is no way at this time to add compatibility with database calls from within ob_sessrewrite().


[0] Message Index

[#] Next page

[*] Previous page

Go to full version