Simple Machines Community Forum

SMF Support => SMF 2.0.x Support => Topic started by: JonnieP on March 19, 2017, 05:19:47 AM

Title: Pages not refreshing when deleting or marking as read
Post by: JonnieP on March 19, 2017, 05:19:47 AM
Forum is running on 2.0.11. Following recent server upgrade when deleting a post, or marking posts as read the page on which they are displayed does not refresh. I have tried to overcome this by removing the access to cached pages without success. Server error logs show an image file is missing, on checking directory this is not the case.

Any ideas?
Title: Re: Pages not refreshing when deleting or marking as read
Post by: Illori on March 19, 2017, 06:18:15 AM
first upgrade to SMF 2.0.13 for security. most likely it will not fix the issue but your forum will be more secure. are you using a custom theme or the default theme? if a custom theme try it on the default theme and see what happens.
Title: Re: Pages not refreshing when deleting or marking as read
Post by: JonnieP on March 19, 2017, 04:13:07 PM
Upgraded and using default theme no improvement
Title: Re: Pages not refreshing when deleting or marking as read
Post by: Colin on March 19, 2017, 11:05:58 PM
Can you give us some details about the server upgrade and perhaps server configuration changes along with that which you performed?
Title: Re: Pages not refreshing when deleting or marking as read
Post by: JonnieP on March 20, 2017, 07:45:34 PM
Hi Colin,
The Server upgrade was undertaken by the hosting company (Krystal). I have contacted them and finally received a reply suggesting that the issue was a "developer matter" and that they could not help.This left me p'd off. I have now installed another instance of SMF completely vanilla using a different URL. I have then populated this with a number of members and added posts. The unread posts are not cleared when the action to do so is selected and the page does not refresh. The version is 2.0.11 (as this is the only one that Instaltron supports)

This suggests to me that this is a server or connection issue


Can you give us some details about the server upgrade and perhaps server configuration changes along with that which you performed?
Title: Re: Pages not refreshing when deleting or marking as read
Post by: Linkjay on March 20, 2017, 08:35:16 PM
Hi Colin,
The Server upgrade was undertaken by the hosting company (Krystal). I have contacted them and finally received a reply suggesting that the issue was a "developer matter" and that they could not help.This left me p'd off. I have now installed another instance of SMF completely vanilla using a different URL. I have then populated this with a number of members and added posts. The unread posts are not cleared when the action to do so is selected and the page does not refresh. The version is 2.0.11 (as this is the only one that Instaltron supports)

This suggests to me that this is a server or connection issue


Can you give us some details about the server upgrade and perhaps server configuration changes along with that which you performed?

Can you try looking in your Javascript console to see if any errors popup before or after you try to do it? You could also edit it to make it refresh manually.
Title: Re: Pages not refreshing when deleting or marking as read
Post by: Illori on March 21, 2017, 05:09:57 AM
how did you populate it with members and added the posts? i have a feeling you did not do this part correctly which is adding to your problems.
Title: Re: Pages not refreshing when deleting or marking as read
Post by: JonnieP on March 21, 2017, 05:47:29 AM
In answer to Ilori. I added members using the normal admin function, and then used logins to create posts.

The forum is now upgraded to 2.0.13.

I have looked at the server error logs and the following appear (routinely after trying to mark posts as read)

File not found (information redacted)/Themes/default/images/english_british-utf8/new.gif]
2017-03-21 09:13:09.328 [INFO] (information redacted) File not found [/home/bfbdadbb/website.club/404.shtml]
2017-03-21 09:13:09.328 [INFO] (information redacted) File not found [/home/bfbdadbb/website.club/robots.txt]

Note I have redacted information on ip addresses and server names
Title: Re: Pages not refreshing when deleting or marking as read
Post by: Illori on March 21, 2017, 05:58:48 AM
those are not related to the issue at hand. you can add the new.gif to the folder mentioned and that will resolve that issue. the robots.txt is not a big issue either you can create the file if you need to.