SMF Support > Español (Spanish)

Editor de texto WYSIWYG (tipo Word) para SMF 1.1.2

(1/15) > >>

videoed:
Actualizado el 10/06/07:

Hoteditor es un editor WYSIWYG que te permite editar mensajes sin necesidad de usar el código BBC usado en SMF por defecto. Es decir, es como editar en Word o cualquier otro editor de texto en el que vas viendo el texto formateado mientras lo escribes. Puedes echarle un vistazo a HotEditor aquí:

http://www.ecardmax.com/hoteditor/index.php
http://www.ecardmax.com/smf_111/index.php?action=post;board=1.0

Hoteditor permite elegir qué editor usar. Esa opción, además, se guarda junto con otras preferencias de usuario de modo que cada usuario edita como prefiere.

Para instalar Hoteditor en tu instalación SMF 1.1.2 debes hacer lo siguiente:

Descarga el archivo de instalación:
http://www.colegiodelaesperanza.com/descargas/varios/smf/hoteditor_4.2_SMF_spanish.zip

Sigue las instrucciones que encontrarás en el archivo Instrucciones.en.español.html que he adjutando en este mensaje por si quieres más información antes de instalarlo

IMPORTANTE: Si tienes instalada cualquier versión anterior de hoteditor ¡¡¡DESINSTÁLALA PRIMERO!!!

Las instrucciones son, básicamente, subir la carpeta richedit y el archivo hoteditor_quickedit.html al directorio de instalación de SMF y luego instalar el mod hoteditor.4.2_smf.1.1.2.zip desde el administrador de paquetes de tu instalación SMF.

Este mod está diseñado únicamente para la SMF 1.1.2 y no funcionará en ninguna otra versión. , aunque es muy sencillo adaptarlo a otras versiones editando el archivo package-info.xml y usando Yet Another Mod Editor, que puedes bajar de aquí:

http://www.colegiodelaesperanza.com/descargas/varios/smf/YaME.zip

Para instalar en otras versiones de SMF 1.1.x (o RCx) sigue estas instrucciones:

En el archivo hoteditor.mod se busca esta línea en index.php:


--- Code: ---$forum_version = 'SMF 1.1.2';
--- End code ---

Si vas a usar el mod en otra versión indica aquí la versión que tengas instalada en tu foro (supongo, aunque no lo he probado, que funcionará en toda las 1.1.x y 1.1 RCx anteriores a la 1.1.2)

En el archivo package-info.xml verás estas dos líneas:


--- Code: ---<install for="1.1.2">
--- End code ---

y


--- Code: ---<uninstall for="1.1.2">
--- End code ---

De nuevo, cambia 1.1.2 por la versión correspondiente. Puedes abrir los archivos package-info.xml y hoteditor.mod con cualquier editor de texto, como el bloc de notas de Windows.

A tener en cuenta que YaME genera archivos de instalación .mod, un formato desfasado. Actualmente se usan archivos .xml para definir las instalaciones. Sin embargo no encontrado una herramienta similar a YaME y que genere archivos .xml con la misma simplicidad. Puesto que mis archivos .mod funcionan y no ando precisamente muy sobrado de tiempo libre, he elegido este formato en lugar de actualizarme y aprender uno nuevo. Si alguien está por la labor seguro que sería de agradecer una versión .xml

Originalmente publiqué toda esta información aquí:

http://www.simplemachines.org/community/index.php?topic=22468.msg926573#msg926573

Lo publiqué ahí, en inglés, y no en este foro, por los siguientes motivos:

- Mayor difusión: El inglés es el idioma "oficial" del foro y un buen número de usuarios de SMF "chapurreamos" más o menos el inglés. Si alguien está realmente interesado, y a través del buscador del foro, sin duda localizaría la información.

- Continuidad: La disponibilidad de Hoteditor para SMF se publicó primeramente en ese hilo. Creo que lo correcto era continuarlo.

¿Por qué no publiqué también la información en este foro tal y como estoy haciendo ahora? Simple y llanamente por falta de tiempo. No os voy a contar mi vida, no os interesa, pero esta tarde estoy haciendo un importante esfuerzo por escribir este mensaje. Un usuario español encontró el hilo antes citado y, puesto que la página donde ofrezco el mod es española (www.colegiodelaesperanza.com) publicó algunos mensajes en español en aquel hilo pensando que daría soporte español. Esto me ha creado "cargo de conciencia" y por eso estoy "haciendo" hueco para publicar aquí.

Por los motivos anteriormente citados (mayor difusión y continuidad) salvo que disponga de tiempo seguiré publicando cualquier novedad únicamente en el hilo oficial en inglés. Rogaría a los usuarios de este foro que estén interesados en el mod y que hablen en inglés que, por favor, actualicen si pueden este hilo. Me resultaría muy complicado llevar simultáneamente la información en dos foros diferentes.

Por último decir para quienes no lo sepan que esta modificación es un tanto polémica por tres motivos que han sido largamente discutidos en otros hilos en inglés de este foro:

- Posibles agujeros de seguridad
- Mayor complejidad en la base de datos
- Mayor tiempo de carga y saturación en el servidor

No es recomendable, por tanto, para instalaciones SMF con grandes bases de datos ni aquellas que necesiten un especial control de seguridad. Los programadores de SMF suelen estar en contra de esta modificación. Por eso nunca se le ha prestado especial atención a esta modificación. No obstante supongo que habrá casos como el mío en el que esté justificado. En mi caso en particular un buen número de mis usuarios o son niños o tienen contacto casi nulo con las tecnologías de la comunicación e información, con lo que evitarles trabajar con código BBC supone, por un lado, evitarme largas y tediosas explicaciones y problemas por parte de los usuarios y, por otro, hacer que el uso del foro sea más agradable y apetecible. Que cada cual saque sus conclusiones; yo únicamente me limito a compartir algo que he modificado (no creado) y que creo que puede ser del interés de ciertos usuarios.

Un saludo a todos y gracias por vuestra comprensión

Ateneo:
Gracias Videoed. Lo he probado con la SMF 1.1 RC2  y funciona correctamente. Estoy intentando averirguar el bug con la imposibilidad de conmutar entre editor WySi y BBcode.  

eCardMax.com:
Hello guys!

Thank you for supporting this MOD. I just released the NEW WYSIWYG MOD for SMF 1.1.1 . This MOD used new technique to control the HTML post. It's more secure and won't increase your database size like the previous MOD that I made.

So, please check it out here: http://www.simplemachines.org/community/index.php?topic=149241.0

Thanks  

bigo:
gracias por tl timo de crear este tema, yo vi el de ingles pero nunca pude hacerlo correr... espero que ahora me funcione bien...
lo voy a probar en el 1.1.1

bigo:
puxa me surgio una duda... como se podria agregar otra funicon el editor, como los videos youtube y otras cosas... creo que lo preguntare en el foro en ingles auque mu ingles es remalito jeje

Navigation

[0] Message Index

[#] Next page

Go to full version