Advertisement:
NameCheap

Author Topic: Label - Bug  (Read 6711 times)

Offline Kettu

  • Sr. Member
  • ****
  • Posts: 711
  • Gender: Female
Label - Bug
« on: July 19, 2008, 01:05:00 AM »
Hi, I couldn't find that bug around here so I open a new topic.
I was working with labels today and labeled a few private messages. After labeling a message I deleted some others and checked twice that only those messages were checked I wanted to delete. Well all checked messages have been deleted including the messages I had labeled on that page before.
Same problem, but fortunately not deleted, a few minutes later. I labeled a message with "important" and than on the same page 2 messages with another label but finally found all 3 under the last chosen label.
So I think the refreshing function there isn't working correct. The labeled messages are still checked for the system but invisible :(
« Last Edit: August 15, 2008, 12:06:08 AM by SleePy »
Main Forum: SMF 2.0.6
Co-Forum: SMF 2.0.6

Offline SleePy

  • Site Team
  • SMF Master
  • *
  • Posts: 28,951
  • Gender: Male
  • Thats his happy face.
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: Label - Bug
« Reply #1 on: July 19, 2008, 08:24:06 PM »
This sounds more like a browser bug..

Did you try another browser?

What version of smf are you using?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub
G+

Offline Kettu

  • Sr. Member
  • ****
  • Posts: 711
  • Gender: Female
Re: Label - Bug
« Reply #2 on: July 25, 2008, 05:02:46 AM »
This sounds more like a browser bug..

Did you try another browser?
No, I didn't because I am using Firefox version 2.0.0.16 and 3. I have tested it at 2.0.0.16 again with the same result. I'll test it with the new version as soon as I can.
But I've tested it in another way right now. I've checked all boxes at the summery and deleted the checks at those I don't want to lavel. After labelling the checkboxes at the complete messages were empty but at the summery still checked.

What version of smf are you using?
As you see in my signature I am using 1.1.5.

Edit:
Okay, I've checked it with Firefox 3, same problem. The checkbox of the summery is still checked after labelling. Like shown in the screenshot.
« Last Edit: July 25, 2008, 10:01:50 AM by Kettu »
Main Forum: SMF 2.0.6
Co-Forum: SMF 2.0.6

Offline SleePy

  • Site Team
  • SMF Master
  • *
  • Posts: 28,951
  • Gender: Male
  • Thats his happy face.
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: Label - Bug
« Reply #3 on: July 26, 2008, 02:32:44 AM »
Do you have any mods installed?
Quickly tested and I didn't get it to occur.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub
G+

Offline Thantos

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 16,150
  • Gender: Male
Re: Label - Bug
« Reply #4 on: July 26, 2008, 12:48:28 PM »
Can you try it with the default theme and see if the problem still occurs.  In addition you mind trying it with Internet Explorer?  Thanks

Offline Kettu

  • Sr. Member
  • ****
  • Posts: 711
  • Gender: Female
Re: Label - Bug
« Reply #5 on: July 27, 2008, 10:29:13 AM »
Do you have any mods installed?
Quickly tested and I didn't get it to occur.
I have tested it in a forum without any mods with FF 3 but error still occurs.

Can you try it with the default theme and see if the problem still occurs.  In addition you mind trying it with Internet Explorer?  Thanks
I have tried it with default: error occurs.
I have tried it with Windows and Linux: error occurs.
I have tried it with Internet Explorer on a friend's laptop with his account: error still occurs.
« Last Edit: July 27, 2008, 10:30:54 AM by Kettu »
Main Forum: SMF 2.0.6
Co-Forum: SMF 2.0.6

Offline SleePy

  • Site Team
  • SMF Master
  • *
  • Posts: 28,951
  • Gender: Male
  • Thats his happy face.
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: Label - Bug
« Reply #6 on: July 27, 2008, 07:37:07 PM »
The code will keep messages selected if you previously selected them (to do something such as labeling the message).

It should be showing that those are selected.

Try this..
open PersonalMessage.template.php
Find:
Code: [Select]
                                        <input style="vertical-align: middle;" type="checkbox" name="pms[]" id="deletedisplay', $message['id'], '" value="', $message['id'], '" class="check" onclick="document.getElementById(\'deletelisting', $message['id'], '\').checked = this.checked;" />
Replace
Code: [Select]
                                        <input style="vertical-align: middle;" type="checkbox" name="pms[]" id="deletedisplay', $message['id'], '" value="', $message['id'], '"', $message['is_selected'] ? ' checked="checked"' : '', '  class="check" onclick="document.getElementById(\'deletelisting', $message['id'], '\').checked = this.checked;" />
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub
G+

Offline Kettu

  • Sr. Member
  • ****
  • Posts: 711
  • Gender: Female
Re: Label - Bug
« Reply #7 on: July 28, 2008, 11:11:40 AM »
Thanks SleePy, but now all checkboxes are still ckecked after labeling.
Main Forum: SMF 2.0.6
Co-Forum: SMF 2.0.6

Offline SleePy

  • Site Team
  • SMF Master
  • *
  • Posts: 28,951
  • Gender: Male
  • Thats his happy face.
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: Label - Bug
« Reply #8 on: July 28, 2008, 12:31:01 PM »
Yes, wouldn't that be the intent?
The checkboxes are there so that way you can quickly use them again to do something such as another label.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub
G+

Offline Kettu

  • Sr. Member
  • ****
  • Posts: 711
  • Gender: Female
Re: Label - Bug
« Reply #9 on: July 30, 2008, 10:12:00 AM »
Yes, wouldn't that be the intent?
The checkboxes are there so that way you can quickly use them again to do something such as another label.
Well, it is much better than before but shouldn't it be that all messages are unmarked after successful labeling?
Main Forum: SMF 2.0.6
Co-Forum: SMF 2.0.6