Advertisement:

Author Topic: Probleme beim Ausloggen und Administrator-Login  (Read 1608 times)

Offline Zipclaw

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
Probleme beim Ausloggen und Administrator-Login
« on: December 30, 2009, 07:50:05 AM »
Moin!

Bei meiner Testinstallation von SMF 1.1.10 habe ich seit neuestem das Problem, daß ich mich weder ausloggen, noch mich im Administratorpanel anmelden kann. Jedesmal kommt folgende Fehlermeldung:

Quote
Sitzungs-Check fehlgeschlagen. Bitte loggen Sie sich aus und versuchen Sie es erneut.

Das Cookie habe ich bereits gelöscht gehabt, woraufhin ich dann auch ausgeloggt war. Wiedereinloggen ging ohne Probleme (obwohl ich mehrere Versuche gebraucht habe, weil angeblich das Paßwort falsch wäre), aber wiederausloggen oder ins Administratorpanel komme ich dennoch nicht. Die Sitzungstabelle habe ich ebenfalls geleert, aber auch hier keine Besserung.

Das letzte mal, als ich die Testinstallation genutzt hatte, funktionierte alles bestens und ist gar nicht mal so lange her (ca. 1 Monat). Damals hatte ich das Board auch in den Wartungsmodus gesetzt. Kurz zuvor nahm ich auch ein Update auf 1.1.10 vor, aber auch danach lief alles einwandfrei. Alles was ich in der Zwischenzeit getan hatte, war die Forumsstruktur meines derzeiten, auf phpBB2-basierten Forums, per Hand zu übernehmen. Mehr habe ich seither nicht getan.

Was könnte da passiert sein und wie kann ich das beheben? Ich kann ja so überhaupt nichts machen!

Offline Zipclaw

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
Re: Probleme beim Ausloggen und Administrator-Login
« Reply #1 on: January 06, 2010, 03:53:26 AM »
Hat denn niemand eine Idee? :(

Offline ディン1031

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,599
  • Gender: Male
  • はるひ! :P
    • ~DIN1031
Re: Probleme beim Ausloggen und Administrator-Login
« Reply #2 on: January 07, 2010, 06:00:05 AM »
Cookie löschen und Browser Cache leeren... alternativ neuen cookie namen eintragen...
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Offline Zipclaw

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
Re: Probleme beim Ausloggen und Administrator-Login
« Reply #3 on: January 07, 2010, 06:20:42 AM »
Okay, Cookie löschen hatte nichts gebracht, aber einen neuen Cookienamen in Settings.php einzutragen hat das Problem gelöst. Da hätte ich früher drauf kommen müssen. Nun konnte ich endlich das Update auf 1.1.11 machen.

Vielen Dank! :D

Offline Zipclaw

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
Re: Probleme beim Ausloggen und Administrator-Login
« Reply #4 on: January 10, 2010, 05:53:02 PM »
Das kann doch wohl unmöglich die Lösung sein, oder? Jeden Tag, wenn ich das Forum aufrufe, mich anmelde und ins Adminstratorpanel hinein möchte, bekomme ich nach der Eingabe das Paßworts oben genannte Fehlermeldung. Beim Versuch mit auszuloggen, passiert wieder dasselbe.

Schön, ich kann das Problem vorübergehend lösen, wenn ich das Cookie lösche und den Browsercache leere. Dann funktioniert alles wieder ordnungsgemäß. Logge ich mich aus, und nach kurzer Zeit wieder ein, ist angeblich jedesmal das Paßwort falsch. Erst wenn ich den Cache leere, geht das wieder.

Gerade habe ich einen Test gemacht, mit einem Freund von mir, der sich vor Monaten in der Testinstallation testweise registriert hatte. Da er sein Paßwort vergessen hatte (sein letzter Login liegt mehrere Monate zurück), wollte er sich ein neues zuschicken lassen, aber es wird bei dem Versuch mit derselben Fehlermeldung abgeschmettert wie ich. Sogar Cookie löschen Browsercache leeren hilft hier nicht mehr weiter.

Ein anderer kann sich noch nicht einmal registrieren. Nach der scheinbar erfolgten Registrierung kann er sich nicht einloggen, weil der Benutzername nicht existiert. Eine Bestätigungsmail bekommt er auch nicht. In der Datenbank wird auch kein neuer Benutzer angelegt. Im Fehlerprotokoll ist nichts diesbezüglich zu finden.

Meiner Meinung nach gibt's hier ein erhebliches Problem!

Falls es irgendwie bei der Problemlösung hilft:

Quote
Versionsinformation:
Forum Version: SMF 1.1.11 (ausführlicher)
Aktuelle SMF Version: SMF 1.1.11
PHP Version: 5.2.5
MySQL Version: 4.1.21-Max
Server Version: Apache/2.0.48 (Fedora) PHP/4.4.7 FrontPage/5.0.2.2635
GD Version: bundled (2.0.34 compatible)

Offline Zipclaw

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
Re: Probleme beim Ausloggen und Administrator-Login
« Reply #5 on: January 19, 2010, 03:51:44 PM »
Das Problem besteht immer noch...