Advertisement:

Author Topic: 2.01 upgrade probs  (Read 1763 times)

Offline leegreaves

  • Semi-Newbie
  • *
  • Posts: 45
2.01 upgrade probs
« on: September 21, 2011, 04:00:27 AM »
Today I attempted to upgrade my forum to smf 2.01. I used the large upgrade from sm 2.0 (which i now wonder if it was wise to do this!). During installation it requested if i wanted to put forum into maintenace mode while the upgrade was in progress which I selected (but do not think this is the problem). The problem I am now getting is the following error:

Fatal error: Call to undefined function register_bar_mod_v3_scripts() in /home/rebelgam/public_html/forum/Sources/Load.php(2238) : eval()'d code on line 162

The website if any one in support needs to see this is: http://www.rebel-gamers.net

Ive tried several methods to try and revert back to smf 2.0 by overwriting ALL files with a backup, but alas to no avail, I still get this error message no matter what I do.

Any suggestions

Offline Kays

  • Customizer
  • SMF Hero
  • *
  • Posts: 8,973
  • Gender: Male
    • Kayssplace
Re: 2.01 upgrade probs
« Reply #1 on: September 21, 2011, 04:38:00 AM »
HI, it looks like that call is in your (old) theme which it's trying to load. Try adding ?theme=1 to the url to your forums to get the default theme to load.

http://www.rebel-gamers.net/forum/?theme=1

It didn't work for me but it might for you since your the admin.

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

Offline leegreaves

  • Semi-Newbie
  • *
  • Posts: 45
Re: 2.01 upgrade probs
« Reply #2 on: September 21, 2011, 04:46:00 AM »
nope didnt work still got the same error message come up

It seems to me that I may have made a MAJOR F-UP, I didnt backup my database :( and when i checked my databases on the server backend. The first check I made was in the smf_members table, and it showed only my name in there, it was as if when i updated it created a new account but completely wiped over everything else in that table.

Im getting the feeling im not gonna be able to recover from this and may have to totally start from scratch, Im gonna have a few unhappy clan members moaning at me and plus over 6 months hard work gone down the creek!!!

Offline Kays

  • Customizer
  • SMF Hero
  • *
  • Posts: 8,973
  • Gender: Male
    • Kayssplace
Re: 2.01 upgrade probs
« Reply #3 on: September 21, 2011, 05:06:29 AM »
OK, silly question maybe. But did you run upgrade.php to do the upgrade? If not, please do so

What it looks like is happening is that your old theme is being loaded and it has a call to a function added by a mod. Which no longer exists.

One more stab at switching to the default theme. Upload the attached file to the root of your forums and access it by url. The same as you did for upgrade.php.This should force the default theme to load.


If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

Offline leegreaves

  • Semi-Newbie
  • *
  • Posts: 45
Re: 2.01 upgrade probs
« Reply #4 on: September 21, 2011, 05:22:57 AM »
good news!!!

I imported the backup database to the forum database on my server backend. Now when I checked the smf version in my softaculous installer it was showing 1.1.13

So far so good...

At this point I tried to go to my site.

Not so far so good....


I then had the idea of installing the update through the softaculous page on my web backend. This updated the forum back to smf 2.01

Now when I tried to go to the site, *HEY PRESTO*, I managed to successfully recover the site. Even though its in the default theme. At least now I can begin to get everything back to how it should be! Seems all the original mods are still showing in the package manager. All topics/posts etc etc that were originally on the site are also there. Long road ahead to getting everything back to how it should be but at least now I know its all back up and running.

Offline Kays

  • Customizer
  • SMF Hero
  • *
  • Posts: 8,973
  • Gender: Male
    • Kayssplace
Re: 2.01 upgrade probs
« Reply #5 on: September 21, 2011, 05:37:35 AM »
Great. :)

Most mods won't work for 2.0 anyways. So it might be best to remove them if you can and revert the packages folder to how it is in the upgrade package with a empty "backups" folder and installed.list file. Both folders should have the .htaccess and index.php files though.

Also try to find a 2.0 compatible theme. Although the upgrade did convert your old theme. It might give you that problem again if you tried to use it.


If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

Offline leegreaves

  • Semi-Newbie
  • *
  • Posts: 45
Re: 2.01 upgrade probs
« Reply #6 on: September 21, 2011, 05:40:42 AM »
It seemed to me the error occurring was because a mod that WAS installed but got deleted at some point in the update process was causing it. The mod was called register_bar_mod_v3, I noticed the same error came up again even after restoring the site successfully if i went to certain pages, but when i checked the packages manager it wasnt there. So in order to prevent this error from occurring again i just simply reinstalled it.

Offline Kays

  • Customizer
  • SMF Hero
  • *
  • Posts: 8,973
  • Gender: Male
    • Kayssplace
Re: 2.01 upgrade probs
« Reply #7 on: September 21, 2011, 05:54:05 AM »
Cool, whatever works. :D

During an upgrade like this all mods will be removed from the source files since they are all replaced. The same doesn't apply to any edits which have been made on any custom themes.

Glad you got it sorted out. :)

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods