Advertisement:
NameCheap

Author Topic: The server encountered an internal error or misconfiguration  (Read 3921 times)

Offline jaisi

  • Full Member
  • ***
  • Posts: 511
The server encountered an internal error or misconfiguration
« on: October 15, 2011, 02:23:45 AM »
Some time its work fine but some time giving Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@****.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


 
« Last Edit: October 16, 2011, 01:04:20 AM by jaisi »

Offline Ricky.

  • Customizer
  • SMF Hero
  • *
  • Posts: 4,026
    • Indian Linux Forums
Re: The server encountered an internal error or misconfiguration
« Reply #1 on: October 15, 2011, 02:33:04 AM »
This is not really helpful, you need dig system logs , server logs .. if you have access then show us server logs generally found in /var/log/httpd

Offline jaisi

  • Full Member
  • ***
  • Posts: 511
Re: The server encountered an internal error or misconfiguration
« Reply #2 on: October 15, 2011, 02:41:07 AM »
thank you for replying here is server log and i dodint see any think

[Sat Oct 15 12:03:26 2011] [error] [client 65.52.109.146] File does not exist: /home/*****/public_html/404.shtml
[Sat Oct 15 12:03:26 2011] [error] [client 65.52.109.146] File does not exist: /home/*****/public_html/robots.txt
[Sat Oct 15 11:37:29 2011] [error] [client 207.46.204.188] File does not exist: /home/*****/public_html/404.shtml
[Sat Oct 15 11:37:29 2011] [error] [client 207.46.204.188] File does not exist: /home/*****/public_html/robots.txt
[Sat Oct 15 11:01:46 2011] [error] [client 49.244.220.100] File does not exist: /home/*****/public_html/500.shtml, referer: http://*****.com/index.php?action=post;board=10.0
[Sat Oct 15 11:01:41 2011] [error] [client 49.244.220.100] File does not exist: /home/*****/public_html/500.shtml, referer: http://*****/index.php?action=post;board=10.0
[Sat Oct 15 11:00:38 2011] [error] [client 49.244.220.100] File does not exist: /home/*****/public_html/500.shtml, referer: http://*****.com/index.php?action=post;board=10.0
[Sat Oct 15 11:00:17 2011] [error] [client 49.244.220.100] File does not exist: /home/*****/public_html/500.shtml, referer: http://*****.com/index.php?action=post;board=10.0
[Sat Oct 15 10:54:18 2011] [error] [client 49.244.220.100] File does not exist: /home/*****/public_html/Themes/52400.php, referer: http://*****.com/index.php/topic,9867.0.html
[Sat Oct 15 10:54:18 2011] [error] [client 49.244.220.100] File does not exist: /home/*****/public_html/Themes/default/images/post/MediaFire.gif, referer: http://*****.com/index.php/topic,9867.0.html
[Sat Oct 15 10:54:17 2011] [error] [client 49.244.220.100] File does not exist: /home/*****/public_html/Themes/52400.php, referer: http://*****.com/index.php/topic,9867.0.html
[Sat Oct 15 10:54:17 2011] [error] [client 49.244.220.100] File does not exist: /home/*****/public_html/Themes/default/images/post/MediaFire.gif, referer: http://*****.com/index.php/topic,9867.0.html
[Sat Oct 15 10:50:36 2011] [error] [client 78.154.229.38] File does not exist: /home/*****/public_html/avatars/189675.php, referer: http://*****.com/index.php?topic=1604.0
[Sat Oct 15 10:50:36 2011] [error] [client 78.154.229.38] File does not exist: /home/*****/public_html/avatars/Country_Flagatars, referer: http://*****.com/index.php?topic=1604.0

Offline Ricky.

  • Customizer
  • SMF Hero
  • *
  • Posts: 4,026
    • Indian Linux Forums
Re: The server encountered an internal error or misconfiguration
« Reply #3 on: October 15, 2011, 10:56:19 AM »
Your log says that you don't have file there... via FTP  , can you see files there at all ? ...

Offline jaisi

  • Full Member
  • ***
  • Posts: 511
Re: The server encountered an internal error or misconfiguration
« Reply #4 on: October 16, 2011, 12:53:29 AM »
which file r u talking ? all SMF files are there, and forum is working fine but Error come sometime only.
And I have contacted my hosting service They say all is fine our end please check your end.

Offline Illori

  • Doc Coordinator
  • SMF Master
  • *
  • Posts: 36,524
Re: The server encountered an internal error or misconfiguration
« Reply #5 on: October 16, 2011, 06:34:13 AM »
there is nothing to check on our end, as all files related to smf are on your server/hosting plan. you need to figure out why the file is reported as being missing. while you are at it you should make sure that your forum has not be attacked by hackers and code added to your files leading to those errors.

Offline Ricky.

  • Customizer
  • SMF Hero
  • *
  • Posts: 4,026
    • Indian Linux Forums
Re: The server encountered an internal error or misconfiguration
« Reply #6 on: October 16, 2011, 03:08:44 PM »
IF it happens randomly but you say your files are there, then your host need to find out the solution as then only he can suggest something.. better try to look at files when you are receiving errors.. at that time are you able to see files using FTP ?

Offline jaisi

  • Full Member
  • ***
  • Posts: 511
Re: The server encountered an internal error or misconfiguration
« Reply #7 on: October 16, 2011, 09:21:48 PM »
yes I'm able to access that time and all files and folder are there that time.

Thank you for replying now pls tell me what should i do ??

MrPhil

  • Guest
Re: The server encountered an internal error or misconfiguration
« Reply #8 on: October 16, 2011, 09:49:30 PM »
You should create "error documents" ("error pages") for your site, as well as the missing robots.txt. See my sig > FAQs > Missing Support Files, and under Missing Error Pages, there is a link to a utility to build them. Note that this will not cure your immediate problem, but it will unclutter your error log so that you're not swamped with all these bogus messages.

Offline jaisi

  • Full Member
  • ***
  • Posts: 511
Re: The server encountered an internal error or misconfiguration
« Reply #9 on: October 17, 2011, 03:00:00 AM »
.I have run the file checker .php  on my site and it told me that there were many xxx.php files such as index.php that did not end with (?>) what should i do ?? and i'am using light_theme theme 2.0 version and site is running very slow 1950 memeber and parday 15 to 25 mebers online

here is the file checker  result

   
    /home/**/public_html/Themes/light_theme_by_SMFSimple/languages/ThemeStrings.spanish_es-utf8.php
        UTF-8 BOM found

    /home/**/public_html/Themes/light_theme_by_SMFSimple/languages/ThemeStrings.spanish_latin-utf8.php
        UTF-8 BOM found

    /home/**/public_html/Themes/light_theme_by_SMFSimple/languages/ThemeStrings.italian-utf8.php
        UTF-8 BOM found

   
« Last Edit: October 17, 2011, 04:16:11 AM by jaisi »

MrPhil

  • Guest
Re: The server encountered an internal error or misconfiguration
« Reply #10 on: October 17, 2011, 03:43:48 PM »
Any file that has a UTF-8 BOM (Byte Order Mark) in it should be edited to remove that BOM. Either use an editor that doesn't put in BOMs, and manually remove the BOM before saving the file, or use an editor where you can configure it to not put in a BOM when you save the file.

As for files not ending in ?>, all PHP files should end with ?>. Sometimes it will not cause any problems, but other times it may. You can try adding ?> at the very end of a file where it's missing, it nothing else works. Just two things to be aware of:
  1. Make sure you put ?> at the very, very end of the very last line. You don't want any characters (including blanks) left after the ?>.
  2. Make sure it's PHP code that the file ends with, and not HTML code. If you're not sure, look backwards from the end of the file (one reported as missing ?>). If you encounter a <?php before you see a ?>, then it really is missing ?>. If you encounter a ?> before seeing a <?php, don't do anything -- it's fine.

Offline jaisi

  • Full Member
  • ***
  • Posts: 511
Re: The server encountered an internal error or misconfiguration
« Reply #11 on: October 18, 2011, 10:10:49 PM »
Thank you mr MrPhil my all probelm solved now i'am geeting only one Error when i post some big topic i'am getting server misconfiguration Error and same time i'am post some small topic its work without any error.  is there is server configuration error or   sfm error ??

Thanks

MrPhil

  • Guest
Re: The server encountered an internal error or misconfiguration
« Reply #12 on: October 19, 2011, 09:22:40 AM »
Good to hear that most of your problems are cleared up. However, I'm not sure what to tell you about the server misconfiguration error -- I'm not familiar with that one. First, you're sure this is not a 500 (Internal Server) error? If it is, see my sig > FAQs > article on 500 Errors. Second, what is a "small topic" that consistently posts OK, but how large a topic fails? That sounds like either some PHP memory limitation, or perhaps the POST data buffer isn't set sufficiently large on your server (your host will have to help you with that).

Offline jaisi

  • Full Member
  • ***
  • Posts: 511
Re: The server encountered an internal error or misconfiguration
« Reply #13 on: October 19, 2011, 11:00:20 PM »
Thanks for replying Mrphil ,
I have contact my host team and they said no problem in server end, plz check your application and i have check every think  but i did not found any solution. when i post like large topic getting error. i have sent you that topic link  in your inbox please check .


MrPhil

  • Guest
Re: The server encountered an internal error or misconfiguration
« Reply #14 on: October 20, 2011, 10:29:27 AM »
I will try to get a chance to look at it tonight. In the meantime, ask your host what the limit is on POST size (it might be too small for your larger posts), and make sure "mod security" is turned off. It's possible that your larger posts aren't failing on size, but on mod security tripping on some word in it.

MrPhil

  • Guest
Re: The server encountered an internal error or misconfiguration
« Reply #15 on: October 20, 2011, 10:13:47 PM »
OK, so the second posting is one that gave you an "internal error or misconfiguration"? It's pretty big, but I've seen larger. One possibility is that all those images resulted in a POST that was just too big for your server to handle. Does the same problem occur with post that are only text? The other possibility is that some of the words in the post (such as file extensions) triggered mod security.

I made a huge post with nothing but the word "Hello" over and over. It was just under the 20,000 character limit. I did not get any error after cutting it back to under 20,000 characters. Above that, the forum refused to accept the posting and gave me a message saying that the limit was 20,000 characters.

Offline jaisi

  • Full Member
  • ***
  • Posts: 511
Re: The server encountered an internal error or misconfiguration
« Reply #16 on: October 21, 2011, 02:03:12 AM »
Thank you for checking and last two days i'am not getting that kind of error hope now  my problem is solved.

Thank you Mrphil for your great Supports,  if i get any kind of error in future i will post here.