Advertisement:

Author Topic: 1.1.20 broke the preview in Firefox  (Read 11903 times)

Offline Stüldt Håjt

  • Jr. Member
  • **
  • Posts: 326
1.1.20 broke the preview in Firefox
« on: October 06, 2014, 01:16:48 PM »
I think the latest patch broke the post preview function in Firefox. It loads the preview forever. Works fine in Chrome.

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,174
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: 1.1.20 broke the preview in Firefox
« Reply #1 on: October 06, 2014, 02:29:17 PM »
I have a possible report from one of my forums from one of my members looking to get more detail from them as well.

Seems to happen on my SMF 1.1.x board just getting "Fetching preview..."
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

kat

  • Guest
Re: 1.1.20 broke the preview in Firefox
« Reply #2 on: October 06, 2014, 03:29:18 PM »
Odd... It works A-OK, on my 1.1.20 site...

Opera v12, Firefox 32.0.3, PaleMoon, IE 11x64, K-Meleon and Lunascape.

Offline onepiece

  • Full Member
  • ***
  • Posts: 698
  • Gender: Female
Re: 1.1.20 broke the preview in Firefox
« Reply #3 on: October 07, 2014, 08:22:37 AM »
This is valid for both 1.1.20 and 2.0.9. A session check is added at the beginning of Post2 function when previewing, however, the AJAX call does not send the session id resulting in the checkSession call to return an error. Possible fixes:

Post.template.php

SMF 1.1.20

Code: (Find) [Select]
"question", "topic"
Code: (Replace) [Select]
"question", "topic", "sc"
SMF 2.0.9

Code: (Find) [Select]
\'question\', \'topic\'
Code: (Replace) [Select]
\'question\', \'topic\', ', JavaScriptEscape($context['session_var']), '
« Last Edit: October 21, 2014, 03:59:04 PM by onepiece »

Offline Stüldt Håjt

  • Jr. Member
  • **
  • Posts: 326
Re: 1.1.20 broke the preview in Firefox
« Reply #4 on: October 07, 2014, 01:06:54 PM »
That did the trick. ;)

Offline Antechinus

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,244
  • Master of BBC Abuse
Re: 1.1.20 broke the preview in Firefox
« Reply #5 on: October 07, 2014, 04:41:55 PM »
Nice find, onepiece.

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: 1.1.20 broke the preview in Firefox
« Reply #6 on: October 07, 2014, 05:12:28 PM »
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

kat

  • Guest
Re: 1.1.20 broke the preview in Firefox
« Reply #7 on: October 08, 2014, 06:12:45 AM »
Hmm... I wonder why it's OK, for me, then? It's not like I usually get GOOD luck, with this kinda thing, after all.

Offline W7 riso

  • Semi-Newbie
  • *
  • Posts: 28
Re: 1.1.20 broke the preview in Firefox
« Reply #8 on: October 08, 2014, 01:23:09 PM »
Hi all,

Here the same issue on 3 Forums running the new 1.1.20 update
Fetching preview... for ever, IE works fine!

2.0.9 works fine in Firefox

Offline onepiece

  • Full Member
  • ***
  • Posts: 698
  • Gender: Female
Re: 1.1.20 broke the preview in Firefox
« Reply #9 on: October 08, 2014, 01:46:49 PM »
If you believe that it works fine, can you make sure that the preview is actually updated without the page being reloaded? I can't test different browsers myself but some of them maybe failing all together on the AJAX error, while some fall back to regular post form reloading the page.

Also, can this topic be moved to the Bug Reports board? I think this is a significant bug that requires more attention.

Offline margarett

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,761
  • Gender: Male
Re: 1.1.20 broke the preview in Firefox
« Reply #10 on: October 08, 2014, 01:52:09 PM »
It was noticed and will be taken care of ;)
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

Quote
Over 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Offline MadMick

  • Charter Member
  • Jr. Member
  • *
  • Posts: 125
  • Gender: Male
    • Australian Hunting Net
Re: 1.1.20 broke the preview in Firefox
« Reply #11 on: October 08, 2014, 06:05:30 PM »
Cool and easy fix onepiece  ;), thanks.
Regards,

Mick.

AHN Moderators - Can explain it to you, but they can't understand it for you" :upu:

Offline knagl

  • Semi-Newbie
  • *
  • Posts: 28
  • Gender: Male
    • Las Vegas Advice Message Forum
Re: 1.1.20 broke the preview in Firefox
« Reply #12 on: October 16, 2014, 05:08:29 PM »
A member reported the preview issue to me and I was able to duplicate it in Firefox 32.0.3.

I used onepiece's fix and we're back up to speed.  Thanks, onepiece!

For those like me who couldn't initially find the file to edit, it's located at:

{forum root}/Themes/default/Post.template.php

Offline NancyMB

  • Charter Member
  • Newbie
  • *
  • Posts: 3
Re: 1.1.20 broke the preview in Firefox
« Reply #13 on: November 20, 2014, 05:47:17 PM »
Thank you all for the information provided in this topic. I am having the same issue (hang up on trying to preview a post) in SMF 1.1.20.

I have edited the post.template.php (Themes/default/Post.template.php) as suggested but it has not made a difference.

Any other suggestions?

many Thanks!

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,934
    • StoryBB/StoryBB on GitHub
Re: 1.1.20 broke the preview in Firefox
« Reply #14 on: November 20, 2014, 05:48:10 PM »
Does your theme have its own Post.template.php file?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline NancyMB

  • Charter Member
  • Newbie
  • *
  • Posts: 3
Re: 1.1.20 broke the preview in Firefox
« Reply #15 on: November 20, 2014, 05:50:11 PM »
no, it doesn't - we use the bisdakworldgreen theme and there is no Post.template.php  file for that theme (I made sure to check).

Offline TonyG

  • Semi-Newbie
  • *
  • Posts: 94
Re: 1.1.20 broke the preview in Firefox
« Reply #16 on: December 27, 2014, 02:05:16 PM »
I just encountered this with 2.0.9 over IE11. I'm glad/lucky I was able to find this in the 1.1 forum reporting a Firefox issue.  :o
Solution for v2 worked. Thanks for this thread!