Advertisement:

Author Topic: Admin can't login  (Read 4935 times)

Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Admin can't login
« on: July 01, 2016, 11:38:47 PM »
Hi,

Don't know what happened, but I can't login with either of my Admin accounts.   :-\

Quote
That username does not exist.

I know there is a file where I can go in and change or add an Admin username, I just forget which php file it is.   ???

Thank you in advance.

Be Well,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,918
Re: Admin can't login
« Reply #1 on: July 01, 2016, 11:50:51 PM »
It's not in a php file, it's in smf_members in your database.  Is that a clean install, or did you upgrade from 2.0?

Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: Admin can't login
« Reply #2 on: July 02, 2016, 12:02:12 AM »
Thank you for your reply Sir.

It is such a clean install that "it's squeaky clean", (was from the full install zip file) I created the DB and everything.
no other members,
only one board,
and only the famous "Welcome to SMF" post.

Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,918
Re: Admin can't login
« Reply #3 on: July 02, 2016, 12:10:11 AM »
Look in the database and see if your admin accounts exist in smf_members.  Are you able to register?


Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: Admin can't login
« Reply #4 on: July 02, 2016, 12:24:47 AM »
I didn't find either of the Admin Usernames present, I did find Siriist  (see screenshot)

But when I tried that username, I still got
"That username does not exist."

If I "register", I will just be a regular member, with only standard permissions.

Kindly,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,918
Re: Admin can't login
« Reply #5 on: July 02, 2016, 12:34:22 AM »
You can't login with your real_name (Siriist), you must use your member_name.  Try logging in as Cloud_Walker.

Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: Admin can't login
« Reply #6 on: July 02, 2016, 12:41:27 AM »
Well now, this is a "poser" (see screenshot)
noun
1. a question or problem that is puzzling or confusing.

Should I just delete the database, create a new database and reinstall the "smf_2-1_beta2_install" zip file?

Also, should I (once I am able to login) treat ver 2.1.0 the same as ver 2.0.11 (such as adding themes, mods, avatars, etc)?

Hmmm,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,918
Re: Admin can't login
« Reply #7 on: July 02, 2016, 01:02:39 AM »
Ok, first of all, you should be using the current 2.1 github version, which is here.  It is constantly changing, and this is the most current version, not the one in the download section here.  I've attached the current github file.  If you've got nothing in the forum, just delete everything and start over. 

You cannot install 2.0 themes and mods in 2.1, and I don't believe there are any approved mods or themes for 2.1.  It's still in beta, so it's a moving target for mod authors and theme designers.  You can do your own customization if you like to tinker, some people have done so with good results. 

Bear in mind that 2.1 is not recommended for production forums, it's a beta.


Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: Admin can't login
« Reply #8 on: July 02, 2016, 10:00:53 AM »
Ok, first of all, you should be using the current 2.1 github version, which is here.  It is constantly changing, and this is the most current version, not the one in the download section here.

Then should not the "Powers that be (CoreISP?) should remove that download link.   ???

Quote from: Sir Osis of Liver
I've attached the current github file.  If you've got nothing in the forum, just delete everything and start over.

Thank you for that.   :)

Quote from: Sir Osis of Liver
You cannot install 2.0 themes and mods in 2.1, and I don't believe there are any approved mods or themes for 2.1.  It's still in beta, so it's a moving target for mod authors and theme designers.  You can do your own customization if you like to tinker, some people have done so with good results. 

But it says right here (hxxp://wiki.simplemachines.org/smf/SMF2.1:Features[no follow]

Quote
SMF 2.1.x is a very versatile forum software. It has many features, including the following:
Minimum requirements

    PHP 5.3.8+
    MySQL 5.0.3+ or PostgreSQL 8.3+

General

    >> Automated Installation of mods on non-default themes
    >> "Smart emulation" to automatically detect a mod's version and to automatically emulate this mod when it is installed

If Mods and themes are written specifically for ver 2.1.0, then:
"Automated Installation of mods on non-default themes"
 > is almost equivalent to current Package Manager.
"Smart Emulation"
 > is just a blur that makes it "seem" better.

What I am understanding is that creating a db for SMFver2.1.0 to "try it out" isn't trying it out at all, because all you can do is post and reply.   :-\

Quote from: Sir Osis of Liver
Bear in mind that 2.1 is not recommended for production forums, it's a beta.

Hmmm, I'm either all right, or all wrong. Now to figure out which I am.

Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,993
    • StoryBB/StoryBB on GitHub
Re: Admin can't login
« Reply #9 on: July 02, 2016, 10:07:05 AM »
Some mods for 2.0 will install on 2.1 with few changes, and there are some backwards compatible things under the hood to help out.

There aren't many mods for 2.1 because writing mods for it is actually quite hard when the find/replace changes become out of date within a matter of weeks. I've been writing a very specific 2.1 mod on and off for the last few months. It's very specific, very unlikely you'll want to use it (it's for RPG forums) and it's very, very invasive in what it does and how it does it - and hooks don't help me nearly enough, so it's done as find/replace. And many times in that time period I've had to go back and worth out what changed to keep the mod up to date.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: Admin can't login
« Reply #10 on: July 02, 2016, 10:40:30 AM »
*scratches head*
Thoughts =
'Are the benefits of SMF ver 2.1.0

General
  • Automated Installation of mods on non-default themes
  • "Smart emulation" to automatically detect a mod's version and to automatically emulate this mod when it is installed
  • Improved attachment security
  • Improved attachment error handling
  • SCEditor (New WYSIWYG editor)
  • Drafts
  • Enhanced admin panel
  • IPv6 Support
  • Built in support for jQuery
  • Full SSL Support
  • Verification questions support for multiple answers and multiple languages
  • Deny access to boards
  • Moved topics placeholders can be set to auto expire/delete
  • Topic preview when hovering over subject on message index
  • Likes System
  • Mentions System
  • Alerts systems for Notifications, Likes, and Mentions
  • Topic notifications can be set to Not Following, No Alerts or Email, Receive Alerts and Receive Emails and Alerts
  • Personal Messages automatically saved in sent box
  • Default theme is responsive
  • Ical calendar event export support
  • Gravatar support

outweighed by the challenges?

'Mods more difficult to create, seemingly 80% more difficult.

Likely that themes will be equally difficult.'

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

This topic is extremely close to a split (or move some of the "discussion" posts out and over to Topic: Where do I talk about SMF ver 2.1?  (Read 132 times)

I can understand why this is should be done, as this was a support thread, and I may have injected SMF ver 2.0 discussion.

Most Sincerely,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,993
    • StoryBB/StoryBB on GitHub
Re: Admin can't login
« Reply #11 on: July 02, 2016, 10:46:39 AM »
Quote
'Mods more difficult to create, seemingly 80% more difficult.

Where did you pull that figure from? Writing a mod for 2.1 is no more difficult than writing for 2.0 is. In many ways it is easier.

The ONLY challenge is writing for a system that is still NOT FINISHED and therefore subject to change. I was writing mods for 2.0 RCs and having the massive upheaval between versions. Nothing has changed there. Ditto for themes, the changes from 2.0 RC1 to 2.0 RC2 for example were monumental and we're not even at that stage yet, we're still in beta (which is before RC)... writing mods for 2.0 beta 3 vs 2.0 beta 4 was a nightmare and the changes in 2.1 are less serious.

If I write a mod for 2.0 now, I know 2.0 is not going to make serious changes between, say, 2.0.10 vs 2.0.11. There aren't changes every week that change quite large chunks of code! That's why 2.1 is hard - for now.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: Admin can't login
« Reply #12 on: July 02, 2016, 12:41:52 PM »
Quote
'Mods more difficult to create, seemingly 80% more difficult.

Where did you pull that figure from? Writing a mod for 2.1 is no more difficult than writing for 2.0 is. In many ways it is easier.

From here

". . . You cannot install 2.0 themes and mods in 2.1, and I don't believe there are any approved mods or themes for 2.1.  It's still in beta, so it's a moving target for mod authors and theme designers.  You can do your own customization if you like to tinker, some people have done so with good results. . . "


The ONLY challenge is writing for a system that is still NOT FINISHED and therefore subject to change. I was writing mods for 2.0 RCs and having the massive upheaval between versions. Nothing has changed there. Ditto for themes, the changes from 2.0 RC1 to 2.0 RC2 for example were monumental and we're not even at that stage yet, we're still in beta (which is before RC)... writing mods for 2.0 beta 3 vs 2.0 beta 4 was a nightmare and the changes in 2.1 are less serious.

If I write a mod for 2.0 now, I know 2.0 is not going to make serious changes between, say, 2.0.10 vs 2.0.11. There aren't changes every week that change quite large chunks of code! That's why 2.1 is hard - for now.

Once again. Hmmm

Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,993
    • StoryBB/StoryBB on GitHub
Re: Admin can't login
« Reply #13 on: July 02, 2016, 12:46:01 PM »
You can certainly install 2.0 mods in SMF 2.1. It even makes this easier for you by offering to do it. Depending on what the mod is, it might work perfectly, it might crash and burn depending on a lot of different things.

I say this as a person who's written 2.0 mods that work on 2.1 and a former member of the 2.1 development team, and someone who is currently writing a mod for 2.1.

Once again, you're complaining about mods not working on a thing that literally changes every few days, versus a thing that hasn't changed in months. These two things are not the same and you can't compare the two like for like. Once 2.1 goes stable, and doesn't change its core code every week, the debate will change.

2.0 themes don't work on 2.1 though, the underlying code is vastly different (but then again it was from 2.0 beta 3 to 4 to RC1 to RC2 to RC3 to RC4, the exact same problem was there)

I'm not being funny but you're taking general advice out of context and arguing with someone who does this stuff - and has been doing it for years.

If you don't understand what a beta is and why it's not for production use, DON'T USE IT.

ETA: we had the exact same situation for 1.1 vs 2.0
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: Admin can't login
« Reply #14 on: July 02, 2016, 01:07:35 PM »
Not complaining.
Attempting to understand, and you have clearly identified the "parameters"(?) of operation.

I will delete the problematic DB, create a new one, and download ver 2.1.0 from the github as directed previously in this topic.

Again, thank you for making this all clear.

Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,918
Re: Admin can't login
« Reply #15 on: July 02, 2016, 03:34:14 PM »
You can certainly install 2.0 mods in SMF 2.1. It even makes this easier for you by offering to do it. Depending on what the mod is, it might work perfectly, it might crash and burn depending on a lot of different things.

That's really the point.  IMO, from a support standpoint it's better to advise against trying something that may crash the install for reasons beyond the user's ability to cope.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,993
    • StoryBB/StoryBB on GitHub
Re: Admin can't login
« Reply #16 on: July 02, 2016, 03:47:00 PM »
Yup, and is why I've been saying the same thing. I just wanted to correct the fallacy that '2.0 mods don't work on 2.1'. They do - for some value of 'work'.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: Admin can't login
« Reply #17 on: July 02, 2016, 11:36:37 PM »
Thank you Arantor and Sir for clarifying this for me.

I can appreciate your position regarding ver 2.1.0 (Beta) as precautious, yet, it initially seemed that with the word "cannot" it would be without purpose to even install the (Beta) software for "testing" if nothing worked with it.

Have a great weekend.

Be Well,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,993
    • StoryBB/StoryBB on GitHub
Re: Admin can't login
« Reply #18 on: July 03, 2016, 06:16:03 AM »
No, it's not without purpose to install it, because you could find bugs in the beta (so it stops being a beta with all the issues hammered out) - like last night, in the middle of developing a mod, I discovered a bug in 2.1 that affects sending PMs, amongst other things.

I actually find this whole 'if you can't use mods with it, it's of no value' somewhat insulting because it implies that the core is of no use without mods...
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Siirist

  • Sophist Member
  • *****
  • Posts: 1,201
  • Gender: Male
  • What would Kindred or Illori do?
    • A Sanctuary (Support for Survivors of abuse/Info for Family & Friends)
Re: Admin can't login
« Reply #19 on: July 04, 2016, 05:34:23 PM »
I actually find this whole 'if you can't use mods with it, it's of no value' somewhat insulting because it implies that the core is of no use without mods...

That was not my intention.  I think that the wording I used created some confusion. Here is my edit.

Thank you Arantor and Sir for clarifying this for me.

I can appreciate your position regarding ver 2.1.0 (Beta) as precautious, yet, i It {had} initially seemed that with the word "cannot"{,} it would be without purpose to even install the (Beta) software for "testing" if nothing worked with it. {As you pointed out, this is NOT the case, and all that are interested should continue to test the Beta so that the "bugs" can be worked out.}

I hope that this is now taken better.   ;)

Have a great weekend.   :)

Be Well,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x