Advertisement:

Author Topic: Cannot install 2.1  (Read 2159 times)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,708
  • Too long in the wasteland
Cannot install 2.1
« on: January 07, 2017, 11:00:35 PM »
Installing on new host (Crocweb), get this error when MySQL is selected -

The version of your database server is very old, and does not meet SMF's minimum requirements.

... and this error when MySQLi is selected -

Cannot find database source script! Please check file Subs-Db-mysqli.php is within your forum source directory

Both are running 5.0.11.


Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 54,810
  • Gender: Male
    • Kindred-999 on GitHub
Re: Cannot install 2.1
« Reply #1 on: January 08, 2017, 12:18:25 AM »
Already reported... ;)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Online d3vcho();

  • Localizer
  • SMF Hero
  • *
  • Posts: 2,000
  • Gender: Male
  • Be prepared for hell
    • d3vcho on GitHub
    • @SMF_ES on Twitter
Re: Cannot install 2.1
« Reply #2 on: January 08, 2017, 03:06:30 AM »
BTW, if I remember well, min MySQL version required is 5.0.3

Regarding MySQLi, I think the solution got merged this night, so latest GitHub build should solve the problem.

EDIT: Not merged yet. Here's the PR (fix) https://github.com/SimpleMachines/SMF2.1/pull/3817
« Last Edit: January 08, 2017, 03:24:20 AM by d3vcho »
Programmer (noun.)
A person who fixed a problem you don't know you have, in a way you don't understand.


¡Únete al canal IRC de SMF en español! #smf-es en Freenode
Sigue a @SMF_ES en Twitter para enterarte de todas las novedades de SMF

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,708
  • Too long in the wasteland
Re: Cannot install 2.1
« Reply #3 on: January 08, 2017, 03:27:04 PM »
The current github package (as of last night) does not contain Subs-Db-mysqli.php.

So there's no way to install 2.1 on this host?

Online d3vcho();

  • Localizer
  • SMF Hero
  • *
  • Posts: 2,000
  • Gender: Male
  • Be prepared for hell
    • d3vcho on GitHub
    • @SMF_ES on Twitter
Re: Cannot install 2.1
« Reply #4 on: January 08, 2017, 05:38:30 PM »
No, it doesn't contain Subs-Db-mysqli.php because they are renaming MySQLi to MySQL and they forgot some bits of the code.

And no, there's no way to install SMF 2.1 unless MySQL is at least version 5.0.3
Programmer (noun.)
A person who fixed a problem you don't know you have, in a way you don't understand.


¡Únete al canal IRC de SMF en español! #smf-es en Freenode
Sigue a @SMF_ES en Twitter para enterarte de todas las novedades de SMF

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,708
  • Too long in the wasteland
Re: Cannot install 2.1
« Reply #5 on: January 09, 2017, 12:08:48 PM »
Isn't 5.0.11 > 5.0.3?

Will this be fixed?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 54,810
  • Gender: Male
    • Kindred-999 on GitHub
Re: Cannot install 2.1
« Reply #6 on: January 09, 2017, 12:15:08 PM »
I believe that it IS fixed, but the fix has not been committed yet
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Online d3vcho();

  • Localizer
  • SMF Hero
  • *
  • Posts: 2,000
  • Gender: Male
  • Be prepared for hell
    • d3vcho on GitHub
    • @SMF_ES on Twitter
Re: Cannot install 2.1
« Reply #7 on: January 09, 2017, 12:19:04 PM »
Isn't 5.0.11 > 5.0.3?

Will this be fixed?


Hmm, yeah that's right. Then I don't know what is causing the problem...

Looking into install_2-1_mysql.sql it appears this: #### Install script for MySQL 4.0.18+

So I don't know... You better report it on GitHub, you'll get better support over there :D
Programmer (noun.)
A person who fixed a problem you don't know you have, in a way you don't understand.


¡Únete al canal IRC de SMF en español! #smf-es en Freenode
Sigue a @SMF_ES en Twitter para enterarte de todas las novedades de SMF

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,708
  • Too long in the wasteland
Re: Cannot install 2.1
« Reply #8 on: January 09, 2017, 09:10:34 PM »
I'll give it another six months, and try again. ;)

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,634
  • Gender: Male
  • Black cat rulz!
    • Antes on GitHub
    • merta on LinkedIn
    • @antesistan on Twitter
    • Lunarfall
Re: Cannot install 2.1
« Reply #9 on: January 09, 2017, 09:20:55 PM »
I'll give it another six months, and try again. ;)


what do you mean?
Active Project(s): [ SimpleDesk ] # [ Lunarfall ] # [ CoreStore ]

Past Project(s): [ ezPortal ]

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,708
  • Too long in the wasteland
Re: Cannot install 2.1
« Reply #10 on: January 09, 2017, 09:27:02 PM »
j/k - Haven't had time to look at 2.1 in a while, and just moved to new host recently.  First try at installing it there didn't work.  Will give it another go when fix is committed.

Offline live627

  • Developer
  • SMF Hero
  • *
  • Posts: 5,269
  • Gender: Male
  • Cat: Destroy!
    • live627 on Facebook
    • live627 on GitHub
    • live627 on LinkedIn
    • @live627 on Twitter
    • livemods
Re: Cannot install 2.1
« Reply #11 on: January 10, 2017, 03:50:06 AM »
that was the fastest six months ever :P

Is my birthday close yet?
Try not to become a man of success, but rather try to become a man of value.
- Albert Einstein

Online Bob Perry of Web Presence Consulting

  • Sr. Member
  • ****
  • Posts: 935
  • Gender: Male
  • (T)ogether (E)veryone (A)chieves (M)ore
    • Bobert921 on Facebook
    • https://www.linkedin.com/in/bperry921/ on LinkedIn
    • @bperry921 on Twitter
    • Web Presence Consulting
Re: Cannot install 2.1
« Reply #12 on: January 11, 2017, 10:48:27 AM »
Isn't 5.0.11 > 5.0.3?

Will this be fixed?


If you mean is it older? yes
Best Regards,
Bob Perry



"The world is moving so fast these days that the man who says it can't be done is generally interrupted by someone doing it." Elbert Hubbard

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,708
  • Too long in the wasteland
Re: Cannot install 2.1
« Reply #13 on: January 11, 2017, 09:39:00 PM »
Just tried installing current github package, installer crashes after Welcome page.

Errorlog -

Code: [Select]

[12-Jan-2017 02:37:12 UTC] PHP Warning:  require_once(/Class-Package.php): failed to open stream: No such file or directory in /home/thekrash/public_html/smf21/install.php on line 595
[12-Jan-2017 02:37:12 UTC] PHP Fatal error:  require_once(): Failed opening required '/Class-Package.php' (include_path='.:/opt/cpanel/ea-php56/root/usr/share/pear') in /home/thekrash/public_html/smf21/install.php on line 595


Online d3vcho();

  • Localizer
  • SMF Hero
  • *
  • Posts: 2,000
  • Gender: Male
  • Be prepared for hell
    • d3vcho on GitHub
    • @SMF_ES on Twitter
Re: Cannot install 2.1
« Reply #14 on: January 12, 2017, 01:44:21 AM »
Maybe you should report that on GitHub.
Programmer (noun.)
A person who fixed a problem you don't know you have, in a way you don't understand.


¡Únete al canal IRC de SMF en español! #smf-es en Freenode
Sigue a @SMF_ES en Twitter para enterarte de todas las novedades de SMF

Offline Jailer

  • Semi-Newbie
  • *
  • Posts: 82
  • Gender: Male
    • Bored Guy Blog
Re: Cannot install 2.1
« Reply #15 on: January 12, 2017, 06:45:30 PM »
Just tried installing current github package, installer crashes after Welcome page.

Errorlog -

Code: [Select]

[12-Jan-2017 02:37:12 UTC] PHP Warning:  require_once(/Class-Package.php): failed to open stream: No such file or directory in /home/thekrash/public_html/smf21/install.php on line 595
[12-Jan-2017 02:37:12 UTC] PHP Fatal error:  require_once(): Failed opening required '/Class-Package.php' (include_path='.:/opt/cpanel/ea-php56/root/usr/share/pear') in /home/thekrash/public_html/smf21/install.php on line 595


Same thing here. I don't have a clue how to use github.

Offline Jailer

  • Semi-Newbie
  • *
  • Posts: 82
  • Gender: Male
    • Bored Guy Blog
Re: Cannot install 2.1
« Reply #16 on: January 12, 2017, 08:18:42 PM »
No edit of posts???

Comment added to the issues section along with snippet of error log message. Best I can do.

EDIT: Must have been a post limit thing, the edit buttons show now.   :o

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,634
  • Gender: Male
  • Black cat rulz!
    • Antes on GitHub
    • merta on LinkedIn
    • @antesistan on Twitter
    • Lunarfall
Re: Cannot install 2.1
« Reply #17 on: January 12, 2017, 08:49:12 PM »
No edit of posts???

Comment added to the issues section along with snippet of error log message. Best I can do.

EDIT: Must have been a post limit thing, the edit buttons show now.   :o

We disabled post editing for users when post has certain age :P I can't recall the exact age (something like 1-3 hours).
Active Project(s): [ SimpleDesk ] # [ Lunarfall ] # [ CoreStore ]

Past Project(s): [ ezPortal ]