Author Topic: max_input_vars on server with fcgi, suhosin and ngxinx  (Read 1152 times)

Offline spiros

  • Language Moderator
  • SMF Hero
  • *
  • Posts: 1,643
  • Gender: Male
  • A different point of view
    • spiros.doikas on Facebook
    • doikas on LinkedIn
    • @greektranslator on Twitter
    • Greek Translation
max_input_vars on server with fcgi, suhosin and ngxinx
« on: January 09, 2017, 07:21:02 AM »
I tried running some stuff where many checkboxes had to be checked (I.e. import images or ran some regexes) and I was greeted with Internal Server Error. Changing max_input_vars on php.ini does not affect things, and I am not sure where and how and what to edit with respect to fcgi, suhosin and ngxinx.

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

So far I found: = 1500
suhosin.request.max_vars = 1500

By default, PHP FastCGI processes exit after handling 500 requests, and they may exit after this module has already connected to the application and sent the next request. When that occurs, an error will be logged and ***500 Internal Server Error*** will be returned to the client. This PHP behavior can be disabled by setting PHP_FCGI_MAX_REQUESTS to 0, but that can be a problem if the PHP application leaks resources. Alternatively, PHP_FCGI_MAX_REQUESTS can be set to a much higher value than the default to reduce the frequency of this problem. FcgidMaxRequestsPerProcess can be set to a value less than or equal to PHP_FCGI_MAX_REQUESTS to resolve the problem.