Advertisement:

Author Topic: Upgrading errors  (Read 2711 times)

Offline kat★

  • Semi-Newbie
  • *
  • Posts: 31
Upgrading errors
« on: February 05, 2017, 07:14:31 PM »
When upgrading a 2.0.10 database to 2.1 Beta 3 (from the git repository) I encounter the following errors:
Warning: mysqli_get_server_info() expects parameter 1 to be mysqli, resource given in /volume1/web/upd/upgrade.php(1555) : eval()'d code on line 1
and
Fatal error: Call to undefined function safe_serialize() in /volume1/web/upd/upgrade.php on line 351
Kinda wierd eh. The database was only modified by the fllowing mods: a shoutbox, country flags, spoilers, reason for editing and users online today.
Those shouldn't really pose much of an obstacle tho, right?

---Edit---
Well I made a new directory in which i put the files for 2.0.13 and assigned a copy of the database to it. After running the beta3 upgrade, it says "The directory: /avatars/Users has to be writable to continue the upgrade. Please make sure permissions are correctly set to allow this. "
I don't have a Users directory, and upon making it and assigning permissions (777) it doesn't fix the issue.
---Edit #2---
Huh...started from scratch and now it works. I'll keep you guys posted on any new stuff that goes down.
« Last Edit: February 05, 2017, 07:42:03 PM by kat★ »
I use smf to learn to write php and css. It's pretty neat. |