Advertisement:

Author Topic: working theme for 2.1 beta ?  (Read 2575 times)

Offline 19at250

  • Newbie
  • *
  • Posts: 6
working theme for 2.1 beta ?
« on: February 12, 2017, 03:54:03 AM »
I'm currently testing the latest SMF v 2.1 beta 2.
Is there any theme available that actually works in the 2.1 version besides the default one..?

Please bear with me, I'm a total n00b when it comes to PHP and coding in general but so far, every most recent theme I tried on this 2.1 beta generates a load of errors.

Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 47,508
Re: working theme for 2.1 beta ?
« Reply #1 on: February 12, 2017, 06:06:59 AM »
that is because there is maybe one theme for SMF 2.1, there are almost no themes because is it still in beta and will be changing as it moves forward. you should not be using SMF 2.1 on a live forum so no one is putting in effort to make themes that will need to have major changes to keep up with development.

themes for SMF 2.0 will not work on SMF 2.1.

Offline 19at250

  • Newbie
  • *
  • Posts: 6
Re: working theme for 2.1 beta ?
« Reply #2 on: February 12, 2017, 06:28:59 AM »
Ofcourse I'm well aware that a beta is still in development, I was just wondering since I'm just testing and trying to get to know SMF and familiarize with its control and management-features.
The test-forum is live on my NAS ( DS 412+ ) but not available to the public, only to my fellow admins and moderators, for them also to have a chance to familiarize with all control and administration-features.
I'm completely new to SMF so I have a lot of reading en checking out ahead of me but eventually I'll get it.
My main goal is to use SMF to replace the old XMB software our live-forum is currently running.

Offline ARG01

  • SMF Hero
  • ******
  • Posts: 4,580
    • All Web Now
Re: working theme for 2.1 beta ?
« Reply #3 on: February 12, 2017, 12:01:00 PM »
I have made 2 custom themes for 2.1 and discovered it to be a huge waste of time due to the reasons Illori pointed out. The constant changes in the beta quickly rendered both custom themes completely useless.
I have been waiting patiently to get started on a few new design ideas.  8)

Offline 19at250

  • Newbie
  • *
  • Posts: 6
Re: working theme for 2.1 beta ?
« Reply #4 on: February 12, 2017, 01:10:37 PM »
Sorry to hear that, but thanks for your reply and efforts in this.
At least, while in beta-stage, I got time to get around and familiarize the management-options of SMF and will eventually decide to install 2.0.13 to go live and meanwhile wait for the 2.1 to get to Final-stage.
We really need to migrate to a different forum-software as the currently used XMB 1.19 has too little options to keep forumspammers out or to block entire VPN IP-ranges.

The reason for it is unclear to me but at this time I can't get 2.0.13 to properly run on my NAS but that's not related to mt topic-question but any pointers are highly appreciated though.
It installs without a problem but after opening the index, I see no theme, it looks like a transparent HTML layout where it keeps jumping up and down when clicking a link.
No idea where to look really.
My DS412+ is running Apache 2.2, PHP 5.6, Java 7.
Browser used doesn't make any difference, I tried I.E. 11, Waterfox and Safari.

Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 47,508
Re: working theme for 2.1 beta ?
« Reply #5 on: February 12, 2017, 02:24:35 PM »
then you need to fix your URLs, it is a know bug with 2.0.*.

What is repair_settings.php?

Offline 19at250

  • Newbie
  • *
  • Posts: 6
Re: working theme for 2.1 beta ?
« Reply #6 on: February 12, 2017, 05:23:09 PM »
Thanks for pointing that out but I already tried that last week when I ran into this issue, that is the reason why I am currently on the 2.1 beta2 which works for me.
I just had to fix the dutch utf8 language-file as that came up with a "unexpected argument" or smth like that when trying to install it.
But I fixed that and offered to upload the working file so you can replace the current one in the download-section but I'm awaiting approval to join the translating-team.

Anyway, I'll create a subfolder and setup the 2.0.13 tomorrow and give it another go.
I know that themes do work there since I had it working before I had to re-configure my NAS setup from JBOD to RAID5.
Thanks again for the support and help  8)

Offline 19at250

  • Newbie
  • *
  • Posts: 6
Re: working theme for 2.1 beta ?
« Reply #7 on: February 15, 2017, 01:15:41 AM »
Right, I spend the last 2 days on installing and setting up v 2.0.13 in a different folder and, after running repair_settings.php, it seems to run without any issues.
Installing xtra languages and theme's did no longer throw up any database- or scripting errors so all good.

I'm gonna mark this topic as resolved and wanna thank you all for your replies and pointers. :D

It's time now for me to jump into the mod-section and find me some additional protection against forumspammers / bots registering an posting crap.
Looking for something other than captcha, preferably something that allows me to exclude VPN IP-blocks / ranges..
For this, any pointers would be highly appreciated as well. 8)

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 54,810
  • Gender: Male
    • Kindred-999 on GitHub
Re: working theme for 2.1 beta ?
« Reply #8 on: February 15, 2017, 08:52:21 AM »
http://wiki.simplemachines.org/smf/Spam_-_my_forum_is_flooded_with_spam,_what_can_I_do


personally, I believe that good "questions" are the best solution...   write 10-20 GOOD questions (more is better) and then ask 2 on registration.

I also use bad behavior + HttpBL and stop Spammer (which queries the Stop Forum Spam database)
however...   httpBL is currently down for new registrations and SFS is known to trigger false positives - so, be aware. :D
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline 19at250

  • Newbie
  • *
  • Posts: 6
Re: working theme for 2.1 beta ?
« Reply #9 on: February 15, 2017, 11:59:25 PM »
Thank you for the pointers, warnings and pro's and cons  8)

I found Bad Behaviour while snooping through the mod-section and installed that for a start and indeed noticed that httpBL is down for maintanance and database work.
That ain't a problem for me at this point in time since me and my fellow Admins are still getting familiar with the administration and control-panel.
Respons is very positive though, so as soon as we have figured out how to convert the XMB database into SMF we will take down the current forum for a couple of days and make the transistion to SMF. I already found the converter-tool for it but I need to study on how to use it..

We had planned to this this before summer so we got time, no hurries, that's never good and a feeding-ground for errors and mistakes.