Advertisement:

Author Topic: Urgent help needed please with my SMF forum  (Read 1777 times)

Offline shabbadoof

  • Semi-Newbie
  • *
  • Posts: 42
Urgent help needed please with my SMF forum
« on: March 20, 2017, 07:02:41 PM »
Hi guys


I Run a pretty large forum (www.themoneyshed.co.uk) (90,000+ posts over 3+ years) and suddenly tonight when I go into it it looks like this



I have no options at the top and obviously that white bar shouldn't be there

If I try and look at a thread by clicking on one I'd be ones on the front page I get


So it doesn't even throw the thread and again no menus

I've tried changing the theme and the same problem occurs

If you access the forum on your phone then the site DOES work on the mobile theme

PLEASE does anyone know what's happened here and how I can fix it !!

Offline shabbadoof

  • Semi-Newbie
  • *
  • Posts: 42
Re: Urgent help needed please with my SMF forum
« Reply #1 on: March 20, 2017, 07:22:41 PM »
Another concern is that I can't even get into the admin page because it just appears empty again unless I am on my phone but I can't seem to get to the page where I could deactivate or remove mods / packages I have running

I've also had my hosting company roll the site back to earlier today when it was working and as you can see the problem is still there.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,530
  • Too long in the wasteland
Re: Urgent help needed please with my SMF forum
« Reply #2 on: March 20, 2017, 10:06:56 PM »
Can you change to default Curve theme for all users via mobile?

Offline shabbadoof

  • Semi-Newbie
  • *
  • Posts: 42
Re: Urgent help needed please with my SMF forum
« Reply #3 on: March 21, 2017, 01:39:03 AM »
Makes no difference I'm afraid


Offline shabbadoof

  • Semi-Newbie
  • *
  • Posts: 42
Re: Urgent help needed please with my SMF forum
« Reply #4 on: March 21, 2017, 03:40:29 AM »
I'm just not where what's happened

I'm on a laptop at the moment so I can see things a bit more clearly

When I go to www.themoneyshed.co.uk every bit of text near enough under the logo takes me to blog.themoneyshed.co.uk which I assume it is getting from the THE BLOG link which is the ONLY one it has kept from the menus that should be there

Does anyone know the action= or can they tell me what it is for the page where I can go to the installed mods and remove / deactivate them?

currently I have to switch to mobile theme

and then go to

https://www.themoneyshed.co.uk/index.php?action=admin

and then it's just showing THIS if I go into the package manager



so I don't seem to have the option to deactivate installed mods not can I see the Menu one that I wonder may be causing this issue

HELP!!!

I just don't get what's caused all this to happen and where my menus have gone and also why rolling back to yesterday morning when everything worked hasn't fixed it!!

Offline shabbadoof

  • Semi-Newbie
  • *
  • Posts: 42
Re: Urgent help needed please with my SMF forum
« Reply #5 on: March 21, 2017, 03:56:42 AM »
I'm wondering if I should run repair_settings and use 'remove all hooks'

I assume this would just give me my forum back with the database intact and no mods is that right?

Offline lurkalot

  • Sr. Member
  • ****
  • Posts: 918
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: Urgent help needed please with my SMF forum
« Reply #6 on: March 21, 2017, 04:19:30 AM »
Your package manager shows Tinyportal 1.2 but your site at the bottom is showing simpleportal.  Is that your current mod list?

Tinyportal.net Official Support Site For TinyPortal.
Camera Craniums Running SMF 2.0.13 / Tinyportal 1.2
Guitarist Guild Running SMF 2.0.14 / Tinyportal 1.2R Beta

Offline shabbadoof

  • Semi-Newbie
  • *
  • Posts: 42
Re: Urgent help needed please with my SMF forum
« Reply #7 on: March 21, 2017, 04:29:34 AM »
Yes, I only use Simpleportal

I tried to uninstall simpleportal and now when I go to www.themoneyshed.co.uk I get


Warning: require_once(/var/sites/t/themoneyshed.co.uk/public_html/Sources/Subs-Portal.php): failed to open stream: No such file or directory in /var/sites/t/themoneyshed.co.uk/public_html/index.php on line 58

Fatal error: require_once(): Failed opening required '/var/sites/t/themoneyshed.co.uk/public_html/Sources/Subs-Portal.php' (include_path='.:/usr/newage/lib/php') in /var/sites/t/themoneyshed.co.uk/public_html/index.php on line 58



Offline lurkalot

  • Sr. Member
  • ****
  • Posts: 918
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: Urgent help needed please with my SMF forum
« Reply #8 on: March 21, 2017, 04:54:05 AM »
OK (I won't ask),  ;) I see TP isn't installed now, I didn't notice the scrollbar in that huge image you posted.

What exactly do you mean when you said "rolling back to yesterday morning when everything worked hasn't fixed it" ?  What exactly did you roll back?

I've got a feeling that you will be advised to upload a fresh set of files and then reinstall all your mods, but I could be wrong.

Tinyportal.net Official Support Site For TinyPortal.
Camera Craniums Running SMF 2.0.13 / Tinyportal 1.2
Guitarist Guild Running SMF 2.0.14 / Tinyportal 1.2R Beta

Offline shabbadoof

  • Semi-Newbie
  • *
  • Posts: 42
Re: Urgent help needed please with my SMF forum
« Reply #9 on: March 21, 2017, 08:07:42 AM »
Hey!

Thanks for your reply Lurkalot

I did indeed so as you said and followed the instructions on this site for uploading a fresh set of files after I had taken some backups.

It was actually quite painless it's just a case of getting all the tweaks and mods back up to speed now but at least my users can talk again on the site!

Offline lurkalot

  • Sr. Member
  • ****
  • Posts: 918
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: Urgent help needed please with my SMF forum
« Reply #10 on: March 21, 2017, 03:00:37 PM »
You're welcome.  Glad it worked out for you, at least it's a good time to update all your mods to the latest versions.  ;)

Tinyportal.net Official Support Site For TinyPortal.
Camera Craniums Running SMF 2.0.13 / Tinyportal 1.2
Guitarist Guild Running SMF 2.0.14 / Tinyportal 1.2R Beta

Offline shabbadoof

  • Semi-Newbie
  • *
  • Posts: 42
Re: Urgent help needed please with my SMF forum
« Reply #11 on: March 22, 2017, 10:12:19 AM »
I'm nearly back to how things should be but I've got quite a unique problem now

There seems to be some kind of delay on the forum.

Not in terms of usage as people can post and reply etc absolutely fine but in terms of things updating.

If someone posts a new post and I read that post it doesn't go from my 'unread posts' list for a good minute

If a new member needs manually approving I approve that member but the 'you have one member to approve' notice at the top doesn't go for a minute

If I make an alteration in a mod such a change a menu title of something I do it, hit save but it doesn't appear for another minute.

Any idea what's going on here please?


Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 54,746
  • Gender: Male
    • Kindred-999 on GitHub
Re: Urgent help needed please with my SMF forum
« Reply #12 on: March 22, 2017, 01:31:18 PM »
is your server using a caching system?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline shabbadoof

  • Semi-Newbie
  • *
  • Posts: 42
Re: Urgent help needed please with my SMF forum
« Reply #13 on: March 22, 2017, 01:39:35 PM »
is your server using a caching system?

Hi Kindred

I'm not sure, How would I find out?

The server / hosting setup hasn't changed for the last 3+ years.

The only change was on Tuesday when I did a fresh install of SMF around the existing database.