xx Is it possible to upgrade version 1.1.2. tot 2.#

January 27, 2023, 10:58:56 AM by arbmil
Hello i'm Wil from the Netherlands. My wify runn since 2003 a forum about Meatloaf in de Netherlands. Last we have a problem with the 1.1.2. version. For my wife is the forum very important ans now I will find out of it is possible tot migrated to de 2.@ versions. In 2003 I make some changes at the looks and my wife will not miss thes. I tryed to install a version en to import the database but that don't going wel.
Now I will found out if migration tot a higher version is possible.

Sorry for my bad English but I hope you understand what I means to say.

With kind regards.

Wil
1 comment | Write Comment

moved MOVED: Smf migration to new server with same domain

January 14, 2023, 06:37:49 AM by Irisado
This topic has been moved to SMF 2.0.x Support.

https://www.simplemachines.org/community/index.php?topic=584687.0
0 comments

xx In Large Upgrade, I have lost all packages

December 29, 2022, 07:08:27 AM by Baloch
Hello there,

Today I have upgraded my smf forum from 1.1.18 to 1.1.19 but I have lost all packages specially simple portal data.
Please advice what to do to resume my packages with data.

Looking forward for your prompt response
With thanks and regards
Raji
3 comments | Write Comment

solved Upgrade from SMF 1.1.21 to 2.1.2

September 06, 2022, 03:31:25 AM by Imago
First of all, I would like to thank all members and team who cared to help me in upgrading from 1.1 RC3 to 1.1.21

Now I am getting the same errors when trying to upgrade to 2.0.x or 2.1.x - tried all of them and the process stops always at 45% after adding the hash file and before converting the serialized strings, as demonstrated in the previous topic.

Tried also all possible combinations with PHP and MySQL but the problem is not there, neither is it in the cPanel or CWP.

Added also serialize_precision to php.ini - no effect. Always getting this image

19 comments | Write Comment

xx Inherited old SMF forum

August 29, 2022, 07:57:48 AM by ghaniba
Hi Folks,

I've inherited an old SMF forum.  I was asked to assist when it got a http error 500. I've got access to the host via SSH & ftp, so full access to files.  I verified it has a database it's pointing to, IP/creds match properly.  I'm guessing it was either compromised or a php version upgrade on the hosting platform happened, knocking it down.  I'm not even positive it's a 1.1 branch, but I see this in changelog.txt:

Changelog started January 1, 2004; Currently at $Revision: 1.2111.2.470 $.

SMF 1.1.4                                                                    ???
================================================================================
September 2007
--------------------------------------------------------------------------------

Also, it appears it's running a much newer version of PHP than what I'm seeing on the forum is supported -- perhaps this is the issue -- Just not sure where to even begin on this, really.

$ /usr/bin/php --version
PHP 7.4.30 (cli) (built: Jun  7 2022 15:50:00) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with the ionCube PHP Loader + ionCube24 v11.0.1, Copyright (c) 2002-2022, by ionCube Ltd.
-bash-4.2$ ls /usr/bin/php*
/usr/bin/php  /usr/bin/php-cgi  /usr/bin/phpize

Any suggestions would be very welcome!

Dave aka Ghan
17 comments | Write Comment