News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Constant login request in the administration

Started by stopguardias24h, July 30, 2022, 07:20:45 AM

Previous topic - Next topic

stopguardias24h

Hello everyone.

I am a new user of SMF, and I just did my first installation.
All good, but when I start managing the forum, every step I take asks me to enter the password.
I can't move from page to page in admin without being constantly prompted for my password.
Is there a way to indicate that you only need to log in once every so often?

Thanks.

Doug Heffernan

Quote from: stopguardias24h on July 30, 2022, 07:20:45 AMHello everyone.

I am a new user of SMF, and I just did my first installation.
All good, but when I start managing the forum, every step I take asks me to enter the password.
I can't move from page to page in admin without being constantly prompted for my password.
Is there a way to indicate that you only need to log in once every so often?

Thanks.

It should not ask for confirmation on every page load. We are talking about the Admin Panel, right?


Aleksi "Lex" Kilpinen

It should only ask it once for getting in to the admin panel, if it asks it for every page separately then perhaps there's something wrong with your cookie settings?
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

stopguardias24h


Arantor

Link to the site, to go digging further?

The admin extra step should be approximately once per hour under normal circumstances.

stopguardias24h

Quote from: Arantor on July 30, 2022, 10:07:46 AMLink to the site, to go digging further?

The admin extra step should be approximately once per hour under normal circumstances.

https://stopguardias24h.com/foro_sanitarios/index.php

Arantor

Hmmm. Putting the forum in a subfolder of WordPress doesn't usually end particularly well because WordPress forgets that people use it with other things.

Also, you didn't happen to use www in the name when you logged in, did you?

stopguardias24h

Quote from: Arantor on July 30, 2022, 12:14:18 PMHmmm. Putting the forum in a subfolder of WordPress doesn't usually end particularly well because WordPress forgets that people use it with other things.

Also, you didn't happen to use www in the name when you logged in, did you?

True, I'm using it in a subfolder. Maybe its better idea put it in a sub-domain?

And well, yes, my hosting redirects to the address without www.

Thank you.

Arantor

Quote from: stopguardias24h on July 30, 2022, 01:19:09 PMmy hosting redirects to the address without www

It doesn't actually redirect though. I was quite happily able to produce session cookies for both with and without www, which occurred to me as potentially related...

In the session cookies area, you could maybe set the cookies to be subdomain independent. But I think there's something else wrong with your site given your other thread as well.

What mods do you have installed?

stopguardias24h

Quote from: Arantor on July 30, 2022, 01:46:01 PM
Quote from: stopguardias24h on July 30, 2022, 01:19:09 PMmy hosting redirects to the address without www

It doesn't actually redirect though. I was quite happily able to produce session cookies for both with and without www, which occurred to me as potentially related...

In the session cookies area, you could maybe set the cookies to be subdomain independent. But I think there's something else wrong with your site given your other thread as well.

What mods do you have installed?

I just installed it. All the mods that I tried are for captcha, but they are unactivated. Always same result: when I try to accept the anti-spam options with recaptcha menu, its the only part where the re-log fails as related in my other post. Maybe I shoud unifie both questions :-S

Thank you.

stopguardias24h

Quote from: Arantor on July 30, 2022, 01:46:01 PM
Quote from: stopguardias24h on July 30, 2022, 01:19:09 PMmy hosting redirects to the address without www

It doesn't actually redirect though. I was quite happily able to produce session cookies for both with and without www, which occurred to me as potentially related...

In the session cookies area, you could maybe set the cookies to be subdomain independent. But I think there's something else wrong with your site given your other thread as well.

What mods do you have installed?

Well, I have more information about the error. When I try to change something like the order of my forums, it comes again to put my password, and the reply is:

Session verification failed. Please try logging out and back in again, and then try again.

Same happen when I change anti-spam settings (where the capcha can be configured). The response when I put my password when I need to change something is:

Session verification failed. Please try logging out and back in again, and then try again.

Can it help?

Arantor

Not really, this was entirely predictable given the rest of your symptoms.

What I don't get is why your sessions are not saving the way they should. I still think the first thing to do is to move it out from under the WordPress so it's not in a subfolder *and* that when it is a subdomain, cPanel hasn't made it as a folder under the WordPress anyway and see if that helps.

stopguardias24h

Quote from: Arantor on July 30, 2022, 08:17:08 PMNot really, this was entirely predictable given the rest of your symptoms.

What I don't get is why your sessions are not saving the way they should. I still think the first thing to do is to move it out from under the WordPress so it's not in a subfolder *and* that when it is a subdomain, cPanel hasn't made it as a folder under the WordPress anyway and see if that helps.

You were right. I put all the forum in a subdomain pointing to a completly differnt directory in my server, and all the errors are fixed.

Thank you!!!

Advertisement: