SMF 2.0.14 Released

Started by Colin, May 14, 2017, 05:16:14 PM

Previous topic - Next topic

vbgamer45

It's a tough call to make on one hand support old software that is years outdate. Or we can use newer PHP versions which has some better functions which can lead to better designed forum software long term.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

青山 素子

If you're stuck on EL6 and can't update, I recommend using the IUS repositories. They are managed by a solid community and do not replace system packages, but conflict with them so you have to actively replace the old ones. Just install the repo and replace the php packages with the php56u, php70u, or php71u ones.

If you don't want to replace system packages, you could look at Software Collections, a project managed by RedHat to allow side-by-side installs of different software versions. It's a bit more complex, but could work very well if you can't replace system PHP packages.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


bobtorre

wooohooo .... It crashed my forum.... happy with 2.0.13 ... and will be so for a while longer. :) ..  maybe 2.0.15 for me.

Br0ski47

Thank you so very much for this update. You guys are the best of the best.
For all those who might want to know... Softaculous did not automatically update.
System sent an email.
Had to do manually in the Softaculous backend.
*Remember to delete your update.php


Alain Rheault

 8)   many Thanks  for this udge upgrade  to give us the OK!  to move our server to PHP 7   :) 

Macabreo

Thank you very much guys for this new awesome update.

Irisado

#106
Quote from: Colin on May 14, 2017, 05:16:14 PM
Please do not use this topic for support requests.
You will receive a much quicker and better response by posting in the 2.0.x Support Board.

N.B. This was posted in response to a message asking for support which has since been removed.
Soñando con una playa donde brilla el sol, un arco iris ilumina el cielo, y el mar espejea iridescentemente

Colin

Quote from: bobtorre on May 25, 2017, 09:18:08 AM
wooohooo .... It crashed my forum.... happy with 2.0.13 ... and will be so for a while longer. :) ..  maybe 2.0.15 for me.

Make a post a support post and we can take a look.
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Arantor

It'll be the lack of PHP 5.4... again.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

spiros

Looks like the
Quote! Fix search highlighting to not mangle/expose some HTML
is not fully resolved. See https://www.simplemachines.org/community/index.php?topic=554286.0

Illori

Quote from: spiros on May 31, 2017, 10:26:25 AM
Looks like the
Quote! Fix search highlighting to not mangle/expose some HTML
is not fully resolved. See https://www.simplemachines.org/community/index.php?topic=554286.0
it was causing more issues as i said in your other topic. we had to fix the search to restore it to work.

iViscosity

I'm not sure if it's related to this or not, but as soon as I updated to 2.0.14 I started getting a bunch of spam bots on my forum. I had only installed a theme recently but it's been removed anyways.

LiroyvH

((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.

GravuTrad

Quote from: Colin on May 14, 2017, 05:16:14 PMThe PHP version requirement for this patch is 5.4.0 or newer. Please ensure that your host is currently in compliance with this or ask them to upgrade your PHP version.

Not happy with this!

Why this choice has been made on a small update and not only on a branch update??

For some sites i must stay to smf 2.0.13 for now so. Great news thanks.
On a toujours besoin d'un plus petit que soi! (Petit!Petit!)


Think about Search function before posting.
Pensez à la fonction Recherche avant de poster.

Steve

It's hardly a small update and it's the decision the team made. Sorry it's causing you grief.
Please do not PM me for support.

GravuTrad

It should have been a branch choice (upgrade) and not in a patch update or anything else. An add is surely good (php 7), but a remove is never a small choice....for smf users too!

Really sad and angry on this choice of update.
On a toujours besoin d'un plus petit que soi! (Petit!Petit!)


Think about Search function before posting.
Pensez à la fonction Recherche avant de poster.

LiroyvH

You should upgrade PHP or ask your host to. PHP 5.3 is really old (EOL'ed quite a while ago), insecure and should generally not be used in production anymore.
((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.

GravuTrad

And it could not always be updated. It should have been removed on a branch choice.  I will remove smf from certains sites on certains hosters cause your update on the branch 2.0. It should have been for the 2.1 branch this remove. Remove done now.
On a toujours besoin d'un plus petit que soi! (Petit!Petit!)


Think about Search function before posting.
Pensez à la fonction Recherche avant de poster.

Gluz

A host that has PHP 5.3 still and don't offer the possibility to change to 5.4, 5.5 or 5.6 is a bad host IMHO, most of the ones I saw helping others have at least the possibility to change, and most of them get 5.4, 5.5 and 5.6


Steve

As you can see, a branch choice was not the way to go. If we can't change your opinion, so be it but the situations presented are quite clear. Besides, out of thousands (millions?) of users, you are the only one insisting on this. That alone should tell you something. ;)
Please do not PM me for support.

Advertisement: