News:

SMF 2.1.1 has been released! Take it for a spin! Read more.

Main Menu

PHP 4.4.0 Compatibility

Started by Ben_S, July 13, 2005, 07:50:22 AM

Previous topic - Next topic

DefTol

Hello...Just wondering,is this the part that was to have the ampersand removed,and if so is this the only place that it is located?

$ret = mysql_query($db_string, $db_connection);
if ($ret === false)
$ret = db_error($db_string, $file, $line);

Meriadoc

yes, there was only one place to remove it from, and that was it :)
If I know the way home and am walking along it drunkenly, is it any less the right way because I am staggering from side to side? : Leo Tolstoy
Everything I know I learned from Calvin and Hobbes.
And patience is about the most useful thing you could ever have.  That and backups. : [Unknown]
If I choose to send thee, Tuor son of Huor, then believe not that thy one sword is not worth the sending. : Ulmo, Lord of the Waters - Unfinished Tales, by J.R.R. Tolkien

MrWoof

that was a sweet and simple update. i just got the message today about subs.php, found this and voila! :D
Are you a reality tv fan? Visit Reality HQ today to get your latest dose!

[Unknown]

Please post a link to your forum.

-[Unknown]

Mark_Breznay

I have v 1.0.5 installed.  Do I need this php upgrade?  If so, where do I find the upgrade files?
Mark
http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

xenovanis

Quote from: Mark_Breznay on August 07, 2005, 01:29:09 PM
I have v 1.0.5 installed.  Do I need this php upgrade?  If so, where do I find the upgrade files?
Mark

Yes, it would be wiser to update just incase your host decides to change the php-version. Have you read the first post of this topic? It describes three different ways of how you can update.
"Insanity: doing the same thing over and over again and expecting different results."

dtm.exe

Quote from: Mark_Breznay on August 07, 2005, 01:29:09 PM
I have v 1.0.5 installed.  Do I need this php upgrade?  If so, where do I find the upgrade files?
Mark

PHP 4.4.0 is not required to run SMF 1.0.5.  This is merely a fix to make SMF 1.0.5 compatible with this new version of PHP.

-Dan The Man

Mark_Breznay

My Package Manager doesn't work.  I don't have any mods.  Please SPECIFY which one I should use.  I don't like multiple choice.
Mark
http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

xenovanis

Quote from: Mark_Breznay on August 07, 2005, 03:16:12 PM
My Package Manager doesn't work.  I don't have any mods.  Please SPECIFY which one I should use.  I don't like multiple choice.
Mark

Just upload the attached Subs.php to your Sourcesdirectory.
"Insanity: doing the same thing over and over again and expecting different results."

Mark_Breznay

http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

dtm.exe

Quote from: Mark_Breznay on August 07, 2005, 04:32:41 PM
???????????????

Would you like for me to do it for you?  I understand how some people aren't the best with computers and the internet (like my mom :P).  Please PM or IM me if I can assist you with the upgrade.

-Dan The Man

Mark_Breznay

Just upload the attached Subs.php to your Sourcesdirectory.

This is what confused me.  To me, it indicated that this person had attached a file to his message.  I went back to the start of the thread and found the file.  It is now uploaded and all, hopefully, is well.  Thanks.
Mark
http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

tdv

When I remore the '&', I got the following message:
QuoteNotice: Undefined index: is_admin in /home/davidh05/public_html/smf/Sources/Security.php on line 556

Notice: Undefined index: permissions in /home/davidh05/public_html/smf/Sources/Security.php on line 563

Warning: in_array(): Wrong datatype for second argument in /home/davidh05/public_html/smf/Sources/Security.php on line 563
session_start(): Cannot send session cache limiter - headers already sent (output started at /home/davidh05/public_html/smf/Sources/Subs.php:1890)
What I should do to get my board back?

xenovanis

Which version of SMF are you using? Try uploading the attached Subs.php from the first post of this thread. You'll need to install some mods again.
"Insanity: doing the same thing over and over again and expecting different results."

tdv

I uploaded the Sub.php, and got my boards back, thanks. ;)

SMAguy

Well, I have precisely the same problem as tdv but uploading the new Sub.php DIDN'T affect anything. I have SMF 1.04 and various mods.

Any ideas?

[Unknown]

Upload all of the files from the upgrade zip file on the downloads page and reinstall your mods.

-[Unknown]

SMAguy

Actually, having initially sent a trouble ticket to my hosting service, I received a reply in the interim from an engineer with them (they had just upgraded to PHP 4.4) and he examined the Sub.php and noticed an extra blank line that was somehow causing the problem!

I'm pretty impressed with that service (Site 5), I must say .


Herman's Mixen

oke ... but host upgraded to php 4.4.0 so why isn't SSI.php work correctly now
with SMF 1.0.5 installed it worked great with 4.3.xx of php version
???

Met vriendelijke groet, The Burglar!

 House Mixes | Mixcloud | Any Intelligent fool can make things bigger, more complex, and more violent.
It takes a touch of genius - and a lot of courage - to move in the opposite direction. - Albert Einstein

Former Godfather of our dutch community ;)

xtremecruiser

Ok stupid Question.
My host went to 4.4.0 and I did the update and it was fine.  They changed back to 4.3.1 :o will that cuase issues ?
Thanks

Advertisement: