News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

Merge Double Posts By Same Member

Started by ディン1031, June 11, 2005, 04:54:02 PM

Previous topic - Next topic

Hiei-

Not solved but that not a big deal, I think, with this line of code : $MergePosts_button = create_button('doublepost.gif', 'a', 'a', 'align="middle"');

The button is displayed fine, there's just the problem that it don't appear like the others if you disable images in your web browser by example.

About the image I used for the button, I used the one in the archive (which I renamed "doublepost.gif" but I could have keep "mergeposts.gif", that would have been the same.).

By chance, in french, the function is also called "Double Post" so no need to change the button :) (and so you can also keep the same for the French package).

ディン1031

Okay i add thie Double Post Image from the english Package :).

Hmmm Okay i know your problem, normal this function is used in the default theme, you can use

//Doublepost for Merge?
if ($message['can_modify'] && $message['doublepost']['postok'] && !empty($message['doublepost']['lastpostid']))
echo '
<a href="', $scripturl, '?action=mergeposts;pid=', $message['id'], ';msnid=', $message['doublepost']['lastpostid'], ';topic=', $context['current_topic'], '">', ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/mergeposts.gif" alt="'.$txt['merge_doublepost'].'" Title="'.$txt['merge_doublepost'].'" border="0" />' : $txt['merge_doublepost'] ), '</a>';


This is the old way of using this image ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Hiei-

#282
Changing the last line "<a href .......... etc..."> keep showing the "Double Posts" link next to the "Button" so, at least, I put it back like before ("a", "a") to hide the link and will leave it like that if there's no other choice, that's not a big deal because chances are reallylow that someone browse/use the forum with images disabled ^^

wrongwood

I tried this mod and it worked without a hitch it was great until I decided to try and uninstall it.  Is there any way I can get this to re-install.  I like the mod but now it does not work.  It keeps telling me that I already have the mod and there is no new update available.  Please contact the mod maker.

If I can't un-install it and now I can't re-install it.  How am I supposed to use it?
Please someone help.  If I have to I will uninstall it by hand if someone can tell me where it is located and what was changed.

Thanks for a prompt reply in advance.

ディン1031

Upload a newer version so that it compatible to the new version, normal it should be uninstallable.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

wrongwood

Although I do appreciate the help this is not the problem.  I have the latest version of the mod as far as I know.  I got it from the link that says it is the latest version.

My question and my problem is I cannot un-install it.  If I could I would just re-install it.

I can't get rid of it and I can't use it because it isn't there according to the install records.
There has been some kind of malfunction and I am wondering how I fix it.

ディン1031

Hmmm i do not unterstand the problem.

What did you do that you need to install the mod again?

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

wrongwood

It doesn't work.  I doesn't show.  I wanted to un-install it so that I could re-install it.

This is very typical of a lot of mods.  Once they are installed they don't seem to un-install.

Coldfx

This mod is no longer there - did you remove it?

wrongwood

Yes I removed it but it will not re-install.  That is my whole problem.  I want to use the mod but I keep getting it will not install because I already have the program installed but...that isn't true it isn't there anymore.  Here is the exact error message:

This package cannot be uninstalled, because there is no uninstaller!

Please contact the mod author for more information.

Neorics

[For Hire] I can help you with anything regarding Simple Machines Forum and TinyPortal  ~ My Portfolio

wrongwood

What?  are you serious?  if you are, I don't understand your question?

Where's the mod?  What does that mean?

Neorics

i clicked the link to mod and it said that the mod cant be found....
[For Hire] I can help you with anything regarding Simple Machines Forum and TinyPortal  ~ My Portfolio

aldo


_Jojo_

Indeed, just wanted to download it but the site is gone :(
What happened?

Hunnenkoenig

Quote from: ディン1031 on September 04, 2007, 05:54:18 AM
I looked into your display.template.php and see that it look good what you changed :x.

But did you upload the mergeposts.gif in the images/yourlanguage in the theme that you use?

Bye
DIN1031

I uploaded the image yes. Automerge works fine, but now I realised that I get this error message on the "Failure Protocol" page:

8: Undefined variable: MergePosts_button
File: /home/.../.../forum/Themes/.../Display.template.php (main sub template - eval?)
Line: 785

kamili34


ZeroMinuS

Is this mod discontinued? Where did it go?

shumar


rumfa


Advertisement: