• Welcome to Simple Machines Community Forum. Please login or sign up.
December 03, 2021, 01:00:13 PM

News:

Join the Facebook Fan Page.


menu con immagini

Started by _Luke_, January 27, 2011, 05:47:02 PM

Previous topic - Next topic

_Luke_

ragazzi come posso mettere al posto del menu di base tipo home messaggi utenti esci ecc mettere al loro posto le immagini con scritto home messaggi ecc.. in pratica sostituire le parole di base del tema cn le immagini
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

emanuele

Versione?

Comunque, se non ricordo male, devi modificare il template.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

_Luke_

SMF 2.0 RC4 se c'è da modificare puoi dirmi dove agire? grazie
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

emanuele

Se non vuoi complicarti troppo la vita con il codice (ma devi provare perché non so come possa essere il risultato finale! ;)), puoi aprire il file index.TUALINGUA.php (quindi immagino index.italian.php) e cercare queste stringhe:

$txt['home']
$txt['help']
$txt['search']
$txt['admin']
$txt['moderate']
$txt['profile']
$txt['pm_short']
$txt['calendar']
$txt['members_title']
$txt['login']
$txt['register']
$txt['logout']


appariranno nella forma:

$txt['logout'] = 'nome_pulsante';

e sostituirle con qualcosa di simile a:

$txt['logout'] = '<img src="' . $settings['theme_url'] . '/immaginimenu/logout.png" alt="nome_pulsante" />';

se opti per questa soluzione, credo tu debba anche aprire subs.php, cercare:
function setupMenuContext()
{
global $context, $modSettings, $user_info, $txt, $scripturl;

e farlo diventare:
function setupMenuContext()
{
global $context, $modSettings, $user_info, $txt, $scripturl, $settings;

e potrai mettere le immagini nella directory del tuo tema (nell'esempio sopra le ho messe in una sottodirectory "immaginimenu") e chiamandole come ti pare.

Altrimenti ci sono modi alternativi.
Ad esempio potresti creare le immagini e chiamarle con la stringa che trovi nel primo blocco di codice che ho scritto sopra (es. home, help, members_title, ecc.) più naturalmente l'estensione. Quindi le salvi nella directory del tuo tema (eventualmente in una sottodirectory, vedi tu).
A quel punto apri index.template.php e cerchi:
// Show the menu up top. Something like [home] [help] [profile] [logout]...
function template_menu()
{
global $context, $settings, $options, $scripturl, $txt;

echo '
<div id="main_menu">
<ul class="dropmenu" id="menu_nav">';

foreach ($context['menu_buttons'] as $act => $button)
{
echo '
<li id="button_', $act, '">
<a class="', $button['active_button'] ? 'active ' : '', 'firstlevel" href="', $button['href'], '"', isset($button['target']) ? ' target="' . $button['target'] . '"' : '', '>
<span class="', isset($button['is_last']) ? 'last ' : '', 'firstlevel">', $button['title'], '</span>
</a>';

li potrai cambiare più o meno a tuo piacimento l'apparenza e la struttura del menù, ottenendo qualcosa tipo:

// Show the menu up top. Something like [home] [help] [profile] [logout]...
function template_menu()
{
global $context, $settings, $options, $scripturl, $txt;

echo '
<div id="main_menu">
<ul class="dropmenu" id="menu_nav">';

foreach ($context['menu_buttons'] as $act => $button)
{
echo '
<li id="button_', $act, '">
<a class="', $button['active_button'] ? 'active ' : '', 'firstlevel" href="', $button['href'], '"', isset($button['target']) ? ' target="' . $button['target'] . '"' : '', '>
<span class="', isset($button['is_last']) ? 'last ' : '', 'firstlevel"><img src="', $settings['theme_url'], '/immaginimenu/', $act, '.png" alt=", $button['title'], '" /></span>
</a>';

In questo caso il risultato sarà sostanzialmente uguale al precedente, ma se vuoi avere ad esempio immagini diverse a seconda che il pulsante sia "selezionato" o meno potresti fare qualcosa di questo genere:

// Show the menu up top. Something like [home] [help] [profile] [logout]...
function template_menu()
{
global $context, $settings, $options, $scripturl, $txt;

echo '
<div id="main_menu">
<ul class="dropmenu" id="menu_nav">';

foreach ($context['menu_buttons'] as $act => $button)
{
echo '
<li id="button_', $act, '">
<a class="', $button['active_button'] ? 'active ' : '', 'firstlevel" href="', $button['href'], '"', isset($button['target']) ? ' target="' . $button['target'] . '"' : '', '>
<span class="', isset($button['is_last']) ? 'last ' : '', 'firstlevel"><img src="', $settings['theme_url'], '/immaginimenu/', $act, '_', $button['active_button'] ? 'active ' : '', '.png" alt=", $button['title'], '" /></span>
</a>';

e chiamerai i file ad esempio:
help_active.png
help.png

Poi, un'altra possibilità, è di togliere le scritte ed usare i css...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

_Luke_

userò molto probabilmente la prima prova :) provo e ti faccio sapere :) grazie...!!!!
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

_Luke_

guarda un po.. nn mi cambia l'immagine..
index.italian.php

$txt['home'] = '<img src="' . $settings['theme_url'] . '/images/homee.png" alt="Indice" />';

Subs.php


function setupMenuContext()
{
global $context, $modSettings, $user_info, $txt, $scripturl, $settings;


l'immagine però non compare ..come mai?
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

emanuele

Quando apri la pagina il percorso dell'immagine è corretto o ne manca un pezzo?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

_Luke_

l'immagine si trova sia nel tema che uso e sia in quello di defaul in quella cartella
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

emanuele

Intendo il percorso nell'url dell'immagine quando apri la pagina del forum, nell'html.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

_Luke_

ora ho messo cosi
$txt['home'] = '<img src="' . $settings['theme_url'] . '/Themes/BlackRain204/images/home.png" alt="home" />';
ma nn va
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

emanuele

ok, ma mi dici cosa vedi nella pagina HTML del forum come src del tag img?

Errori nel log? (tipo 'theme_url not defined')

Inoltre, "non va" e "non funziona" non vogliono dire niente.
Immagino che tu voglia dire che non si vede l'immagine, ma scriverlo per esteso ti risparmia possibili fraintendimenti. ;)  (e non preoccuparti, non fa venire i calli alle dita :P)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

_Luke_

January 29, 2011, 02:46:14 PM #11 Last Edit: January 29, 2011, 09:30:49 PM by _Luke_
negli errori non mi da nessun errore...
l'immagine non si vede per tant nel codice HTML nessun errore..
dimmi cosa dovrei vedere bene
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

emanuele


<img src="http://www.tuosito.it/forum/Themes/default/images/home.png" alt="home" />
__________^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

che cosa c'è scritto (nell'html, non nel codice php) al posto della parte sottolineata da "^^^".


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

_Luke_

<li><a  href="http://miosito.com/index.php"><span>Indice</span></a></li>
c'è solo questo
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

emanuele

Io ho appena provato su un'installazione pulita di SMF e funziona...
Hai per caso installati mod? Se sì quali?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

_Luke_

ho questi MOD
1.     Adk Portal    
2.    VB Style Board Index    
3.    Registered Links    
4.    Welcome Topic Mod
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

emanuele

Onestamente non ho idea.

Hai provato solo con home?
Potrebbe essere che il portale si usa una sua variabile diversa...non saprei proprio.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

_Luke_

provo su altri tasti.. ma secondo me sarà uguale.. grazie lo stesso per l'aiuto.
NEL MiNUTO iN CUi STAi PENSANDO Di ARRENDERTi PENSA ALLA RAGiONE PER CUi HAi RESiSTiTO COSi A LUNGO...

Advertisement: