News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

I need some help, really hard. Any help is welcomed!!

Started by kizko, December 10, 2009, 10:40:52 AM

Previous topic - Next topic

kizko

Quote from: Kays on December 21, 2009, 08:05:15 AM
Is there a "temp" folder in the Packages folder?

If not, create one and chmod it to 777 or 755 depending on which your server allows.

There wasnt any temp folder. I create it, and istalled succesufull Gobal header and footer, but no mod appear in admin panel. And RSS feed controal panel disapear.

Kays

But it did install and it is showing in the package manager as being installed now?

Did you attempt to install it on the theme you are using?

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

kizko

Quote from: Kays on December 21, 2009, 08:20:06 AM
But it did install and it is showing in the package manager as being installed now?

Did you attempt to install it on the theme you are using?

View and Remove Installed Packages
   Mod Name    Version    
1.    Global Headers Footers    2.0    [ Uninstall ]
2.    Aeva ~ Auto-Embed Video & Audio    7.0    [ Uninstall ]
3.    RSS Feeder    1.1.4    [ Uninstall ]


Yes it apears as installed...
I didn`t isntalled it for my theme... How should i do that ?
Do i have to unistall and install it back ? An select to isntall on that theme?

Kays

Quote
Do i have to unistall and install it back ? An select to isntall on that theme?

Yes, that would be the best way.

If it shows an error then you will need to do a manual install on whatever file is showing the error.


Please see: Manual Installation of Mods

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

kizko

Quote from: Kays on December 21, 2009, 08:32:44 AM
Quote
Do i have to unistall and install it back ? An select to isntall on that theme?

Yes, that would be the best way.

If it shows an error then you will need to do a manual install on whatever file is showing the error.





Please see: Manual Installation of Mods


Installing this package will perform the following actions:
      Type    Action    Description
*    1.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test failed
      1.    Replace    ./Themes/default/languages/Modifications.english.php    Test failed
   2.    Execute Modification    ./Themes/default/languages/Modifications.english-utf8.php    Skipping file
*    3.    Execute Modification    ./index.php    Test failed
      1.    Replace    ./index.php    Test failed
*    4.    Execute Modification    ./Sources/Subs.php    Test failed
      1.    Replace    ./Sources/Subs.php    Test failed
      2.    Replace    ./Sources/Subs.php    Test failed
      3.    Replace    ./Sources/Subs.php    Test failed
*    5.    Execute Modification    ./Sources/Admin.php    Test failed
      1.    Replace    ./Sources/Admin.php    Test failed
   6.    Execute Code    UnInstall.php    

It gave me errors on unistall. Everywhere!
Only  2.     Execute Modification     ./Themes/default/languages/Modifications.english-utf8.php     Skipping file
is skiped.

Arantor

Is the mod actually installed? That suggests it isn't.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

Kays

His previous posts shows that they are installed.

Try uninstalling them in the reverse order they were installed in.

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

kizko


Kays

Have you tried uninstalling in reverse order?

If that sill gives errors. Then forget about uninstalling and just do any edits to the theme you are using manually.

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

Norv

You may want to verify if it's installed indeed on files, or isn't it: choose one of the files that give failed test on uninstall, and check the mod's page for the edits that should be in the file. Open the file and check if they were done. Same for the others. It might be useful to know if it didn't do *any* edits, despite saying it was "installed successfully" in the first place.
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

kizko

Quote from: Norv on December 21, 2009, 09:07:16 AM
You may want to verify if it's installed indeed on files, or isn't it: choose one of the files that give failed test on uninstall, and check the mod's page for the edits that should be in the file. Open the file and check if they were done. Same for the others. It might be useful to know if it didn't do *any* edits, despite saying it was "installed successfully" in the first place.

It didn`t do any edits... Can`t find any modification, except Pretty URLS (this one i`ve installed manually).

Norv

It sounds like a permission issue. What permissions have those exact files?
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

kizko

Quote from: Norv on December 21, 2009, 10:57:52 AM
It sounds like a permission issue. What permissions have those exact files?

All sources files and package and theme files have 777

Norv

Errors in the error log for this specific installation?
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

kizko

Quote from: Norv on December 21, 2009, 11:30:00 AM
Errors in the error log for this specific installation?

No but i have a lot of:


Apply Filter: Only show the errors with the same message
8: Undefined index: mods_cat_modifications_rssfeeds
Apply Filter: Only show the errors from this file
File: /var/www/vhosts/psp-fanatik.ro/subdomains/forum/httpdocs/Sources/Admin.php
Line: 210

Apply Filter: Only show the errors with the same message
8: Undefined index: mods_cat_modifications_rssfeeds
Apply Filter: Only show the errors from this file
File: /var/www/vhosts/psp-fanatik.ro/subdomains/forum/httpdocs/Sources/Admin.php
Line: 210


This is from the mod:

Apply Filter: Only show the errors with the same message
2: fclose(): supplied argument is not a valid stream resource
Apply Filter: Only show the errors from this file
File: /var/www/vhosts/psp-fanatik.ro/subdomains/forum/httpdocs/Sources/Subs-Package.php
Line: 2424



Apply Filter: Only show the errors with the same message
2: fopen(/var/www/vhosts/psp-fanatik.ro/subdomains/forum/httpdocs/index.php) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied
Apply Filter: Only show the errors from this file
File: /var/www/vhosts/psp-fanatik.ro/subdomains/forum/httpdocs/Sources/Subs-Package.php
Line: 2417


Apply Filter: Only show the error messages of this URL  http://forum.psp-fanatik.ro/index.php?action=admin;area=packages;sa=uninstall;package=globalheadersfooters.zip;pid=3
Apply Filter: Only show the errors with the same message
8: Undefined index: mods_cat_modifications_rssfeeds
Apply Filter: Only show the errors from this file
File: /var/www/vhosts/psp-fanatik.ro/subdomains/forum/httpdocs/Sources/Admin.php
Line: 210

...

Norv

It seems like RSS Feeder was installed with errors, that is, was not properly installed.
Did you have errors during its installation? Is the mod compatible with RC2?

Might be worth trying to check the edits that RSS Feeder needs, as per its page, and see if your files have them. In particular, you might want to check your language files, if they have the edits indicated for the mod in *.language.php files, specially if you're using another language on the forum than English.
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

kizko

Quote from: Norv on December 21, 2009, 02:06:30 PM
It seems like RSS Feeder was installed with errors, that is, was not properly installed.
Did you have errors during its installation? Is the mod compatible with RC2?

Might be worth trying to check the edits that RSS Feeder needs, as per its page, and see if your files have them. In particular, you might want to check your language files, if they have the edits indicated for the mod in *.language.php files, specially if you're using another language on the forum than English.

I have RC1.2, and it is compatible only with RC2, now i See... But i emulate for other version and install it without errors.

Norv

On this note, it may be a good idea to upgrade to RC2. There are lots of bug fixes done meanwhile.

I'm not fully sure I understand what happened with RSS Feeder, please correct me if I get it wrong: you tried to emulate RC2 on a RC1.2 installation?

It may be worth to check the language files anyway. What language(s) is your forum using currently? (and please specify if they're utf8 or not)
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

kizko

Quote from: Norv on December 23, 2009, 02:54:43 AM
On this note, it may be a good idea to upgrade to RC2. There are lots of bug fixes done meanwhile.

I'm not fully sure I understand what happened with RSS Feeder, please correct me if I get it wrong: you tried to emulate RC2 on a RC1.2 installation?

It may be worth to check the language files anyway. What language(s) is your forum using currently? (and please specify if they're utf8 or not)

My theme don`t work on RC2...
Where can i find thoose Language files ?

And yes, i emulate for RC2 on RC1.2

Norv

Admin > Languages, to see the languages currently installed.

The files themselves, are in ./Themes/default/languages/.
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

Advertisement: