• Welcome to Simple Machines Community Forum. Please login or sign up.
December 03, 2021, 02:06:49 PM

News:

Follow SMF on Twitter.


TinyPortal

Started by lurkalot, February 12, 2005, 04:43:00 AM

Previous topic - Next topic

bloc

No, its great you share this. I have not been able to look at this problem yet - just on my "bug"- list , so if it is a issue with SMF, it will of course be present in TinyPortal too...

Let me know what you find out eventually - if you have the time. :)

verbam

February 26, 2005, 08:20:29 AM #141 Last Edit: February 26, 2005, 08:48:26 AM by verbam
Thanks!  :)

I have taking some time to make a PDF document with the settings and results off these.
Let's hope you will get something out off it.

Here is the document: http://verbam.sytes.net/xtra/SMC_ERROR_20050226.pdf [nofollow]

Little correction from the document: My opinion: "It goes wrong there where SMF shows the attachment !"

Let me know something!

CU

bloc

ah..I understand some more now...the behaviour of returning to the frontpage is default in SMF. As TinyPortal patches the index.php to go to TP frontpage instead, it will naturally go there of course. If TP is not installed it would just go to the boardindex.

I think [Unknown] has written something about why it is like that. If I remember correctly it was more problems with it staying at the page, than just returning to index.php.

verbam

Yes, BUT

The thing what i try to tell, exept it goes wrong at the portal, the greatest error comes from SMF.
SMF shows the download links in the forum to GUESTS !
example how it goes wright:    index.php?action=recent   gives the correct pages (without the download link)

Maybe SMF can considder to check this.

Thanks for all your replies !!!!

[Unknown]

Obviously the cookie isn't setting properly, or you have cookies disabled and the session isn't carrying through.

It is meant to show attachments to guests, but not allow them to download them.  This is as intended.

-[Unknown]

verbam

It is meant to show attachments to guests, but not allow them to download them.  This is as intended.

No ! Do NOT showing the attachents at all to the guest (like it is in your recent.php) !
But the forum SHOWS the attachment, while mmy settings are DON'T show it !!!

CU

bloc

I think that could be done by just modifying the Display.tempalte a bit. You essentially dont want to show anything about whether there is an attachment or not to guests?

I guess - not having looked at it - it could be put behind a check to see if the user is a member or not.

Tanks

Hey Bloc

'Whats the status on version 0.5 ??

I feel like a little kid waiting for christmas  :P

The things i really need so badly to work is:

Permissions and the new posts shown on frontpage.

again i must thank you for this portal, its very great software :-)


nanoarray

Thanks, Bloc, for re-directing me here.  I had difficulty finding this thread.  Anyway, I post my question again here:

I notice that after I close the right and left side boxes, they reappear if I click any link.  Is there a way to close the side box permanently when users close them the first time?  It may become annoying for users to close them every time after they click a link.  Any suggestion?

bloc

:) They should do that already...but only if you are a member. As a guest they will not remember what they were.

_complex

Should I install this version. Or wait for V5 as someone said in this thread earlier... what's the progress of that version.

Or should i just gone ahead and install this version???.. thanks..

complex

bloc

I am getting near finishing v0.5beta so you could wait for that. Its going to work fine upgrading from 0.4 though - you could try it if you want.

nanoarray

Is there a way to set my forum so that users can choose a language between English and French?

fittizle

Quote from: wise on February 24, 2005, 06:33:45 AM
just installed the portal. It's adjusted my frontpage - but I dont see any tpadmin settings at all?? How do I edit the portal??!!

I was wondering the same exact thing.

bloc

Quote from: nanoarray on March 05, 2005, 05:06:13 AM
Is there a way to set my forum so that users can choose a language between English and French?
If you mean the whole forum, not just TinyPortal - you need to download french langauge pack, install it into default themes languages folder, and finally choose french in admin section(it will show up when you ahve uploaded it.)

Now - Tinyportal use the same system, but I haven't translated it to french, so you need to copy the TPxxxx.english.php and rename them to TPxxxx.french.php. If you then look into them the texts can be translated.

Currently its not many texts that are not hard-coded, but in future releases this will change.

bloc

Quote from: fittizle on March 05, 2005, 05:31:45 AM
Quote from: wise on February 24, 2005, 06:33:45 AM
just installed the portal. It's adjusted my frontpage - but I dont see any tpadmin settings at all?? How do I edit the portal??!!

I was wondering the same exact thing.

Check if this is correct:

1. You are using the default theme, or a converted theme to show the blocks and the extra buttons ( forum and tpadmin)

2. If you are not , you can still access:
Tinyportal admin : index.php?action=tpadmin
Forum frontpage: index.php?action=forum

But I would suggest converting your preferred theme or using a already converted one.

nanoarray

I want to put underline in page index links.  How do I do that?  If I change stylesheet, it will change the whole forum, but I just want to underline the page index.

bloc

You need to open TPortal.template.php and find this code:
            // show number of pages, don't show 0 pages
            if($pages>0){
              echo '<div style="padding: 5px; text-align: right; padding-right: 50px;">  ';
              echo '<b>Pages</b>: ';
              for($t=0 ; $t<=$pages ; $t++){
                     $s=$t+1;
                     if($t==$whichpage){
                       echo ' <b>['.$s.']</b> ';
                     }
                     else{
                       $what=floor(($t*$context['TPortal']['frontpage_limit']));
                       if($what<0)
                          $what=0;
                       echo ' <a href="' . $scripturl . '?tpstart='. $what .'', (isset($context['TPortal']['mycat']) && $context['TPortal']['mycat']!='') ? ';cat='.$context['TPortal']['mycat'] : '' ,'" /><b>'.$s.'</b></a> ';
                     }
               }
               echo '</div>';
            }
         }


Now, for you to change the "pages" style, I suggest adding a new style to <a href="' . $scripturl . '?tpstart.... like this:
<a style="pagenav" href="' . $scripturl . '?tpstart......

Then in style.css you define that style like :

.pagenav, .pagenav:link, .pagenav:visited
{
        text-decoration: underline;
}

a.pagenav:hover
{
        color: #cc3333;
}

fittizle

March 05, 2005, 04:12:46 PM #158 Last Edit: March 05, 2005, 04:14:19 PM by fittizle
Quote from: Bloc on February 22, 2005, 01:34:31 PM
Well, at least some of my themes are already converted : Helios, Mercury and Themis. And of course SMF default theme..that one is the the one that gets modded..! For downloads of my converted ones , look here :
hxxp:www.bloczone.net/smf/index.php?board=24.0 [nonactive]

As for the others they will have to be done manually, but its only index.template.php in them that needs some modifications. If the theme authors agreed on that, i could help out on this...but I won't start mass-converting them as such.

I will make a tutorial on how to convert other themes though. 

I did exactly what the tinyportal.mod instructed to do for the index.template.php, but I got a parse code error that says the following.

emplate Parse Error!
There was a problem loading the /Themes/Daze_burgandy/index.template.php template or language file. Please check the syntax and try again - remember, single quotes (') often have to be escaped with a slash (\). To see more specific error information from PHP, try accessing the file directly.

You may want to try to refresh this page or use the default theme.

nanoarray

Thanks.  It's a good try, but it doesn't work.  I notice that in MessageIndex.template.php, there is a variable called  $context['page_index'].  It's at the very last line.  Which file contains the definition of that variable?


// Finish off the form - again, if Quick Moderation is being done with checkboxes. (1)
if (!empty($options['display_quick_mod']) && $options['display_quick_mod'] == 1 && !empty($context['topics']))
echo '
<input type="hidden" name="sc" value="' . $context['session_id'] . '" />
</form>';

echo '
<table width="100%" cellpadding="3" cellspacing="0" border="0" class="tborder" style="margin-top: 1ex;">
<tr>
<td align="left" class="catbg" width="100%">
<table cellpadding="0" cellspacing="0" width="100%">
<tr>
<td nowrap="nowrap" style="font-size: smaller;">
                            <a name="bot"></a><b>', $txt[139], ':</b> ', $context['page_index'], $modSettings['topbottomEnable'] ? $context['menu_separator'] . '<a href="#top">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/go_up.gif" alt="' . $txt['topbottom4'] . '" border="0" align="top" />' : $txt['topbottom4']) . '</a>' : '', '

Advertisement: