News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

SMF 2.0.2 and 1.1.16 critical security patches released

Started by Norv, December 22, 2011, 11:43:01 PM

Previous topic - Next topic

Masterd


BigJacko

I think I've found a problem with one of the files in the 2.0.2 small-update from the downloads area (alas, I'm using Windows IIS6, and thus package manager is seemingly impossible to get working properly, so I have to do manual updates). This one - http://download.simplemachines.org/index.php?thanks;filename=smf_2-0-2_update.zip

Anyway, the errant file in question is:

Themes/default/PersonalMessage.template.php

and the problem seems to be that it is still reporting as Version 2.0, not version 2.0.2

Is this correct?

I noticed that after I did the manual file-copy followed by running the 'upgrade.php' to sort out my MySQL DB - all of which seemed to work ok - I went back to the Administration Center and confirmed that my board had updated. The Admin Center shows '2.0.2' as the headline version, but when doing the 'more detailed' check, I see Default Templates with a red 2.0 next to it, and when I open that up, I see a red 2.0 next to PersonalMessage.template.php.

I confirmed that I had correctly copied the right files over, so I then looked at the individual files within the 2.0.2 small update distribution file and compared PersonalMessage.template.php from the Core and Default themes in a file-comparison utility. They are vastly different (maybe to be expected? I don't know) - but specifically, the Core instance of the file showed Version 2.0.2 while the Default instance showed 2.0

Is this correct? Did someone forget to include the correct Default Theme file in the small manual upgrade zip?

My forum uses the Default Theme, by default (and I have no idea whether that's a clone of the Core theme, or what) - so will I have a problem at some point when members start using the PM system?

Any help gratefully received - if you need further information or testing please ask away! Thanks.

Neil
This area zoned for redevelopment. Apply City Planning Dept. Brown envelopes preferred if bringing bribes.

Illori

take a look at http://www.simplemachines.org/community/index.php?topic=463145.0 also this thread is not for support you should open your own thread for issues related to the upgrade.

BigJacko

Ilori - thanks for the pointer to the other thread. I will continue this discussion there.

However, for the record, I wasn't actually looking for support, and don't consider this a personal support issue. I was merely trying to be helpful, and was reporting an ERROR with the small-update zip's contents (an error which I can see is indeed accepted as such on the other thread).

Thanks anyway.
This area zoned for redevelopment. Apply City Planning Dept. Brown envelopes preferred if bringing bribes.

OlivierShop

SMF 2.0.2

bassinRN

Quote from: Fantasy-Faction on December 23, 2011, 03:49:45 AM
Hey guys!

Trying to update from 1.1.15 and getting the following message:
The package you are trying to download or install is either corrupt or not compatible with this version of SMF.

Any ideas? :)

Same here...????

mashby

Quote from: bassinRN on January 04, 2012, 07:03:17 AM
Quote from: Fantasy-Faction on December 23, 2011, 03:49:45 AM
Hey guys!

Trying to update from 1.1.15 and getting the following message:
The package you are trying to download or install is either corrupt or not compatible with this version of SMF.

Any ideas? :)

Same here...????
http://www.simplemachines.org/community/index.php?topic=463108.msg3234016#msg3234016
Always be a little kinder than necessary.
- James M. Barrie

ShastaEXE

Thanks for the updates SMF team, will be sure to update once I have everything else set up but thanks again for all your work

~Shasta

|

"Random Fact: I have a mini traffic cone under my desk"

Kokoin

Quote from: [email protected] on January 01, 2012, 03:57:38 PM
I'm afraid I don't understand that, Kokoin.
Does this help?
http://www.simplemachines.org/community/index.php?topic=463108.msg3234016#msg3234016


ok [email protected] , your attached file download. I manuel editing;
index.php
sources/packages.php
sources/messagindex.php

Thank you...

Lolafish

Do these security updates address DDOS attack vulnerability?

AquaPuppies - A Goldfish Community
www.aquapuppies.com

Running SMF 2.0.2 & SimplePortal 2.3.5

Arantor

Nope. You can't solve a DDOS issue at the application level, if you're being hit by a DDOS, talk to your host.

Lolafish

Quote from: arrowtotheknee on January 11, 2012, 02:33:06 PM
Nope. You can't solve a DDOS issue at the application level, if you're being hit by a DDOS, talk to your host.

That's what I thought.  Thanks!

AquaPuppies - A Goldfish Community
www.aquapuppies.com

Running SMF 2.0.2 & SimplePortal 2.3.5

kaoss

I've used it before, but can't find it now, the step by step instructions on upgrading from an older version? I'm on SMF 2.0 RC4. Thanks!

Kindred

Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

ForestEB

Hello, I have some problem.
How to fix this?

Not Acceptable

An appropriate representation of the requested resource /forum/index.php could not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.21 (Unix) mod_ssl/2.2.21 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at hxxp:mcekvidetibugs.net [nonactive] Port 80

Arantor

What exactly were you trying to do when you got that message?

Ieazo

Please help our forum has gone down and I am on-line now trying to fix but I must admit to not really having a clue what is going on, any advice greatfully received. It is throwing the following message no matter what I try, won't let me into admin panel or owt???

"Table './planetai_smf924/smf_log_online' is marked as crashed and should be repaired
File: /home/planetai/public_html/Sources/Subs.php
Line: 2608

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.2, while your database is at version 2.0.1. The above error might possibly go away if you execute the latest version of upgrade.php."

Apologies if I have posted in the wrong section, I'm a bit new to all of this and slightly panicked.

Illori

Quote from: Illori on December 23, 2011, 06:13:00 AM
also dont use this thread for support please open a separate thread in the correct support board for support

vbgamer45

Login to your control panel and phpmyadmin and run this command on your database

REPAIR TABLE smf_log_online;
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Ieazo

Quote from: Illori on January 16, 2012, 03:35:58 PM
Quote from: Illori on December 23, 2011, 06:13:00 AM
also dont use this thread for support please open a separate thread in the correct support board for support

My apologies, I panicked.

Advertisement: