News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

repair_settings.php help

Started by asduskun, March 20, 2011, 01:28:30 PM

Previous topic - Next topic

asduskun

hi all

i moved my hosting to x10hosting and i knew that i have to run repair settings for that but when i run that i get the following errors what is wrong?

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/usr/export/www/vhosts/funnetwork/hosting/asduskun/Sources) is not within the allowed path(s): (/home/:/tmp) in /home/asduskun/public_html/Settings.php on line 63

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/usr/export/www/vhosts/funnetwork/hosting/asduskun/cache) is not within the allowed path(s): (/home/:/tmp) in /home/asduskun/public_html/Settings.php on line 65

redone

I would suggest opening a support ticket with your host first.

~RedOne

asduskun


asduskun


Arantor

Not really, no, it's a configuration issue - but in any case most people aren't here to sit and wait for new posts, so expecting a reply within 10 minutes from a volunteer-run community is a bit much...

asduskun

i saw that i have forgotten to upload sources folder into my new host now i have done so and i just get this error below, is there something wrong with the cache file?

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/usr/export/www/vhosts/funnetwork/hosting/asduskun/cache) is not within the allowed path(s): (/home/:/tmp) in /home/asduskun/public_html/Settings.php on line 65

asduskun

I asked about this problem to my hosting support and thEY suggested me to ask this on smf support, so can anybody help?

Arantor

OK, so did you use repair-settings.php to fix all the paths? The error seems to suggest it's trying to access files outside your user area.

MrPhil

Since your SMF installation is under /home/asduskun/public_html/, what are you doing messing in /usr/export/www/vhosts/funnetwork/hosting/asduskun/? Was that where your previous installation was? Look in Settings.php to see if for some reason you have $boarddir hardcoded to that path, rather than

$boarddir = dirname(__FILE__); # The absolute path to the forum's folder. (not just '.'!)
$sourcedir = dirname(__FILE__) . '/Sources'; # Path to the Sources directory.

(This is SMF 1.1.12; I don't know if SMF 2.0 is different). Could you have been hacked at some point?

CapadY

The last errormessage is about the path to the cache diretory.
Repair_settings don't affect that path, so you have to edit it manually in settings.php
Please, don't PM me for support unless invited.
If you don't understand this, you will be blacklisted.

asduskun

Quote from: capady on March 21, 2011, 03:23:42 PM
The last errormessage is about the path to the cache diretory.
Repair_settings don't affect that path, so you have to edit it manually in settings.php

yes but how?i don t know how to do that! by the way i haven t install my forum firstly on this hosting, x10hosting, it was installed on byethost at first then i moved my hosting to funpic.de and lastly i moved all my forum files to my current host from funpic and uploaded all the stuff into public_html... and my cache folder is also there, but how comes the repair_settings.php doesn t see that, if it doesn t see cache folder it can t see the other folders as well but it doesn t give an error for other folders, by the way there are two more folders  within public_html, they are asduskun and cgi-bin and i don t have any idea about what they are for.... and following is my settings folder please help me

<?php
/**********************************************************************************
* Settings.php                                                                    *
***********************************************************************************
* SMF: Simple Machines Forum                                                      *
* Open-Source Project Inspired by Zef Hemel ([email protected])                    *
* =============================================================================== *
* Software Version:           SMF 2.0 RC2                                         *
* Software by:                Simple Machines (http://www.simplemachines.org)     *
* Copyright 2006-2009 by:     Simple Machines LLC (http://www.simplemachines.org) *
*           2001-2006 by:     Lewis Media (http://www.lewismedia.com)             *
* Support, News, Updates at:  http://www.simplemachines.org                       *
***********************************************************************************
* This program is free software; you may redistribute it and/or modify it under   *
* the terms of the provided license as published by Simple Machines LLC.          *
*                                                                                 *
* This program is distributed in the hope that it is and will be useful, but      *
* WITHOUT ANY WARRANTIES; without even any implied warranty of MERCHANTABILITY    *
* or FITNESS FOR A PARTICULAR PURPOSE.                                            *
*                                                                                 *
* See the "license.txt" file for details of the Simple Machines license.          *
* The latest version can always be found at http://www.simplemachines.org.        *
**********************************************************************************/

########## Maintenance ##########
# Note: If $maintenance is set to 2, the forum will be unusable!  Change it to 0 to fix it.
$maintenance '0'; # Set to 1 to enable Maintenance Mode, 2 to make the forum untouchable. (you'll have to make it 0 again manually!)
$mtitle ''; # Title for the Maintenance Mode message.
$mmessage ''; # Description of why the forum is in maintenance mode.

########## Forum Info ##########
$mbname 'JUST COMMUNICATE!'; # The name of your forum.
$language 'english'; # The default language file set for the forum.
$boardurl 'http://asduskun.x10.mx'; # URL to your forum's folder. (without the trailing /!)
$webmaster_email '*********'; # Email address to send emails from. (like [email protected])
$cookiename 'SMFCookie11'; # Name of the cookie to set for authentication.

########## Database Info ##########
$db_type 'mysql';
$db_server 'localhost';
$db_name '********';
$db_user '*******';
$db_passwd '******';
$ssi_db_user '';
$ssi_db_passwd '';
$db_prefix 'smf_';
$db_persist '0';
$db_error_send 1;

########## Directories/Files ##########
# Note: These directories do not have to be changed unless you move things.
$boarddir '/home/asduskun/public_html'; # The absolute path to the forum's folder. (not just '.'!)
$sourcedir '/home/asduskun/public_html/Sources'; # Path to the Sources directory.
$cachedir '/usr/export/www/vhosts/funnetwork/hosting/asduskun/cache'; # Path to the cache directory.

########## Error-Catching ##########
# Note: You shouldn't touch these settings.
$db_last_error 1299960347;

# Make sure the paths are correct... at least try to fix them.
if (!file_exists($boarddir) && file_exists(dirname(__FILE__) . '/agreement.txt'))
$boarddir dirname(__FILE__);
if (!
file_exists($sourcedir) && file_exists($boarddir '/Sources'))
$sourcedir $boarddir '/Sources';
if (!
file_exists($cachedir) && file_exists($boarddir '/cache'))
$cachedir $boarddir '/cache';

$db_character_set 'utf8';
?>

Illori

this line needs to be changed
$cachedir = '/usr/export/www/vhosts/funnetwork/hosting/asduskun/cache'; # Path to the cache directory.

that is pointing to your old host.

asduskun

Quote from: Illori on March 21, 2011, 04:15:42 PM
this line needs to be changed
$cachedir = '/usr/export/www/vhosts/funnetwork/hosting/asduskun/cache'; # Path to the cache directory.

that is pointing to your old host.

will i change it to the folder directory to public_html directory of my current host or where else?

asduskun

thanks for all the replies it s ok now but why i see my forum like this now, what is missing with the files or folders? here s the link

http://asduskun.x10.mx/

Illori

looks like your theme files are missing or your path to your theme is incorrect.

CapadY

Path to theme files aren't affected by repair_settings either.

You'll have to edit them manualy via the forums OP-panel.
Please, don't PM me for support unless invited.
If you don't understand this, you will be blacklisted.

Illori

well the source looks correct from what i can see.... yet the theme is not loading which makes me think the files are missing or in the wrong spot.

<script type="text/javascript"><!-- // --><![CDATA[
var smf_theme_url = "http://asduskun.x10.mx/Themes/default";
var smf_default_theme_url = "http://asduskun.x10.mx/Themes/default";
var smf_images_url = "http://asduskun.x10.mx/Themes/default/images";
var smf_scripturl = "http://asduskun.x10.mx/index.php";

asduskun

#17
i just upgraded my forum to rc 5 if i run upgrade again would that solve the problem?

by the way i changed the theme and the result is the same, i just see an outline

Illori

running the upgrade again will not fix the issue, repair settings will attempt to repair the paths but if the files are missing that will not fix it. verify the files are in place for the default theme in the location quoted above.

asduskun

all the files are there but  i think the problem is i got my database from byethost that is my first database of smf forum and it was rc 2 then i move that database to funpic.de and then i upgraded to rc5 and lastly i moved my hosting to x10hosting and i tried to import the database of funpic into my new host but i could it gives error that includes CREATE TABLE statement and i decided to use my old database from byethost....so is this the problem causing this ?

by the way i asked my hosting why i can t import the databse and they told it musn t include create table command but i can t delete all create table commands in the database there are lots of.... so what do you think the problem is:?

Advertisement: