News:

SMF 2.1.1 has been released! Take it for a spin! Read more.

Main Menu

This error was generated by Mod_Security.

Started by NiceCarvings, October 01, 2013, 02:35:07 PM

Previous topic - Next topic

NiceCarvings

QuoteNot Acceptable!

An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

I'm getting this error everytime I try to do anything on my forum, except for just browse it. I can look around it fine, but if I  try to reply for anything I get that message above. I don't know what to do about it.

kat

Give your host a slap, to get them to disable it. Mod_security is the dumbest thing on the internet, bar none. ;)


live627


kat

It REALLY is silly.

When it's enabled, I often can't even tell people I'm from Essex, coz it has "sex" in it.

It's that stoopid.

If your host has it enabled, even disabling it in .htaccess won't cure it, unfortunately.

Might be worth trying, though.

Cyberhost

Put this code to your .htaccess

<IfModule mod_security.c>
# Turn off mod_security filtering.  SMF is a big boy, it does not need its hands held.
SecFilterEngine Off

# The below probably isn't needed, but better safe than sorry.
SecFilterScanPOST Off
</IfModule>


If the site is white blank. Don't worry just delete the code and contact your host to disable mod_security

Bigguy

Any good host should be able to disable mod_security on a per site basis.

Advertisement: